Bug 1019875 - Title of element does not reflect an element type
Title of element does not reflect an element type
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER5
: 6.0.0
Assigned To: Tihomir Surdilovic
Sona Mala
: TestBlocker
Depends On:
Blocks: 1019885
  Show dependency treegraph
 
Reported: 2013-10-16 10:37 EDT by Sona Mala
Modified: 2014-08-06 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Title for User Task - screenshot (10.41 KB, image/png)
2013-10-16 10:38 EDT, Sona Mala
no flags Details
Title for None Task - screenshot (9.65 KB, image/png)
2013-10-16 10:38 EDT, Sona Mala
no flags Details
Title for Start Event- screenshot (13.40 KB, image/png)
2013-10-16 10:40 EDT, Sona Mala
no flags Details
Title for Error Start Event- screenshot (13.46 KB, image/png)
2013-10-16 10:40 EDT, Sona Mala
no flags Details
Title for Error End Event- screenshot (10.58 KB, image/png)
2013-10-16 10:42 EDT, Sona Mala
no flags Details
Title for End Event- screenshot (10.49 KB, image/png)
2013-10-16 10:43 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-10-16 10:37:57 EDT
Description of problem:
If you change type of task from None task to User task then the title is is still same.

User is able to recognize Start Event and Message Start Event but not Message Start Event and Message End Event.

See attached screenshots.

Expected results:
Use an unique identifier for each type of element.
Comment 1 Sona Mala 2013-10-16 10:38:29 EDT
Created attachment 812966 [details]
Title for User Task - screenshot
Comment 2 Sona Mala 2013-10-16 10:38:52 EDT
Created attachment 812968 [details]
Title for None Task - screenshot
Comment 3 Sona Mala 2013-10-16 10:40:08 EDT
Created attachment 812969 [details]
Title for Start Event- screenshot
Comment 4 Sona Mala 2013-10-16 10:40:37 EDT
Created attachment 812970 [details]
Title for Error Start Event- screenshot
Comment 5 Sona Mala 2013-10-16 10:42:39 EDT
Created attachment 812983 [details]
Title for Error End Event- screenshot
Comment 6 Sona Mala 2013-10-16 10:43:10 EDT
Created attachment 812984 [details]
Title for End Event- screenshot
Comment 8 Tihomir Surdilovic 2013-10-21 16:24:09 EDT
There was no easy way to fix this issue due to the addition of type-specific tasks in the stencil set. The titles are not dynamically reset on node creation so they do not change when the type changes (morphing). 

I have removed titles from svg nodes on the canvas (nodes + edges/sequence flows). I think this is the best thing to do to not confuse users at this time.

As far as iterating through the nodes on canvas for your tests. Using the title is probably a bad idea anyways. Designer exposes you with a JS api you can use to easily iterate over these..for example lets say you have designer loaded on the browser (designer-standalone lets say), you can do:

window.frames[2].ORYX.EDITOR._canvas.getChildren() to get a list of all children of the canvas (all nodes). Note that you might have to replace the "2" with another number depending if you are testing designer-standalone or kie-wb for example. Now you can iterate if you want with JS:


window.frames[2].ORYX.EDITOR._canvas.getChildren().each(function(child) {

alert(child._stencil.id();

});

the alert will give you the stencil set title of the node which is the best way of determining its type, for example it will give you:

- http://b3mn.org/stencilset/bpmn2.0#Task for tasks
- http://b3mn.org/stencilset/bpmn2.0#ParallelGateway for gateways etc

if you want a specific task type you can do for example:

child.properties["oryx-tasktype"]

which will give you for user task "User" as result..there are lots more things you can do with the Designer JS api but I hope this helps for now.
Comment 9 Marek Baluch 2013-11-27 16:37:55 EST
Verified on ER5.

Note You need to log in before you can comment on or make changes to this bug.