Bug 1019885 - New names in ShapeRepo broke other features
New names in ShapeRepo broke other features
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Tihomir Surdilovic
Sona Mala
:
Depends On: 1019869 1019875 1019883
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 10:59 EDT by Sona Mala
Modified: 2014-02-03 08:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-03 08:30:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shape Repository (302.17 KB, image/png)
2013-10-16 10:59 EDT, Sona Mala
no flags Details
Shape Repository (25.93 KB, image/png)
2013-10-16 11:26 EDT, Sona Mala
no flags Details
Video file - step to reproduce (2.82 MB, video/webm)
2013-10-16 11:27 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-10-16 10:59:26 EDT
Created attachment 812991 [details]
Shape Repository

Description of problem:
See attached screenshot. This is ShapeRepo for ER4. Please look at elements:
   - Tasks - None
   - Start Events - None
   - End Events - None

This is a code from 6.0.0.CR4/jbpm-designer-client/src/main/resources/org/jbpm/designer/public/stencilsets/bpmn2.0jbpm/stencildata/bpmn2.0jbpm.orig:

   - Start Event:
         "type":    "node",
         "id":      "StartNoneEvent",
         "title":   "None",
         "groups" : ["Start Events"],

   - Tasks:
         "type":   "node",
         "id":     "Task",
         "title":  "None",
         "groups": ["Tasks"],

   - End Event:
         "type" :  "node",
         "id":     "EndNoneEvent",
         "title":  "None",
         "groups": ["End Events"],

I like this solution but it broke:
   - attribute "title" for node on canvas:
       see https://bugzilla.redhat.com/show_bug.cgi?id=1019875
   - attribute "title" for Quick Shape Repo:
       see https://bugzilla.redhat.com/show_bug.cgi?id=1019869
   - a header of property bar:
       see https://bugzilla.redhat.com/show_bug.cgi?id=1019883


Version-Release number of selected component (if applicable):
6.0.0 ER4 BPMS

Steps to Reproduce:
1. Create process Start Event -> Task -> End Event
2. move mouse over each element in the process (Start | Task | End)
3. activate one element
4. move mouse over icon Task and End Event in Quick Shape Repo
5. open properties
6. activate each element in the process (Start | Task | End)
7. morph Start Event to Start Error Event
8. move mouse over this element
9. morph Task to User Task
10. move mouse over this element



Actual results:
step 2: title is "None" for all of them
step 4: titles of both icons are same ("None - Click or drag")
step 6: header of properties bar is "None" for all of them
step 8: title is "Error"
step 10: title is "None"
 


Expected results:
Please create a unique title for all nodes. I suggest "group - title" or "title group" for example "Task - None", "Start Event - None", "None Start Event", "User Task", etc. Use this title for all features like:
  - Quick Shape Repo ("None Task - click or drag", "None End Event - click or drag"
  - Title of element (<g ... title="title_format">)
  - Header of properties bar - "Properties (title_format)"

Additional info:
Comment 1 Sona Mala 2013-10-16 11:26:36 EDT
Created attachment 813007 [details]
Shape Repository
Comment 2 Sona Mala 2013-10-16 11:27:28 EDT
Created attachment 813008 [details]
Video file - step to reproduce
Comment 3 Rajesh Rajasekaran 2013-10-29 16:29:37 EDT
Increasing priority of 'TestBlocker' to 'high'
Comment 4 Tihomir Surdilovic 2013-11-01 17:03:54 EDT
Is this really needed for tests only because for users it makes more sense to keep it as it is, as each node is already grouped within the stencil set. Not sure if tests should drive usability. If tests really need this we could add alt text or some other indication in the html to help them, but we should IMO not change the usability for them.
Comment 5 Sona Mala 2013-11-04 04:41:50 EST
This issue just represents a cause of problems. I like this changes but the "depends on" issues should be resolved.

I welcome that the missing information will be presented on HTML level rather then on JS level.
Comment 6 Marek Baluch 2014-02-03 08:29:08 EST
We went over this issues and we believe that this BZ can safely be closed as NOT A BUG.

Note You need to log in before you can comment on or make changes to this bug.