Bug 101997 - max_loop should be set higher for mounting loopback devices
max_loop should be set higher for mounting loopback devices
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
: FutureFeature
: 102000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 14:53 EDT by Brian "netdragon" Bober
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:41:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2003-08-08 14:53:29 EDT
Description of problem:
Tried to mount all Redhat ISOs at the same time to mkisofs a DVD. I wish
max_loop was higher (maybe 16?). I guess you can only do 8. I don't understand
why the value has to be so low.

This is the script I made. It worked until I decided to also add the other two
doc isos besides the US docs:

    mkdir dvd-iso
    cd dvd-iso
    mkdir shrike-SRPMS-disc{1,2,3} shrike-i386-disc{1,2,3} shrike-docs-US
shrike-docs-EMEA shrike-docs-APAC

#Mount the ISO images using a loop device mount:

    mount -o ro,loop ../i386/shrike-SRPMS-disc1.iso shrike-SRPMS-disc1
    mount -o ro,loop ../i386/shrike-SRPMS-disc2.iso shrike-SRPMS-disc2
    mount -o ro,loop ../i386/shrike-SRPMS-disc3.iso shrike-SRPMS-disc3
    mount -o ro,loop ../i386/shrike-i386-disc1.iso shrike-i386-disc1
    mount -o ro,loop ../i386/shrike-i386-disc2.iso shrike-i386-disc2
    mount -o ro,loop ../i386/shrike-i386-disc3.iso shrike-i386-disc3
    mount -o ro,loop ../doc/shrike-docs-US.iso shrike-docs-US
    mount -o ro,loop ../doc/shrike-docs-EMEA.iso shrike-docs-EMEA
    mount -o ro,loop ../doc/shrike-docs-APAC.iso shrike-docs-APAC


#Copy the isolinux directory and the .discinfo from disc1 to the
#current directory:

    cp -a shrike-i386-disc1/isolinux shrike-i386-disc1/.discinfo .

#Edit the .discinfo

    head --lines=3 .discinfo > discinfo.tmp
    echo 1,2,3,4,5 >> discinfo.tmp
    tail --lines=3 .discinfo >> discinfo.tmp
    rm .discinfo
    mv discinfo.tmp .discinfo

# Create the ISO image
     mkisofs -o shrike-i386-dvd.iso \
      -b isolinux/isolinux.bin -c isolinux/boot.cat \
      -no-emul-boot -boot-load-size 4 -boot-info-table \
      -R -m TRANS.TBL \
      -x shrike-i386-disc1/.discinfo -x shrike-i386-disc1/isolinux \
      -graft-points shrike-i386-disc1 .discinfo=.discinfo isolinux/=isolinux \
      RedHat/=shrike-i386-disc2/RedHat RedHat/=shrike-i386-disc3/RedHat \
      SRPMS/=shrike-SRPMS-disc1/SRPMS SRPMS/=shrike-SRPMS-disc3/SRPMS \
      SRPMS/=shrike-SRPMS-disc2/SRPMS docs/US=shrike-docs-US \
      docs/APAC/=shrike-docs-APAC docs/EMEA/=shrike-docs-EMEA

# Show the MD5SUM
ls -l shrike-i386-dvd.iso
echo shrike-i386-dvd.iso installed into dvd-iso
echo Now run ./mkmediacheck.sh if you want to do a media check
cd ..
Comment 1 Brian "netdragon" Bober 2003-08-08 14:56:12 EDT
This is the error I get:

mount: could not find any free loop device
Comment 2 Brian "netdragon" Bober 2003-08-08 15:21:15 EDT
*** Bug 102000 has been marked as a duplicate of this bug. ***
Comment 3 Brian "netdragon" Bober 2003-08-08 15:23:09 EDT
I realize you can do:

rmmod loop
modprobe loop max_loop=255

But wouldn't it be nice if we didn't have to deal with this (and the uncertainty
that if other people try to do what you do they won't have loop as a separate
module) by increasint it to some reasonable number like 16? Is there a reason its 8?
Comment 4 Elliot Lee 2004-06-03 16:24:32 EDT
This seems like a request to have the kernel change the default number
of max_loop to 16.
Comment 5 Brian "netdragon" Bober 2004-06-03 23:10:43 EDT
16, or 256, whatever number would be reasonable as a default.
Comment 6 Bugzilla owner 2004-09-30 11:41:25 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.