Bug 102000 - max_loop should be set higher for mounting loopback devices
max_loop should be set higher for mounting loopback devices
Status: CLOSED DUPLICATE of bug 101997
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 15:19 EDT by Brian "netdragon" Bober
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian "netdragon" Bober 2003-08-08 15:19:21 EDT
Description of problem:
Tried to mount all Redhat ISOs at the same time to mkisofs a DVD. I wish
max_loop was higher (maybe 16?). I guess you can only do 8. I don't understand
why the value has to be so low.

This is the script I made. It worked until I decided to also add the other two
doc isos besides the US docs:

    mkdir dvd-iso
    cd dvd-iso
    mkdir shrike-SRPMS-disc{1,2,3} shrike-i386-disc{1,2,3} shrike-docs-US
shrike-docs-EMEA shrike-docs-APAC

#Mount the ISO images using a loop device mount:

    mount -o ro,loop ../i386/shrike-SRPMS-disc1.iso shrike-SRPMS-disc1
    mount -o ro,loop ../i386/shrike-SRPMS-disc2.iso shrike-SRPMS-disc2
    mount -o ro,loop ../i386/shrike-SRPMS-disc3.iso shrike-SRPMS-disc3
    mount -o ro,loop ../i386/shrike-i386-disc1.iso shrike-i386-disc1
    mount -o ro,loop ../i386/shrike-i386-disc2.iso shrike-i386-disc2
    mount -o ro,loop ../i386/shrike-i386-disc3.iso shrike-i386-disc3
    mount -o ro,loop ../doc/shrike-docs-US.iso shrike-docs-US
    mount -o ro,loop ../doc/shrike-docs-EMEA.iso shrike-docs-EMEA
    mount -o ro,loop ../doc/shrike-docs-APAC.iso shrike-docs-APAC


#Copy the isolinux directory and the .discinfo from disc1 to the
#current directory:

    cp -a shrike-i386-disc1/isolinux shrike-i386-disc1/.discinfo .

#Edit the .discinfo

    head --lines=3 .discinfo > discinfo.tmp
    echo 1,2,3,4,5 >> discinfo.tmp
    tail --lines=3 .discinfo >> discinfo.tmp
    rm .discinfo
    mv discinfo.tmp .discinfo

# Create the ISO image
     mkisofs -o shrike-i386-dvd.iso \
      -b isolinux/isolinux.bin -c isolinux/boot.cat \
      -no-emul-boot -boot-load-size 4 -boot-info-table \
      -R -m TRANS.TBL \
      -x shrike-i386-disc1/.discinfo -x shrike-i386-disc1/isolinux \
      -graft-points shrike-i386-disc1 .discinfo=.discinfo isolinux/=isolinux \
      RedHat/=shrike-i386-disc2/RedHat RedHat/=shrike-i386-disc3/RedHat \
      SRPMS/=shrike-SRPMS-disc1/SRPMS SRPMS/=shrike-SRPMS-disc3/SRPMS \
      SRPMS/=shrike-SRPMS-disc2/SRPMS docs/US=shrike-docs-US \
      docs/APAC/=shrike-docs-APAC docs/EMEA/=shrike-docs-EMEA

# Show the MD5SUM
ls -l shrike-i386-dvd.iso
echo shrike-i386-dvd.iso installed into dvd-iso
echo Now run ./mkmediacheck.sh if you want to do a media check
cd ..
Comment 1 Brian "netdragon" Bober 2003-08-08 15:21:09 EDT
Sorry, I got one of those annoying Netscape POSTDATA errors, and it wouldn't let
me back to the bug using the Back menu.When I went back, it made a new bug.

*** This bug has been marked as a duplicate of 101997 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.