Bug 1019977 - 'lmi' python namespace not properly registered
'lmi' python namespace not properly registered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openlmi-providers (Show other bugs)
20
noarch Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Radek Novacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 13:44 EDT by Stephen Gallagher
Modified: 2016-11-30 19:32 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 01:36:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2013-10-16 13:44:29 EDT
Description of problem:
After installing openlmi-python-base, the 'lmi' namespace is not properly installed. Other python packages that attempt to specify a requirement on this module in their setup.py files fail to find it on the system.

Version-Release number of selected component (if applicable):
openlmi-python-base-0.2.0-2.fc20.noarch

How reproducible:
Every time

Steps to Reproduce:
1. yum install openlmi-python-base
2. As root (or in a virtualenv created with --system-site-packages) run:
easy_install lmi

Actual results:

(virtualenv)[sgallagh@sgallagh520:virtualenv]$ easy_install lmi
Searching for lmi
Reading https://pypi.python.org/simple/lmi/
Couldn't find index page for 'lmi' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading https://pypi.python.org/simple/
No local packages or download links found for lmi
error: Could not find suitable distribution for Requirement.parse('lmi')


Expected results:
lmi 0.2.0 is already the active version in easy-install.pth

Additional info:
This is blocking the package review for openlmi-scripts
Comment 1 Michal Minar 2013-10-17 01:36:37 EDT
'lmi' you refer to is a python namespace package. Not the python egg downloadable from PyPi. All of OpenLMI python packages are named 'openlmi*'. The problem you refer to is probably caused by 'openlmi-tools' packages which has wrong requires in its egg metadata. It depends on 'lmi' instead of 'openlmi'. This causes any other package installed either to system or user directory to search for 'lmi' dependency which does not exist. This is already fixed in upstream.

I'll open corresponding bug on openlmi-tools.
Comment 2 Michal Minar 2013-10-17 04:10:28 EDT
I've opened the bug bz#1020166 on openlmi-tools instead.

Note You need to log in before you can comment on or make changes to this bug.