Bug 1020101 - 'dnf grouplist' throws NameError
'dnf grouplist' throws NameError
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
: 1024794 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 22:24 EDT by Luke Macken
Modified: 2016-09-19 22:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: hawkey-0.4.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 19:39:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2013-10-16 22:24:34 EDT
Description of problem:

`dnf group list` works as expected, but `dnf grouplist` throws the following exception:

$ sudo dnf grouplist                                                                                             
Setting up Group Process                                                                                            
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1305, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 873, in doCommand
    return self.base.returnGroupSummary(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 832, in returnGroupSummary
    installed, available = self.group_lists(uservisible, patterns)
NameError: global name 'patterns' is not defined

Version-Release number of selected component (if applicable):

dnf-0.4.4-1.fc20.noarch
Comment 1 Ales Kozumplik 2013-10-18 05:03:01 EDT
Thanks for reporting this here, Luke. I'll take a look.
Comment 2 Ales Kozumplik 2013-10-23 03:28:56 EDT
Fixed by 5de35d5, will be included with dnf-0.4.6.
Comment 3 Fedora Update System 2013-10-30 06:09:06 EDT
dnf-0.4.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.6-1.fc20
Comment 4 Ales Kozumplik 2013-10-30 09:42:26 EDT
*** Bug 1024794 has been marked as a duplicate of this bug. ***
Comment 5 Joachim Backes 2013-10-30 10:01:24 EDT
(In reply to Fedora Update System from comment #3)
> dnf-0.4.6-1.fc20 has been submitted as an update for Fedora 20.
> https://admin.fedoraproject.org/updates/dnf-0.4.6-1.fc20

Thank you, works as expected :-)
Comment 6 Fedora Update System 2013-10-30 13:14:24 EDT
Package dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, hawkey-0.4.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.6-1.fc20 libsolv-0.4.0-1.gitd49d319.fc20 hawkey-0.4.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20333/libsolv-0.4.0-1.gitd49d319.fc20,hawkey-0.4.4-1.fc20,dnf-0.4.6-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-31 10:22:44 EDT
hawkey-0.4.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hawkey-0.4.4-1.fc20
Comment 8 Fedora Update System 2013-10-31 13:42:31 EDT
Package hawkey-0.4.4-1.fc20, dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, librepo-1.3.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.4.4-1.fc20 dnf-0.4.6-1.fc20 libsolv-0.4.0-1.gitd49d319.fc20 librepo-1.3.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20406/dnf-0.4.6-1.fc20,libsolv-0.4.0-1.gitd49d319.fc20,librepo-1.3.0-1.fc20,hawkey-0.4.4-1.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-11-11 19:39:38 EST
hawkey-0.4.4-1.fc20, dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, librepo-1.3.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.