Bug 1024794 - dnf grouplist exeption: "NameError: global name 'patterns' is not defined"
dnf grouplist exeption: "NameError: global name 'patterns' is not defined"
Status: CLOSED DUPLICATE of bug 1020101
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 09:00 EDT by Joachim Backes
Modified: 2013-10-30 09:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 09:42:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-10-30 09:00:31 EDT
Description of problem:

running "dnf grouplist" fails:
NameError: global name 'patterns' is not defined

Version-Release number of selected component (if applicable):
dnf-0.4.5-1.fc20.noarch

How reproducible:
always

Steps to Reproduce:
1.dnf grouplist
2.
3.

Actual results:
Setting up Group Process
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1305, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 873, in doCommand
    return self.base.returnGroupSummary(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 832, in returnGroupSummary
    installed, available = self.group_lists(uservisible, patterns)
NameError: global name 'patterns' is not defined


Expected results:
grouplist is shown

Additional info:
Comment 1 Ales Kozumplik 2013-10-30 09:42:26 EDT
Hello this is fixed in the dnf version that was released today. See bug 1020101.

*** This bug has been marked as a duplicate of bug 1020101 ***

Note You need to log in before you can comment on or make changes to this bug.