Bug 1020410 - cinder-backup service doesn't start on boot and missing from chkconfig --list
cinder-backup service doesn't start on boot and missing from chkconfig --list
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
x86_64 Linux
unspecified Severity high
: beta
: 4.0
Assigned To: Eric Harney
Yogev Rabl
storage
:
: 1025857 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-17 11:41 EDT by Haim
Modified: 2016-04-26 23:14 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
Cause: openstack-cinder-backup service init scripts were not added to chkconfig. Consequence: Cinder backup service were not able to be started. Fix: Add init scripts to chkconfig at install time in the package. Result: Cinder backup service now operates as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:29:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
eharney: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Haim 2013-10-17 11:41:05 EDT
Description of problem:

trying to create backup using cinder i'm failing as service is not started. 
started the service manually solves it, however, when trying to set it for next boot, i noticed its missing from chkconfig service list:

[root@cougar08 cougar08(keystone_admin)]# chkconfig --list | grep openstack 
openstack-cinder-api    0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-cinder-scheduler      0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-cinder-volume 0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-glance-api    0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-glance-registry       0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-glance-scrubber       0:off   1:off   2:off   3:off   4:off   5:off   6:off
openstack-keystone      0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-api      0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-cert     0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-compute  0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-conductor        0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-console  0:off   1:off   2:off   3:off   4:off   5:off   6:off
openstack-nova-consoleauth      0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-metadata-api     0:off   1:off   2:off   3:off   4:off   5:off   6:off
openstack-nova-network  0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-novncproxy       0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-scheduler        0:off   1:off   2:on    3:on    4:on    5:on    6:off
openstack-nova-xvpvncproxy      0:off   1:off   2:off   3:off   4:off   5:off   6:off
Comment 1 Eric Harney 2013-10-17 11:44:58 EDT
RPM spec only has:

    # Initial installation
    for svc in volume api scheduler; do
        /sbin/chkconfig --add openstack-cinder-$svc
    done
Comment 3 Eric Harney 2013-11-01 14:36:40 EDT
*** Bug 1025857 has been marked as a duplicate of this bug. ***
Comment 4 Yogev Rabl 2013-11-04 03:36:31 EST
verified: 

openstack-utils-2013.2-1.el6ost.noarch
openstack-cinder-2013.2-1.el6ost.noarch
Comment 7 errata-xmlrpc 2013-12-19 19:29:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.