Bug 1020497 - [RFE] able to sort/change the order of kickstart scripts
[RFE] able to sort/change the order of kickstart scripts
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
: FutureFeature, Triaged
: 516771 (view as bug list)
Depends On: 729775
Blocks: spacewalk-rfe space21
  Show dependency treegraph
 
Reported: 2013-10-17 14:59 EDT by Stephen Herr
Modified: 2014-03-04 08:08 EST (History)
8 users (show)

See Also:
Fixed In Version: spacewalk-java-2.1.58-1 spacewalk-branding-2.1.5-1 spacewalk-schema-2.1.21-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 729775
Environment:
Last Closed: 2014-03-04 08:07:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2013-10-17 14:59:18 EDT
+++ This bug was initially created as a clone of Bug #729775 +++

2) Nature Of Problem:
The order of Kickstart scripts can not be changed

3) Business Requirements Satisfied By Request:
Changing the order of the kickstart scripts, adding new ones not only at the end.

4) Functional Requirements That Are Not Presently Possible:
Be able to sort/change the order of kickstart scripts.

5) What Will Success Look Like:
Changing the order of kickstart scripts, newly added script can be moved before other scripts.
Comment 1 Stephen Herr 2013-10-17 15:05:07 EDT
Committing to Spacewalk master:
c821c7ee2d93635471930d5419a54494db34afb5

This update features a new page in the UI that allows you to order kickstart scripts as well as a new api method (kickstart.profile.orderScripts) that offers the same functionality.
Comment 2 Stephen Herr 2013-10-17 15:26:07 EDT
And commit:
c7917c0b99b5cfb253f20efac99a5eb8512f0910
Comment 3 Stephen Herr 2013-10-18 16:25:11 EDT
Fixing a bug and adding a unit test:
6c888d530ac6141d4b3cc30649fcf51a57d20995
Comment 4 Tomas Lestach 2013-11-19 11:21:22 EST
One more fix ...

spacewalk.git: 6ec20e9d412c8d325edf200c8db09589fe2d1d6a
Comment 5 Tomas Lestach 2013-11-29 04:48:45 EST
*** Bug 516771 has been marked as a duplicate of this bug. ***
Comment 6 Matej Kollar 2014-01-17 07:16:21 EST
Switching MODIFIED Spacewalk bugs to ON_QA before 2.1 release.
Comment 7 Matej Kollar 2014-03-04 08:07:29 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21
Comment 8 Matej Kollar 2014-03-04 08:08:49 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21

Note You need to log in before you can comment on or make changes to this bug.