Bug 516771 - [RFE] order of scripts in kickstart-profile can't be (re)organized
[RFE] order of scripts in kickstart-profile can't be (re)organized
Status: CLOSED DUPLICATE of bug 1020497
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
: FutureFeature, Reopened
Depends On:
Blocks: spacewalk-rfe
  Show dependency treegraph
 
Reported: 2009-08-11 09:20 EDT by Sandro Mathys
Modified: 2013-11-29 04:48 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-29 04:48:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2009-08-11 09:20:42 EDT
Description of problem:
In Systems > Kickstart > Profiles > Scripts (and the resulting kickstart-file), the scripts are sorted in the same order they are created. There should be up/down buttons to move the scripts around, since scripts may depend upon each other and therefore the right order is important. Right now, to change the order, one has to delete the scripts and re-add them in the correct order.

Version-Release number of selected component (if applicable):
# rpm -qa | grep spacewalk
spacewalk-search-0.6.11-1.el5
spacewalk-branding-0.6.8-1.el5
spacewalk-0.6.4-1.el5
spacewalk-html-0.6.19-1.el5
spacewalk-backend-0.6.30-1.el5
spacewalk-backend-config-files-0.6.30-1.el5
spacewalk-taskomatic-0.6.42-1.el5
spacewalk-schema-0.6.22-1.el5
rhn-org-httpd-ssl-key-pair-spacewalk-1.0-4
spacewalk-backend-xml-export-libs-0.6.30-1.el5
spacewalk-backend-package-push-server-0.6.30-1.el5
spacewalk-moon-0.6.19-1.el5
spacewalk-client-tools-0.0-1
spacewalk-java-config-0.6.42-1.el5
spacewalk-monitoring-0.6.7-1.el5
spacewalk-admin-0.6.3-1.el5
spacewalk-backend-server-0.6.30-1.el5
spacewalk-backend-app-0.6.30-1.el5
spacewalk-backend-iss-export-0.6.30-1.el5
spacewalk-backend-xp-0.6.30-1.el5
spacewalk-pxt-0.6.19-1.el5
spacewalk-cypress-0.6.19-1.el5
spacewalk-selinux-0.6.13-1.el5
spacewalk-java-lib-0.6.42-1.el5
spacewalk-backend-sql-0.6.30-1.el5
spacewalk-backend-xmlrpc-0.6.30-1.el5
spacewalk-backend-config-files-tool-0.6.30-1.el5
spacewalk-backend-iss-0.6.30-1.el5
spacewalk-base-0.6.19-1.el5
spacewalk-sniglets-0.6.19-1.el5
spacewalk-certs-tools-0.6.3-1.el5
spacewalk-doc-indexes-0.6.1-1.el5
spacewalk-config-0.6.13-1.el5
spacewalk-base-minimal-0.6.19-1.el5
spacewalk-backend-config-files-common-0.6.30-1.el5
spacewalk-backend-applet-0.6.30-1.el5
spacewalk-grail-0.6.19-1.el5
spacewalk-monitoring-selinux-0.6.12-1.el5
spacewalk-backend-tools-0.6.30-1.el5
spacewalk-java-0.6.42-1.el5
spacewalk-setup-0.6.21-1.el5


How reproducible:
Always

Steps to Reproduce:
1. Systems > Kickstart > Profiles > Scripts
2. add several kickstart scripts
  
Actual results:
Scripts are sorted by date they were added.

Expected results:
Scripts are sorted by date they were added and there's buttons to change the order.

Additional info:
Comment 1 Sandro Mathys 2009-11-19 04:05:21 EST
This ticket is also applicable to RHN Satellite 5.3.0.
Comment 2 Jan Pazdziora 2010-11-19 11:03:48 EST
Mass-moving to space13.
Comment 3 Miroslav Suchý 2011-04-11 03:32:22 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 4 Miroslav Suchý 2011-04-11 03:36:44 EDT
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.
Comment 5 Jan Pazdziora 2011-07-20 07:50:12 EDT
Aligning under space16.
Comment 6 Tomáš Kašpárek 2013-03-27 04:39:18 EDT
this feature already exists in spacewalk, you can sort kickstart profiles by their name,active state,kickstart distro and spacewalk managed status

commit: 5b88e84ef9c2101700433cbbf81e99383e855fa9
Comment 7 Milan Zazrivec 2013-03-27 05:04:55 EDT
What was meant in this report was to be able to specify order of scripts
in which they will be included into a kickstart.

This is being done in webui in:

    /rhn/kickstart/Scripts.do

The requested feature has not yet been implemented.
Comment 8 Tomas Lestach 2013-11-29 04:48:45 EST
This RFE has been implemented within Bug 1020497.

*** This bug has been marked as a duplicate of bug 1020497 ***

Note You need to log in before you can comment on or make changes to this bug.