Bug 102071 - rpmbuild should Require: gettext
rpmbuild should Require: gettext
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
: 102626 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-10 12:17 EDT by Dams
Modified: 2007-04-18 12:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 11:49:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-08-10 12:17:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
[anvil@gruyere ~]# rpmbuild --rebuild metacity-2.4.55-7.src.rpm
[SNIP]
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ /bin/rm -f /var/tmp/metacity-root/usr/lib/libmetacity-private.la
+ /usr/lib/rpm/redhat/find-lang.sh /var/tmp/metacity-root metacity
No translations found for metacity in /var/tmp/metacity-root
erreur: Mauvais status de sortie pour /var/tmp/rpm-tmp.88952 (%install)
Erreur de construction de RPM:
    Mauvais status de sortie pour /var/tmp/rpm-tmp.88952 (%install)
zsh: exit 1     rpmbuild --rebuild metacity-2.4.55-7.src.rpm

Please add 'BuildRequires:gettext' in spec file.

Version-Release number of selected component (if applicable):
metacity-2.4.55-7

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild metacity-2.4.55-7.src.rpm

Additional info:
Comment 1 Havoc Pennington 2003-10-03 18:25:12 EDT
Makes more sense to me to have rpmbuild require gettext, if find-lang.sh
requires it.

Opinions?
Comment 2 Jeremy Katz 2003-10-03 18:39:18 EDT
I tend to agree (if you think you should do it for gettext, why not for
glibc-devel, too?  where does it stop?)
Comment 3 Havoc Pennington 2003-10-04 01:43:02 EDT
Moving to add Requires: gettext to rpmbuild.
Comment 4 Havoc Pennington 2003-10-04 01:43:52 EDT
*** Bug 102626 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Johnson 2003-10-05 09:45:30 EDT
Both rpm-build and gettext are dependencies that are always
supposed to be present, like make or gcc. Adding a build
dependency to rpmbuild fixes nothing.

Reopen and assign to distribution if you wish to argue.
Comment 6 Ville Skyttä 2003-10-05 10:52:16 EDT
Unfortunately Bugzilla won't let me reopen this, but I'd like to argue that for
Fedora Core:

1) The list of "assumed present" packages must be published.
2) It's a packaging bug if a package doesn't build or the result doesn't work
   as expected because it doesn't list a build time dependency which is not in
   1) or not pulled in by other deps.

If gettext would for some reason not be in the list of assumed present packages,
either adding "BuildRequires: gettext" into the dependent packages or "Requires:
gettext" into rpm-build would satisfy the dep.  The former would perhaps
preferable because most packages build fine without gettext.
Comment 7 Dams 2003-10-05 11:16:02 EDT
I agree with Ville and i re-open the bug :o)

I must add that i saw some [fedora.us] packages (wxGTK, xine-lib..) rebuild
running %find_lang without gettext being installed.
Comment 8 Jeff Johnson 2003-10-09 11:49:57 EDT
I'd rather drop find-lang.sh (there's redhat-rpm-config)
than add Yet Another reuires for a script that is only
occaisionally (majority of packages don't care about
find-langs.sh).

The tradeoff is between the benefit, find-lang.sh
needs will be tracked through a rpm-build dependency,
and cost, each and every user will be forced to
install gettext.

I believe the cost out weighs the benefit, and I would rather
dump a rather trivial helper script than inflict another
dependency on all rpm-build users.

cpanflute has already been removed from rpm for this reason,
the cost of maintaining a perl dependency outweighed whatever benefit
there was in distributing a helper script.

Note You need to log in before you can comment on or make changes to this bug.