Bug 1020776 - file count limit not increasing relative to quota increase
file count limit not increasing relative to quota increase
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
: Reopened
: 1039847 (view as bug list)
Depends On: 979182 1039847
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 05:24 EDT by Ma xiaoqiang
Modified: 2017-03-08 12 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 979182
Environment:
Last Closed: 2014-01-20 09:36:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-10-18 05:24:24 EDT
this problem happen on puddle [2.0/2013-10-15.2]
+++ This bug was initially created as a clone of Bug #979182 +++

Description of problem:

https://www.openshift.com/content/ability-to-increase-file-count-limit#comment-31792

So I tested this recently and it's not increasing relative to the diskspace increase.  Looks like a regression as it did in the past.  

Test results:

[phpnew-sannam.rhcloud.com 51c266e35973ca79f70000ba]\> quota -s
Disk quotas for user 51c266e35973ca79f70000ba (uid 3718): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/EBSStore01-user_home01
                   1612       0   1024M             298       0   40000        

Sumanas-MacBook-Pro:OSApps sumana$ rhc cartridge-storage --show -a phpnew
RESULT:

PHP 5.3
-------
  Base Gear Storage:       1GB
  Additional Gear Storage: None


allocate more quota to the PHP cartridge:

Sumanas-MacBook-Pro:OSApps sumana$ rhc cartridge-storage php-5.3 --add 1GB -a phpnew
RESULT:
Success: additional storage space set to 1GB
Storage Info
------------
  Base Gear Storage:       1GB
  Additional Gear Storage: 1GB

[phpnew-sannam.rhcloud.com 51c266e35973ca79f70000ba]\> quota -s
Disk quotas for user 51c266e35973ca79f70000ba (uid 3718): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/EBSStore01-user_home01
                   1612       0   2048M             298       0   40000        




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Ravi Sankar on 2013-07-09 20:48:26 EDT ---

Fixed in https://github.com/openshift/origin-server/pull/3026.

Also test the fixer script 'rhc-fix-gear-filelimit' that will fix max file limit for all existing gears with additional storage (https://github.com/openshift/li/pull/1718).

--- Additional comment from openshift-github-bot on 2013-07-10 00:20:12 EDT ---

Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/23311711512886dde576ccc0d1e07a3d5c73f661
Merge pull request #1718 from pravisankar/dev/ravi/bug979182

Merged by openshift-bot

--- Additional comment from openshift-github-bot on 2013-07-10 00:20:17 EDT ---

Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/808a4f6e7aa232981b4d7de78d56124e52c4d409
Bug 979182 - Increase file limit for the gear in proportion to the filesystem storage.

https://github.com/openshift/origin-server/commit/75ca64edbd9dcbe699318f69b6182b67acc4e60e
Merge pull request #3026 from pravisankar/dev/ravi/bug979182

Merged by openshift-bot

--- Additional comment from Hou Jianwei on 2013-07-10 03:47:52 EDT ---

Tested this feature on devenv_3473, the file limit increased properly

Before adding quota(5G)
[d1-jhou.dev.rhcloud.com b514fd52e93111e29e2422000aa42526]\> quota -s
Disk quotas for user b514fd52e93111e29e2422000aa42526 (uid 501): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     420       0   1024M             112       0   40000 

After adding quota(5G)       
[d1-jhou.dev.rhcloud.com b514fd52e93111e29e2422000aa42526]\> quota -s
Disk quotas for user b514fd52e93111e29e2422000aa42526 (uid 501): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     420       0   6144M             112       0    240k   

Also tested this fixer script, for the applications that have additional gear storage, the file limits didn't increase as exepcted

Before fix(On devenv_3271):
[app1-jhou.dev.rhcloud.com 578593102290071706402816]\> quota -s
Disk quotas for user 578593102290071706402816 (uid 503): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     944       0   6144M             273       0   40000  

Run the fix script:
[root@ip-10-141-152-11 bin]# ./rhc-fix-gear-filelimit 
Summary:: SUCCESS (total: 2, failed: 0)

After fix with rhc-fix-gear-filelimit, the file limit did not change.
[app1-jhou.dev.rhcloud.com 578593102290071706402816]\> quota -s
Disk quotas for user 578593102290071706402816 (uid 503): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     944       0   6144M             273       0   40000

--- Additional comment from Hou Jianwei on 2013-07-10 04:59:25 EDT ---

Sorry, for the fix script, should have tested it after the instance is upgraded to version >= devenv_3473.
Tested it after upgrading devevn-stage ami to lastest(devenv_3473), and the file limit issue is fixed.
This bug could be verified.

--- Additional comment from Hou Jianwei on 2013-07-10 21:59:49 EDT ---

Mark as verified according to comment 4 and comment 5
Comment 2 Cong Wei 2013-12-11 00:47:12 EST
*** Bug 1039847 has been marked as a duplicate of this bug. ***
Comment 3 Jason DeTiberus 2014-01-14 15:03:01 EST
The fix for this bug was pulled in during one of the rebases leading up to the 2.0 release.
Comment 4 Anping Li 2014-01-14 21:52:00 EST
I verified this bug. The file count limit is still not increasing .
The result is as below on puddle-2-0-2-2014-01-14.

[php53-huser1dom.oseanli.com 52d5ef2a190c68ac80000007]\> quota -s
Disk quotas for user 52d5ef2a190c68ac80000007 (uid 1000): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/vg_dhcp9137-lv_root
                   1008       0   2048M             245       0   80000        
[php53-huser1dom.oseanli.com 52d5ef2a190c68ac80000007]\> quota -s
Disk quotas for user 52d5ef2a190c68ac80000007 (uid 1000): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/vg_dhcp9137-lv_root
                   1008       0   4096M             245       0    160k
Comment 5 Anping Li 2014-01-14 23:55:26 EST
(In reply to Anping Li from comment #4)
> I verified this bug. The file count limit is still not increasing .
> The result is as below on puddle-2-0-2-2014-01-14.
> 
> [php53-huser1dom.oseanli.com 52d5ef2a190c68ac80000007]\> quota -s
> Disk quotas for user 52d5ef2a190c68ac80000007 (uid 1000): 
>      Filesystem  blocks   quota   limit   grace   files   quota   limit  
> grace
> /dev/mapper/vg_dhcp9137-lv_root
>                    1008       0   2048M             245       0   80000     
> 
> [php53-huser1dom.oseanli.com 52d5ef2a190c68ac80000007]\> quota -s
> Disk quotas for user 52d5ef2a190c68ac80000007 (uid 1000): 
>      Filesystem  blocks   quota   limit   grace   files   quota   limit  
> grace
> /dev/mapper/vg_dhcp9137-lv_root
>                    1008       0   4096M             245       0    160k

The limit is changed from 80000 to 160K. So the bug is fixed, and works fine. change states to verified.

Note You need to log in before you can comment on or make changes to this bug.