Bug 979182 - file count limit not increasing relative to quota increase
file count limit not increasing relative to quota increase
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Cesar Wong
libra bugs
: Reopened
Depends On:
Blocks: 1020776 1039847
  Show dependency treegraph
 
Reported: 2013-06-27 16:43 EDT by Sumana Annam
Modified: 2015-05-14 20:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1020776 1039847 (view as bug list)
Environment:
Last Closed: 2015-03-19 05:52:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sumana Annam 2013-06-27 16:43:14 EDT
Description of problem:

https://www.openshift.com/content/ability-to-increase-file-count-limit#comment-31792

So I tested this recently and it's not increasing relative to the diskspace increase.  Looks like a regression as it did in the past.  

Test results:

[phpnew-sannam.rhcloud.com 51c266e35973ca79f70000ba]\> quota -s
Disk quotas for user 51c266e35973ca79f70000ba (uid 3718): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/EBSStore01-user_home01
                   1612       0   1024M             298       0   40000        

Sumanas-MacBook-Pro:OSApps sumana$ rhc cartridge-storage --show -a phpnew
RESULT:

PHP 5.3
-------
  Base Gear Storage:       1GB
  Additional Gear Storage: None


allocate more quota to the PHP cartridge:

Sumanas-MacBook-Pro:OSApps sumana$ rhc cartridge-storage php-5.3 --add 1GB -a phpnew
RESULT:
Success: additional storage space set to 1GB
Storage Info
------------
  Base Gear Storage:       1GB
  Additional Gear Storage: 1GB

[phpnew-sannam.rhcloud.com 51c266e35973ca79f70000ba]\> quota -s
Disk quotas for user 51c266e35973ca79f70000ba (uid 3718): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
/dev/mapper/EBSStore01-user_home01
                   1612       0   2048M             298       0   40000        




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ravi Sankar 2013-07-09 20:48:26 EDT
Fixed in https://github.com/openshift/origin-server/pull/3026.

Also test the fixer script 'rhc-fix-gear-filelimit' that will fix max file limit for all existing gears with additional storage (https://github.com/openshift/li/pull/1718).
Comment 2 openshift-github-bot 2013-07-10 00:20:12 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/23311711512886dde576ccc0d1e07a3d5c73f661
Merge pull request #1718 from pravisankar/dev/ravi/bug979182

Merged by openshift-bot
Comment 3 openshift-github-bot 2013-07-10 00:20:17 EDT
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/808a4f6e7aa232981b4d7de78d56124e52c4d409
Bug 979182 - Increase file limit for the gear in proportion to the filesystem storage.

https://github.com/openshift/origin-server/commit/75ca64edbd9dcbe699318f69b6182b67acc4e60e
Merge pull request #3026 from pravisankar/dev/ravi/bug979182

Merged by openshift-bot
Comment 4 Jianwei Hou 2013-07-10 03:47:52 EDT
Tested this feature on devenv_3473, the file limit increased properly

Before adding quota(5G)
[d1-jhou.dev.rhcloud.com b514fd52e93111e29e2422000aa42526]\> quota -s
Disk quotas for user b514fd52e93111e29e2422000aa42526 (uid 501): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     420       0   1024M             112       0   40000 

After adding quota(5G)       
[d1-jhou.dev.rhcloud.com b514fd52e93111e29e2422000aa42526]\> quota -s
Disk quotas for user b514fd52e93111e29e2422000aa42526 (uid 501): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     420       0   6144M             112       0    240k   

Also tested this fixer script, for the applications that have additional gear storage, the file limits didn't increase as exepcted

Before fix(On devenv_3271):
[app1-jhou.dev.rhcloud.com 578593102290071706402816]\> quota -s
Disk quotas for user 578593102290071706402816 (uid 503): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     944       0   6144M             273       0   40000  

Run the fix script:
[root@ip-10-141-152-11 bin]# ./rhc-fix-gear-filelimit 
Summary:: SUCCESS (total: 2, failed: 0)

After fix with rhc-fix-gear-filelimit, the file limit did not change.
[app1-jhou.dev.rhcloud.com 578593102290071706402816]\> quota -s
Disk quotas for user 578593102290071706402816 (uid 503): 
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvde2     944       0   6144M             273       0   40000
Comment 5 Jianwei Hou 2013-07-10 04:59:25 EDT
Sorry, for the fix script, should have tested it after the instance is upgraded to version >= devenv_3473.
Tested it after upgrading devevn-stage ami to lastest(devenv_3473), and the file limit issue is fixed.
This bug could be verified.
Comment 6 Jianwei Hou 2013-07-10 21:59:49 EDT
Mark as verified according to comment 4 and comment 5
Comment 7 Oleg Fayans 2015-03-09 09:02:58 EDT
Reproduced again in the fresh devenv instance. AMI ID is ami-f04a1298
Comment 8 Cesar Wong 2015-03-17 13:27:19 EDT
I am not able to reproduce this problem. On a new devenv environment:

- Create app
[root@ip-10-154-250-123 ~]# rhc create-app phptest php-5.4

- Get initial quota
[root@ip-10-154-250-123 ~]# quota -s -u 550862cffa9e89f541000009
Disk quotas for user 550862cffa9e89f541000009 (uid 1000):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvda1    1012       0   1024M             221       0   80000

- Add storage
[root@ip-10-154-250-123 ~]# rhc cartridge-storage php-5.4 --add 1GB -a phptest
Set storage on cartridge ... set to 1GB

Storage Info
------------
  Base Gear Storage:       1GB
  Additional Gear Storage: 1GB

- Get quota after storage
[root@ip-10-154-250-123 ~]# quota -s -u 550862cffa9e89f541000009
Disk quotas for user 550862cffa9e89f541000009 (uid 1000):
     Filesystem  blocks   quota   limit   grace   files   quota   limit   grace
     /dev/xvda1    1012       0   2048M             221       0    160k
Comment 9 Cesar Wong 2015-03-17 13:29:42 EDT
Can you please include the steps you used to reproduce the bug and output from the quota command? Thx.
Comment 10 Oleg Fayans 2015-03-19 05:52:55 EDT
I was looking at the different column, sorry about that.

Note You need to log in before you can comment on or make changes to this bug.