Bug 1020903 - wxGTK 3.0 RC 1 has been released
wxGTK 3.0 RC 1 has been released
Status: CLOSED DUPLICATE of bug 682043
Product: Fedora
Classification: Fedora
Component: wxGTK (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 09:32 EDT by Jeremy Newton
Modified: 2013-10-18 10:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 09:40:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Newton 2013-10-18 09:32:49 EDT
wxGTK 3.0 RC 1 has been released and it should be considered to be updated in Rawhide.


Not a huge priority but there is a number of FOSS projects that either use 2.9 (which have been patched if in Fedora already) or are moving to 3.0 soon

This currently blocks a package update in RPMFusion, although I don't have an example of a blocking bug in Fedora, I would figure it's good to update this now, or be ready for when 3.0 proper comes out.

A combat-wxgtk28 maybe required
Comment 1 Dan Horák 2013-10-18 09:40:23 EDT

*** This bug has been marked as a duplicate of bug 682043 ***
Comment 2 Jeremy Newton 2013-10-18 09:50:10 EDT
Wait, how is this a duplicate of the 2.9 bug? 3.0 is not a development release...?
Comment 3 Jeremy Newton 2013-10-18 09:55:56 EDT
See the following links for details:

http://sourceforge.net/projects/wxwindows/files/3.0.0-rc1/

http://www.wxwidgets.org/
Comment 4 Dan Horák 2013-10-18 10:05:24 EDT
(In reply to Jeremy Newton from comment #2)
> Wait, how is this a duplicate of the 2.9 bug? 3.0 is not a development
> release...?

Is there any public promise of keeping API and ABI stability starting in the RC1?

I want to keep wxGTK on the 2.8 series as there are dozens of packages using it currently. Anybody is free to submit wxGTK3 as a new package for review, my capacity is already exhausted.
Comment 5 Dan Horák 2013-10-18 10:06:31 EDT
Also please read http://sharkcz.livejournal.com/11207.html
Comment 6 Jeremy Newton 2013-10-18 10:12:56 EDT
Fair enough, I'll open a package request
Comment 7 Jeremy Newton 2013-10-18 10:47:59 EDT
Moved to a package request:
https://bugzilla.redhat.com/show_bug.cgi?id=1020942

Thanks

Note You need to log in before you can comment on or make changes to this bug.