Bug 1020942 - Package Request: wxGTK3
Package Request: wxGTK3
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
: 1034133 1057696 1065138 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 10:44 EDT by Jeremy Newton
Modified: 2014-03-19 16:21 EDT (History)
12 users (show)

See Also:
Fixed In Version: wxGTK3-3.0.0-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-02 11:31:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
hobbes1069: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Jeremy Newton 2013-10-18 10:44:54 EDT
wxGTK 3.0 RC 1 has been released and it should be considered to be packaged in Rawhide.


Not a huge priority but there is a number of FOSS projects that either use 2.9 (which have been patched if in Fedora already) or are moving to 3.0 soon

This currently blocks a package update in RPMFusion, although I don't have an example of a blocking bug in Fedora, I would figure it's good to update this now, or be ready for when 3.0 proper comes out.

See this bug for additional details:

https://bugzilla.redhat.com/show_bug.cgi?id=1020903

Note that the maintainer of wxGTK has no interest in updating to/packaging wxGTK3
Comment 1 Dan Horák 2013-10-18 10:51:01 EDT
Package requests are for people actually submitting the packages for review, see https://fedoraproject.org/wiki/Package_Review_Process
Comment 2 Jeremy Newton 2013-10-18 12:18:08 EDT
Fair enough, it'll be a place holder until I'm ready to tackle it or if someone else has more time on their hands and want's to take it.

Thanks Dan
Comment 3 Dan Horák 2013-11-25 08:57:01 EST
*** Bug 1034133 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Newton 2014-01-06 22:27:55 EST
Ok I've decided to take this on:

SPEC
https://dl.dropboxusercontent.com/u/42480493/wxGTK3.spec

SRPM
https://dl.dropboxusercontent.com/u/42480493/wxGTK3-3.0.0-1.fc20.src.rpm


This should not have any file conflicts with wxGTK
The maintainer does not want to update to version 3, so this will have to make do, especially since 2.6.* support does not seem to compile/work. A compat package will likely be necessary anyway, so I see no issue with having this as a separate package.

rpmlint errors:
wxBase3.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxString -> stringing, string
wxBase3.x86_64: W: spelling-error %description -l en_US wxBase -> abase
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3/lgpl.txt
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3/gpl.txt
wxGTK3.src: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3.src: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3/gpl.txt
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3/lgpl.txt
wxGTK3-devel.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-devel.x86_64: W: no-documentation
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wxrc-3.0
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wx-config-3.0
wxGTK3-docs.noarch: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-gl.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-gl.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-gl.x86_64: W: no-documentation
wxGTK3-media.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-media.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-media.x86_64: W: no-documentation
8 packages and 0 specfiles checked; 4 errors, 17 warnings.

I'll contact upstream about the incorrect address errors
Comment 5 Christopher Meng 2014-01-06 22:34:01 EST
I have one question, I've read Dan's post in the last year about wxwidget 2.9.

So will wxGTK in repo be upgraded to 3.0 or create a new package named wxGTK3(I don't prefer the latter one IMO)

Thanks.
Comment 6 Jeremy Newton 2014-01-07 12:20:18 EST
Well the spec I posted is patched to not conflict with wxGTK, i.e. not upgrade the package.

But there's two paths we can choose:

- Add a compat-wxGTK28 package (if necessary) and change this to wxGTK to submit the SRPM as an update

OR

- Add this as is and keep the old wxGTK package

Either way, it's up to the maintainer of wxGTK (Dan Horák), as I personally don't care.

As well, if I recall correctly, I believe I spoke with Dan earlier and he does not wish to maintain 3.0. Personally, if this is the case, I wouldn't mind being added as a co-maintainer or as the new maintainer if he is not opposed to that. I just have no interest in maintaining a 3.0 EPEL 5 package.
Comment 7 Volker Fröhlich 2014-01-07 17:06:38 EST
I'll try to build saga 2.1. It requires wx > 2.8.
Comment 8 Volker Fröhlich 2014-01-08 17:46:26 EST
After replacing all occurences of wx-config with wx-config-3.0 saga built fine in Rawhide.
Comment 9 Michael Schwendt 2014-01-12 03:54:37 EST
Originally, "compat-" packages cannot be used as BuildRequires, because they don't ship a corresponding -devel subpackage but only the runtime libs. For compatibility with 3rd party software. Over time, there have been multiple packages which deviated from that naming scheme.

If the plan is to create multiple parallel-installable versions of wxWidgets/GTK+ that may be developed with, consider _not_ using a compat- prefix but a version postfix, such as wxGTK28. An example that follows that scheme properly is "yum list libpng\*".
Comment 10 Jeremy Newton 2014-01-12 11:55:33 EST
Fair enough, thanks for your input Michael. Though I would like to point out that some combat packages currently do have devel subpackages; I assume this is what you meant by deviating from the naming scheme.
None the less, would you suggest that wxgtk be renamed wxgtk2 (or whatever) and this be named wxgtk3?
Comment 11 Dan Horák 2014-01-13 04:57:02 EST
I prefer to keep wxGTK as is and add wxGTK3 with the new 3.x series. The renaming would bring unnecessary burden to all parties and had to still provide the development files under the same name as unlikely someone will test and fix the dozens of wxGTK consumers when switched to wxGTK3 during or before the next mass rebuild. I had a chat with Richard Shaw who is also interested in getting wxGTK3 into Fedora and we agreed that the new wxGTK3 packages should also switch to using the GTK3 toolkit. The main reason is to have a consistent user experience with the major desktop environments who are using GTK3. Richard already did some basic testing and it works.
Comment 12 Christopher Meng 2014-01-13 06:20:53 EST
Why can't we keep 2.8 as wxGTK28?
Comment 13 Richard Shaw 2014-01-13 09:03:51 EST
Here's my spec and srpm I developed based on Dan's 2.9 package. Feel free to use or abuse it as needed! :)

SPEC: https://dl.dropboxusercontent.com/u/34775202/wxGTK3.spec
SRPM: https://dl.dropboxusercontent.com/u/34775202/wxGTK3-3.0.0-1.fc19.src.rpm
Comment 14 Dan Horák 2014-01-24 10:58:04 EST
*** Bug 1057696 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Newton 2014-02-04 19:26:47 EST
Hi Richard! Are you interested in taking over this package? If you are, I'm happy to review this for you this, else wise I can take a look and adapt my spec file.
Comment 16 Richard Shaw 2014-02-07 15:11:27 EST
I need another package like I need a hole in the head but I will if no one else will :)

I'm pretty swamped right now at home and work but when I get a chance I'll diff the two specs and take what I like from both.

Right now I need to figure out (maybe you already have) what to do with wx-config. The 2.8 package owns that name so unless we want to do some "alternatives" magic, it will have to be wx-config-3.0 only and any package building against it may have to be patched to look for that name instead. (same for rc)
Comment 17 Richard Shaw 2014-02-09 09:20:29 EST
Ok, a couple of questions/differences about your spec...

1. You move the bakefiles but Dan's spec mentions that they're not supported and just deletes them.

2. I've got the compat26 option enabled right now... I'm not sure we need it since 2.8 should have this enabled...

3. I'm building against GTK3 instead of GTK2 but I'm assuming that's OK with you.

That seems to be the big stuff...
Comment 18 Jeremy Newton 2014-02-09 12:35:24 EST
(In reply to Richard Shaw from comment #17)
> Ok, a couple of questions/differences about your spec...
> 
> 1. You move the bakefiles but Dan's spec mentions that they're not supported
> and just deletes them.

Hmm that's a good question, because if I understand correctly those bakefiles are supported, but I'll remove them and re-add them if necessary in the future.

> 2. I've got the compat26 option enabled right now... I'm not sure we need it
> since 2.8 should have this enabled...

Agreed, plus this flag seems to cause an odd build fail on f20, so I've deemed this as a non-issue.

> 3. I'm building against GTK3 instead of GTK2 but I'm assuming that's OK with
> you.

I'll make this change, I've just been busy but I have some time today to finish this off so it can be reviewed.

As for the wx-config, I purpose that patching should be the method for the time being; if a more elegant solution is necessary, this issue can be re-approached.
Comment 19 Dan Horák 2014-02-10 02:56:17 EST
(In reply to Richard Shaw from comment #17)
> Ok, a couple of questions/differences about your spec...
> 
> 1. You move the bakefiles but Dan's spec mentions that they're not supported
> and just deletes them.

this seems to be being out-of-sync in the wxGTK3 spec, bakefiles are installed in the wxGTK2 spec for some time

> 2. I've got the compat26 option enabled right now... I'm not sure we need it
> since 2.8 should have this enabled...

IMHO the wxGTK3 package should be a clean wxGTK3 without enabling the wxGTK2 compat methods
 
> 3. I'm building against GTK3 instead of GTK2 but I'm assuming that's OK with
> you.
> 
> That seems to be the big stuff...

and as for wx-config using alternatives should work for switching between wxGTK2 and wxGTK3

and there is also a question of wxwin.m4 installed in /usr/share/aclocal in wxGTK2 package, but %excluded in wxGTK3, again the alternatives could do the work
Comment 20 Jeremy Newton 2014-02-10 16:01:54 EST
(In reply to Dan Horák from comment #19)
> (In reply to Richard Shaw from comment #17)
> > Ok, a couple of questions/differences about your spec...
> > 
> > 1. You move the bakefiles but Dan's spec mentions that they're not supported
> > and just deletes them.
> 
> this seems to be being out-of-sync in the wxGTK3 spec, bakefiles are
> installed in the wxGTK2 spec for some time

Would you suggest to include these then?

> > 2. I've got the compat26 option enabled right now... I'm not sure we need it
> > since 2.8 should have this enabled...
> 
> IMHO the wxGTK3 package should be a clean wxGTK3 without enabling the wxGTK2
> compat methods

Agreed, there is no need for overlap

> > 3. I'm building against GTK3 instead of GTK2 but I'm assuming that's OK with
> > you.
> > 
> > That seems to be the big stuff...
> 
> and as for wx-config using alternatives should work for switching between
> wxGTK2 and wxGTK3
> 
> and there is also a question of wxwin.m4 installed in /usr/share/aclocal in
> wxGTK2 package, but %excluded in wxGTK3, again the alternatives could do the
> work

Is there an advantage to using alternatives? Wouldn't patching be just fine? I would like to hear your feedback as I maybe missing something.
Also what is the value of wxwin.m4?
Comment 21 Jeremy Newton 2014-02-10 16:16:22 EST
My confusion mainly revolves around the fact that alternatives would imply that the same functionality is provided, but this is not the case.
From what I see, moving and patching is the correct way of doing this, though I will admit that I'm very unsure on this subject.

Would adding a conflict between the two devel packages also be out of the question?
Comment 22 Dan Horák 2014-02-10 16:38:57 EST
(In reply to Jeremy Newton from comment #21)
> My confusion mainly revolves around the fact that alternatives would imply
> that the same functionality is provided, but this is not the case.
> From what I see, moving and patching is the correct way of doing this,
> though I will admit that I'm very unsure on this subject.
> 
> Would adding a conflict between the two devel packages also be out of the
> question?

after thinking more about it I think using Conflicts is probably the way to go, the devel packages can't be made parallel installable with all functionality included (bakefiles, wx-config and wxwin.m4), all of these would have to versioned somehow and it doesn't seem to be feasible
Comment 23 Richard Shaw 2014-02-10 22:28:42 EST
Ok, I've updated my spec file based on the comments so far but I want to make sure it's not possible/practical to create a parallel installable devel package before we implement a Conflict with it.

The bakefiles can be moved (is there something that needs to be updated to point to the new location?)

wx-config can be renamed wx-config-3.0 OR we can see what it would take to create a wrapper that's not only multi-lib aware but version aware?

wxwin.m4 can be renamed, but like the bakefiles, is there anything that assumes it's location that can't be fixed at build time?
Comment 24 Jeremy Newton 2014-02-10 22:59:43 EST
(In reply to Dan Horák from comment #22)
> (In reply to Jeremy Newton from comment #21)
> > My confusion mainly revolves around the fact that alternatives would imply
> > that the same functionality is provided, but this is not the case.
> > From what I see, moving and patching is the correct way of doing this,
> > though I will admit that I'm very unsure on this subject.
> > 
> > Would adding a conflict between the two devel packages also be out of the
> > question?
> 
> after thinking more about it I think using Conflicts is probably the way to
> go, the devel packages can't be made parallel installable with all
> functionality included (bakefiles, wx-config and wxwin.m4), all of these
> would have to versioned somehow and it doesn't seem to be feasible

Agreed, this is a much more elegant solution

(In reply to Richard Shaw from comment #23)
> Ok, I've updated my spec file based on the comments so far but I want to
> make sure it's not possible/practical to create a parallel installable devel
> package before we implement a Conflict with it.
> 
> The bakefiles can be moved (is there something that needs to be updated to
> point to the new location?)
> 
> wx-config can be renamed wx-config-3.0 OR we can see what it would take to
> create a wrapper that's not only multi-lib aware but version aware?
> 
> wxwin.m4 can be renamed, but like the bakefiles, is there anything that
> assumes it's location that can't be fixed at build time?

Is there a reason a conflict should be avoided?

(In reply to Richard Shaw from comment #17)
> Ok, a couple of questions/differences about your spec...
> 
> 1. You move the bakefiles but Dan's spec mentions that they're not supported
> and just deletes them.
> 
> 2. I've got the compat26 option enabled right now... I'm not sure we need it
> since 2.8 should have this enabled...
> 
> 3. I'm building against GTK3 instead of GTK2 but I'm assuming that's OK with
> you.
> 
> That seems to be the big stuff...

It seems building with GTK3 causes a build failure for F20 (though it builds fine on F19):

https://dl.dropboxusercontent.com/u/42480493/build.log

Are you familiar with this build issue?
It appears to be wayland related. Are you sure Wxwidgets even supports gtk-3.10? I have a feeling it only supports up to 3.8, i.e. F19, due to recent major changes to the toolkit. I'll look more into it when I have some free time; a patch is likely in order.

Here's my source files as of now:
SPEC
https://dl.dropboxusercontent.com/u/42480493/wxGTK3.spec

SRPM
https://dl.dropboxusercontent.com/u/42480493/wxGTK3-3.0.0-2.fc20.src.rpm
Comment 25 Richard Shaw 2014-02-10 23:03:55 EST
(In reply to Jeremy Newton from comment #24)
> (In reply to Richard Shaw from comment #23)
> > Ok, I've updated my spec file based on the comments so far but I want to
> > make sure it's not possible/practical to create a parallel installable devel
> > package before we implement a Conflict with it.
> > 
> > The bakefiles can be moved (is there something that needs to be updated to
> > point to the new location?)
> > 
> > wx-config can be renamed wx-config-3.0 OR we can see what it would take to
> > create a wrapper that's not only multi-lib aware but version aware?
> > 
> > wxwin.m4 can be renamed, but like the bakefiles, is there anything that
> > assumes it's location that can't be fixed at build time?
> 
> Is there a reason a conflict should be avoided?

Well it should always be avoided if it's avoidable :) But in all seriousness... What if you need to be able to develop programs for both libraries outside of a mock build environment? Are you supposed to yum erase / yum install back and forth?

 
> It seems building with GTK3 causes a build failure for F20 (though it builds
> fine on F19):

Yes, I found a patch for it upstream and applied it. I'm getting good builds for rawhide in mock.
Comment 26 Jeremy Newton 2014-02-10 23:31:08 EST
(In reply to Richard Shaw from comment #25)
> (In reply to Jeremy Newton from comment #24)
> > (In reply to Richard Shaw from comment #23)
> > > Ok, I've updated my spec file based on the comments so far but I want to
> > > make sure it's not possible/practical to create a parallel installable devel
> > > package before we implement a Conflict with it.
> > > 
> > > The bakefiles can be moved (is there something that needs to be updated to
> > > point to the new location?)
> > > 
> > > wx-config can be renamed wx-config-3.0 OR we can see what it would take to
> > > create a wrapper that's not only multi-lib aware but version aware?
> > > 
> > > wxwin.m4 can be renamed, but like the bakefiles, is there anything that
> > > assumes it's location that can't be fixed at build time?
> > 
> > Is there a reason a conflict should be avoided?
> 
> Well it should always be avoided if it's avoidable :) But in all
> seriousness... What if you need to be able to develop programs for both
> libraries outside of a mock build environment? Are you supposed to yum erase
> / yum install back and forth?

Fair enough, i can revert what I did to make it compatible again
  
> > It seems building with GTK3 causes a build failure for F20 (though it builds
> > fine on F19):
> 
> Yes, I found a patch for it upstream and applied it. I'm getting good builds
> for rawhide in mock.

Do you have a link for this patch, so I can include it?
Comment 27 Richard Shaw 2014-02-11 23:12:23 EST
Ok, I did a mock install for a rawhide build of both wxGTK and my build of wxGTK3 without any conflicts so that's promising.

Here's my spec:
https://dl.dropboxusercontent.com/u/34775202/wxGTK3/wxGTK3.spec

Here's the path for the wayland issue:
https://dl.dropboxusercontent.com/u/34775202/wxGTK3/wxGTK3-3.0.0-gtk3_build.patch

And to make comparisons easier, here's a diff of the last spec you posted (I think) and my current spec:
https://dl.dropboxusercontent.com/u/34775202/wxGTK3/wxGTK3.diff
Comment 28 Dan Horák 2014-02-14 02:07:41 EST
*** Bug 1065138 has been marked as a duplicate of this bug. ***
Comment 29 Richard Shaw 2014-02-14 11:35:26 EST
I decided to see what it would take to build on epel 6 so here's a new spec with a few conditionals to make it work...

https://dl.dropboxusercontent.com/u/34775202/wxGTK3/wxGTK3.spec

Changes:
- Builds against GTK2 instead of GTK3 (most of the ugly conditionals)
- EPEL does not have gtkwebview.
Comment 30 Jeremy Newton 2014-02-17 10:45:35 EST
Thanks for the patch and the tips!

Just a few minor stylistic changes to make it a little cleaner.
Also I used %{?epl6} instead of %{?rhel} to be ready to support epel 7 (as it uses gtk3); note that I don't plan on supporting epel 5 or prior, as mentioned before.

Just to summarize, this package now supports:
F19, F20, rawhide/F21, epel 6, and ready for epel 7

Here's the new files:
SPEC
https://dl.dropboxusercontent.com/u/42480493/wxGTK3.spec

SRPM
https://dl.dropboxusercontent.com/u/42480493/wxGTK3-3.0.0-3.fc20.src.rpm
Comment 31 Richard Shaw 2014-02-17 10:58:39 EST
Either way works for me, I usually use the rhel definition because it's defined on epel but I doubt that's true in reverse.
Comment 32 Jeremy Newton 2014-02-17 11:13:54 EST
(In reply to Richard Shaw from comment #31)
> Either way works for me, I usually use the rhel definition because it's
> defined on epel but I doubt that's true in reverse.

Indeed, but this way I don't have to change it for epel 7

Are you able to give me a review by any chance?
Comment 33 Richard Shaw 2014-02-17 15:22:36 EST
Maybe today, maybe later this week. I ran fedora review on it and stepped away for a while. Now just a matter of checking and checking boxes.
Comment 34 Richard Shaw 2014-02-17 15:54:39 EST
Ok, one thing we need to fix, if you run rpmlint on the installed packages it finds a BUNCH of "unused-direct-shlib-dependency"

Which means:
$ rpmlint -I unused-direct-shlib-dependency
unused-direct-shlib-dependency:
The binary contains unused direct shared library dependencies.  This may
indicate gratuitously bloated linkage; check that the binary has been linked
with the intended shared libraries only.

If the build honors LDFLAGS then a quick solution is to use:
export LDFLAGS='-Wl,--as-needed"
just before configure.
Comment 35 Julian D 2014-02-18 14:08:34 EST
(In reply to Jeremy Newton from comment #30)
> Thanks for the patch and the tips!
> 
> Just a few minor stylistic changes to make it a little cleaner.
> Also I used %{?epl6} instead of %{?rhel} to be ready to support epel 7 (as
> it uses gtk3); note that I don't plan on supporting epel 5 or prior, as
> mentioned before.
> 
> Just to summarize, this package now supports:
> F19, F20, rawhide/F21, epel 6, and ready for epel 7
> 
> Here's the new files:
> SPEC
> https://dl.dropboxusercontent.com/u/42480493/wxGTK3.spec
> 
> SRPM
> https://dl.dropboxusercontent.com/u/42480493/wxGTK3-3.0.0-3.fc20.src.rpm

I just tried your package and stumbled upon the following problem:
in wx-config line 34: wxconfig=$libdir/wx/config/gtk2-unicode-$version 
will become wxconfig=$libdir/wx/config/gtk2-unicode-3.0 (for now) but the package creates "gtk3-unicode-3.0".... thereby the if-statement in line 40 will always fail. (Maybe I just screwed it while building the package ?)
Comment 36 Jeremy Newton 2014-02-19 21:13:27 EST
(In reply to Richard Shaw from comment #34)
> Ok, one thing we need to fix, if you run rpmlint on the installed packages
> it finds a BUNCH of "unused-direct-shlib-dependency"
> 
> Which means:
> $ rpmlint -I unused-direct-shlib-dependency
> unused-direct-shlib-dependency:
> The binary contains unused direct shared library dependencies.  This may
> indicate gratuitously bloated linkage; check that the binary has been linked
> with the intended shared libraries only.
> 
> If the build honors LDFLAGS then a quick solution is to use:
> export LDFLAGS='-Wl,--as-needed"
> just before configure.

Good catch, I must have missed this. I added the line, hopefully this fixes it; I haven't had time to build it yet.

(In reply to noobie from comment #35)
> I just tried your package and stumbled upon the following problem:
> in wx-config line 34: wxconfig=$libdir/wx/config/gtk2-unicode-$version 
> will become wxconfig=$libdir/wx/config/gtk2-unicode-3.0 (for now) but the
> package creates "gtk3-unicode-3.0".... thereby the if-statement in line 40
> will always fail. (Maybe I just screwed it while building the package ?)

No this is indeed a bug, thanks for catching this! :)

Here's the new files:
SPEC
https://dl.dropboxusercontent.com/u/42480493/wxGTK3.spec

SRPM
https://dl.dropboxusercontent.com/u/42480493/wxGTK3-3.0.0-4.fc20.src.rpm
Comment 37 Richard Shaw 2014-02-19 21:26:47 EST
Looks like a little type in the spec:

# likely still dereferences type-punned pointers
CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
# fix unused-direct-shlib-dependency error:
export LDFLAGS='-Wl,--as-needed"

Gotta stick with one type of quotes on the LDFLAGS line :)
Comment 38 Jeremy Newton 2014-02-19 21:40:44 EST
Whopps, thanks again ;)

I re-uploaded the files, same links.
Comment 39 Richard Shaw 2014-02-21 20:57:10 EST
Possible issues:

1. The note about large documentation. The docs are already a subpackage but
   perhaps the docs for wxBase3 are fairly large?
2. There are a lot of mixed licenses in here, all FOSS, but how should they be
   attributed?
3. Directories which are owned by other packages (i.e. wxGTK-devel, see below).
   I don't think this is a problem but would like to hear other opions.

Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package contains BR: python2-devel or python3-devel
  * The only python file is related to a bakefile, I don't think we need to BR python-devel.
- Large documentation must go in a -doc subpackage. Large could be size (~1MB)
  or number of files.
  Note: Documentation size is 161495040 bytes in 5307 files.
  See: http://fedoraproject.org/wiki/Packaging/Guidelines#PackageDocumentation


===== MUST items =====

C/C++:
[x]: Package does not contain kernel modules.
[x]: Package contains no static executables.
[x]: Header files in -devel subpackage, if present.
[x]: Package does not contain any libtool archives (.la)
[x]: Rpath absent or only used for internal libs.
[x]: Development (unversioned) .so files in -devel subpackage, if present.

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[?]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. Licenses found:
     "Public domain", "*No copyright* GPL (v2 or later) (with incorrect FSF
     address)", "GPL (v2 or later)", "Unknown or generated", "BSD (4 clause)",
     "MIT/X11 (BSD like)", "LGPL (v2 or later) (with incorrect FSF address)",
     "*No copyright* Public domain", "BSD (3 clause)", "BSD", "GPL (v2 or
     later) (with incorrect FSF address)", "libpng", "zlib/libpng". 4360 files
     have unknown license. Detailed output of licensecheck in /home/build
     /fedora-review/1020942-wxGTK3/licensecheck.txt
[x]: License file installed when any subpackage combination is installed.
[?]: Package must own all directories that it creates.
     Note: Directories without known owners: /usr/share/bakefile,
     /usr/share/bakefile/presets
     * These are owned by the bakefile package, not sure if the bakefile
       package should be pulled in or not.
[x]: Package does not own files or directories owned by other packages.
     Note: Dirs in package are owned also by: /usr/lib64/wx/config(wxGTK-
     devel), /usr/lib64/wx(wxGTK-devel), /usr/lib64/wx/include(wxGTK-devel)
     * I don't think wxGTK and wxGTK3 co-owning these is a problem.
[x]: %build honors applicable compiler flags or justifies otherwise.
[x]: Package contains no bundled libraries without FPC exception.
[x]: Changelog in prescribed format.
[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: The spec file handles locales properly.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Useful -debuginfo package or justification otherwise.
[x]: Package is not known to require an ExcludeArch tag.
[x]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Package installs properly.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

Python:
[-]: Python eggs must not download any dependencies during the build process.
[-]: A package which is used by another package via an egg interface should
     provide egg info.
[-]: Package meets the Packaging Guidelines::Python
[-]: Binary eggs must be removed in %prep

===== SHOULD items =====

Generic:
[-]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[x]: Fully versioned dependency in subpackages if applicable.
     Note: No Requires: %{name}%{?_isa} = %{version}-%{release} in wxBase3
     * This sub-package can probably be installed by itself, though I'm not
       sure if that's useful or not.
[x]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[x]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: Scriptlets must be sane, if used.
[-]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: %check is present and all tests pass.
[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: Uses parallel make %{?_smp_mflags} macro.
[x]: SourceX is a working URL.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[?]: Large data in /usr/share should live in a noarch subpackage if package is
     arched.
     Note: Arch-ed rpms have a total of 3246080 bytes in /usr/share
[x]: Rpmlint is run on all installed packages.
     Note: There are rpmlint messages (see attachment).
[x]: Spec file according to URL is the same as in SRPM.


Rpmlint
-------
Checking: wxGTK3-3.0.0-4.fc19.x86_64.rpm
          wxGTK3-devel-3.0.0-4.fc19.x86_64.rpm
          wxGTK3-gl-3.0.0-4.fc19.x86_64.rpm
          wxGTK3-media-3.0.0-4.fc19.x86_64.rpm
          wxBase3-3.0.0-4.fc19.x86_64.rpm
          wxGTK3-docs-3.0.0-4.fc19.noarch.rpm
          wxGTK3-3.0.0-4.fc19.src.rpm
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3-3.0.0/lgpl.txt
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3-3.0.0/gpl.txt
wxGTK3-devel.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-devel.x86_64: W: no-documentation
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wxrc-3.0
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wx-config-3.0
wxGTK3-gl.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-gl.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-gl.x86_64: W: no-documentation
wxGTK3-media.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-media.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-media.x86_64: W: no-documentation
wxBase3.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxString -> stringing, string
wxBase3.x86_64: W: spelling-error %description -l en_US wxBase -> abase
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3-3.0.0/lgpl.txt
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3-3.0.0/gpl.txt
wxGTK3-docs.noarch: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3.src: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3.src: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3.src:24: W: mixed-use-of-spaces-and-tabs (spaces: line 12, tab: line 24)
7 packages and 0 specfiles checked; 4 errors, 18 warnings.




Rpmlint (installed packages)
----------------------------
# rpmlint wxGTK3 wxGTK3-media wxGTK3-gl wxBase3 wxGTK3-devel wxGT 
K3-docs
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3-3.0.0/lgpl.txt
wxGTK3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxGTK3-3.0.0/gpl.txt
wxGTK3-media.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-media.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-media.x86_64: W: no-documentation
wxGTK3-gl.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxGTK3-gl.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-gl.x86_64: W: no-documentation
wxBase3.x86_64: W: spelling-error Summary(en_US) wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxBase3.x86_64: W: spelling-error %description -l en_US wxString -> stringing, string
wxBase3.x86_64: W: spelling-error %description -l en_US wxBase -> abase
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3-3.0.0/lgpl.txt
wxBase3.x86_64: E: incorrect-fsf-address /usr/share/doc/wxBase3-3.0.0/gpl.txt
wxGTK3-devel.x86_64: W: spelling-error %description -l en_US wxWidgets -> widgets
wxGTK3-devel.x86_64: W: no-documentation
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wxrc-3.0
wxGTK3-devel.x86_64: W: no-manual-page-for-binary wx-config-3.0
wxGTK3-docs.noarch: W: spelling-error %description -l en_US wxWidgets -> widgets
6 packages and 0 specfiles checked; 4 errors, 15 warnings.
# echo 'rpmlint-done:'



Requires
--------
wxGTK3 (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libSDL-1.2.so.0()(64bit)
    libSM.so.6()(64bit)
    libX11.so.6()(64bit)
    libXxf86vm.so.1()(64bit)
    libc.so.6()(64bit)
    libcairo.so.2()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libgdk-3.so.0()(64bit)
    libgdk_pixbuf-2.0.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libjpeg.so.62()(64bit)
    libjpeg.so.62(LIBJPEG_6.2)(64bit)
    libm.so.6()(64bit)
    libmspack.so.0()(64bit)
    libpango-1.0.so.0()(64bit)
    libpangocairo-1.0.so.0()(64bit)
    libpng15.so.15()(64bit)
    libpng15.so.15(PNG15_0)(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libtiff.so.5()(64bit)
    libtiff.so.5(LIBTIFF_4.0)(64bit)
    libwebkitgtk-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libwx_baseu_xml-3.0.so.0()(64bit)
    libwx_baseu_xml-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_adv-3.0.so.0()(64bit)
    libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_core-3.0.so.0()(64bit)
    libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_html-3.0.so.0()(64bit)
    libwx_gtk3u_html-3.0.so.0(WXU_3.0)(64bit)
    rtld(GNU_HASH)
    wxBase3(x86-64)

wxGTK3-media (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libc.so.6()(64bit)
    libcairo.so.2()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libgdk-3.so.0()(64bit)
    libglib-2.0.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgstinterfaces-0.10.so.0()(64bit)
    libgstreamer-0.10.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_core-3.0.so.0()(64bit)
    libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
    rtld(GNU_HASH)
    wxGTK3(x86-64)

wxGTK3-gl (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    libGL.so.1()(64bit)
    libX11.so.6()(64bit)
    libc.so.6()(64bit)
    libcairo.so.2()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libgdk-3.so.0()(64bit)
    libgobject-2.0.so.0()(64bit)
    libgtk-3.so.0()(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_core-3.0.so.0()(64bit)
    libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
    rtld(GNU_HASH)
    wxGTK3(x86-64)

wxBase3 (rpmlib, GLIBC filtered):
    /sbin/ldconfig
    ld-linux-x86-64.so.2()(64bit)
    libc.so.6()(64bit)
    libdl.so.2()(64bit)
    libexpat.so.1()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libm.so.6()(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libstdc++.so.6(CXXABI_1.3.2)(64bit)
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libz.so.1()(64bit)
    rtld(GNU_HASH)

wxGTK3-devel (rpmlib, GLIBC filtered):
    /bin/sh
    gtk3-devel
    libGLU-devel
    libc.so.6()(64bit)
    libgcc_s.so.1()(64bit)
    libgcc_s.so.1(GCC_3.0)(64bit)
    libpthread.so.0()(64bit)
    libstdc++.so.6()(64bit)
    libstdc++.so.6(CXXABI_1.3)(64bit)
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libwx_baseu_net-3.0.so.0()(64bit)
    libwx_baseu_xml-3.0.so.0()(64bit)
    libwx_baseu_xml-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_adv-3.0.so.0()(64bit)
    libwx_gtk3u_aui-3.0.so.0()(64bit)
    libwx_gtk3u_core-3.0.so.0()(64bit)
    libwx_gtk3u_gl-3.0.so.0()(64bit)
    libwx_gtk3u_html-3.0.so.0()(64bit)
    libwx_gtk3u_media-3.0.so.0()(64bit)
    libwx_gtk3u_propgrid-3.0.so.0()(64bit)
    libwx_gtk3u_qa-3.0.so.0()(64bit)
    libwx_gtk3u_ribbon-3.0.so.0()(64bit)
    libwx_gtk3u_richtext-3.0.so.0()(64bit)
    libwx_gtk3u_stc-3.0.so.0()(64bit)
    libwx_gtk3u_webview-3.0.so.0()(64bit)
    libwx_gtk3u_xrc-3.0.so.0()(64bit)
    rtld(GNU_HASH)
    wxBase3
    wxGTK3(x86-64)
    wxGTK3-gl
    wxGTK3-media

wxGTK3-docs (rpmlib, GLIBC filtered):
    wxGTK3(x86-64)



Provides
--------
wxGTK3:
    libwx_gtk3u_adv-3.0.so.0()(64bit)
    libwx_gtk3u_adv-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_aui-3.0.so.0()(64bit)
    libwx_gtk3u_aui-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_core-3.0.so.0()(64bit)
    libwx_gtk3u_core-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_html-3.0.so.0()(64bit)
    libwx_gtk3u_html-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_propgrid-3.0.so.0()(64bit)
    libwx_gtk3u_propgrid-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_qa-3.0.so.0()(64bit)
    libwx_gtk3u_qa-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_ribbon-3.0.so.0()(64bit)
    libwx_gtk3u_ribbon-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_richtext-3.0.so.0()(64bit)
    libwx_gtk3u_richtext-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_stc-3.0.so.0()(64bit)
    libwx_gtk3u_stc-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_webview-3.0.so.0()(64bit)
    libwx_gtk3u_webview-3.0.so.0(WXU_3.0)(64bit)
    libwx_gtk3u_xrc-3.0.so.0()(64bit)
    libwx_gtk3u_xrc-3.0.so.0(WXU_3.0)(64bit)
    wxGTK3
    wxGTK3(x86-64)
    wxWidgets

wxGTK3-media:
    libwx_gtk3u_media-3.0.so.0()(64bit)
    libwx_gtk3u_media-3.0.so.0(WXU_3.0)(64bit)
    wxGTK3-media
    wxGTK3-media(x86-64)

wxGTK3-gl:
    libwx_gtk3u_gl-3.0.so.0()(64bit)
    libwx_gtk3u_gl-3.0.so.0(WXU_3.0)(64bit)
    wxGTK3-gl
    wxGTK3-gl(x86-64)

wxBase3:
    libwx_baseu-3.0.so.0()(64bit)
    libwx_baseu-3.0.so.0(WXU_3.0)(64bit)
    libwx_baseu_net-3.0.so.0()(64bit)
    libwx_baseu_net-3.0.so.0(WXU_3.0)(64bit)
    libwx_baseu_xml-3.0.so.0()(64bit)
    libwx_baseu_xml-3.0.so.0(WXU_3.0)(64bit)
    wxBase3
    wxBase3(x86-64)

wxGTK3-devel:
    wxGTK3-devel
    wxGTK3-devel(x86-64)
    wxWidgets-devel
    wxrc(WXU_3.0)(64bit)

wxGTK3-docs:
    wxGTK3-docs
    wxWidgets-docs



Source checksums
----------------
http://downloads.sf.net/wxwindows/wxWidgets-3.0.0.tar.bz2 :
  CHECKSUM(SHA256) this package     : ff340539bcb6e45d8dbce848d3c13ebce34da6ffb9004a0a88e9541bec45bf85
  CHECKSUM(SHA256) upstream package : ff340539bcb6e45d8dbce848d3c13ebce34da6ffb9004a0a88e9541bec45bf85
http://downloads.sf.net/wxwindows/wxWidgets-3.0.0-docs-html.tar.bz2 :
  CHECKSUM(SHA256) this package     : fbdd24fc712d775ae3b156eb66dcaebb7289858b4f45d3bdcfe55119a3c932f4
  CHECKSUM(SHA256) upstream package : fbdd24fc712d775ae3b156eb66dcaebb7289858b4f45d3bdcfe55119a3c932f4


Generated by fedora-review 0.5.1 (bb9bf27) last change: 2013-12-13
Command line :/bin/fedora-review -b 1020942
Buildroot used: fedora-19-x86_64
Active plugins: Python, Generic, Shell-api, C/C++
Disabled plugins: Java, SugarActivity, fonts, Haskell, Ocaml, Perl, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG
Comment 40 Rex Dieter 2014-02-22 10:27:18 EST
> 2. There are a lot of mixed licenses in here, all FOSS, but how should they be
>   attributed?

https://fedoraproject.org/wiki/Licensing:FAQ?rd=Licensing/FAQ#Multiple_licensing_situations

For example, if sources are all combined into the library, you can simplify matters into one "effective" license.  ie, gplv2 + bsd + lgplv2+ sources combine into a single object who's effective license is gplv2
Comment 41 Richard Shaw 2014-02-23 08:36:15 EST
Thanks... Licenses are still one of my weak points.
Comment 42 Richard Shaw 2014-02-25 08:57:37 EST
Ok, I'm still curious about #1 and #3 above but I don't see them as a blocker.

*** APPROVED ***
Comment 43 Christopher Meng 2014-02-25 09:01:14 EST
Jeremy, what's your FAS id?
Comment 44 Jeremy Newton 2014-02-25 19:10:24 EST
(In reply to Rex Dieter from comment #40)
> > 2. There are a lot of mixed licenses in here, all FOSS, but how should they be
> >   attributed?
> 
> https://fedoraproject.org/wiki/Licensing:FAQ?rd=Licensing/
> FAQ#Multiple_licensing_situations
> 
> For example, if sources are all combined into the library, you can simplify
> matters into one "effective" license.  ie, gplv2 + bsd + lgplv2+ sources
> combine into a single object who's effective license is gplv2

Thanks for your help Rex!

(In reply to Richard Shaw from comment #42)
> Ok, I'm still curious about #1 and #3 above but I don't see them as a
> blocker.
> 
> *** APPROVED ***

Dully noted, thanks!

(In reply to Christopher Meng from comment #43)
> Jeremy, what's your FAS id?

My fas is is mystro256
Comment 45 Jeremy Newton 2014-02-25 19:20:52 EST
New Package SCM Request
=======================
Package Name: wxGTK3
Short Description: GTK port of the wxWidgets GUI library
Owners: mystro256
Branches: f19 f20 f21 devel epel6 epel7
InitialCC:
Comment 46 Gwyn Ciesla 2014-02-26 08:01:36 EST
Git done (by process-git-requests).
Comment 47 Jeremy Newton 2014-02-27 08:47:19 EST
Thanks Jon
Comment 48 Jeremy Newton 2014-03-02 11:31:35 EST
This should be good now, it's been succesfully built on all platforms except epel7.
Comment 49 Fedora Update System 2014-03-02 11:34:10 EST
wxGTK3-3.0.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-4.fc20
Comment 50 Fedora Update System 2014-03-02 11:36:03 EST
wxGTK3-3.0.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-4.fc19
Comment 51 Fedora Update System 2014-03-02 11:37:00 EST
wxGTK3-3.0.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/wxGTK3-3.0.0-4.el6
Comment 52 Jeremy Newton 2014-03-03 21:24:39 EST
rhel 7 successfully build
Comment 53 Fedora Update System 2014-03-12 08:28:02 EDT
wxGTK3-3.0.0-4.fc20 has been pushed to the Fedora 20 stable repository.
Comment 54 Fedora Update System 2014-03-12 08:29:27 EDT
wxGTK3-3.0.0-4.fc19 has been pushed to the Fedora 19 stable repository.
Comment 55 Fedora Update System 2014-03-19 16:21:59 EDT
wxGTK3-3.0.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.