This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1020921 - sddm does not use full screen on two monitor system
sddm does not use full screen on two monitor system
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
20
All Linux
medium Severity low
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
: 1030065 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 10:01 EDT by Jeff Bastian
Modified: 2014-10-07 05:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: sddm-0.2.0-0.31.20140627gitf49c2c79.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-30 06:30:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sddm screenshot (815.91 KB, image/jpeg)
2013-10-18 10:04 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2013-10-18 10:01:11 EDT
Description of problem:
I have a laptop with a 1600x900 display on the left, and an external 1920x1080 monitor on the right.

sddm runs on the external display and it only uses the upper-left 1600x900 corner.  The area below sddm is solid white, and the area to the right is the left edge of a different wallpaper, and the laptop display is solid black.

Leaving the secondary display as solid black is fine, but sddm should use the entire primary display.  It's kind of ugly the way it works now.

Version-Release number of selected component (if applicable):
sddm-0.2.0-0.16.20130914git50ca5b20.fc20.x86_64
sddm-themes-0.2.0-0.16.20130914git50ca5b20.fc20.noarch

How reproducible:
every time

Steps to Reproduce:
1. run sddm with dual monitor setup where monitors are different resolutions

Actual results:
sddm displays in upper-left portion of the larger screen

Expected results:
sddm uses entire screen

Additional info:
Comment 1 Jeff Bastian 2013-10-18 10:04:54 EDT
Created attachment 813788 [details]
sddm screenshot

(I don't know how to take a screenshot from sddm itself, so I used my camera.)
Comment 2 Jeff Bastian 2013-10-18 10:06:31 EDT
xrandr info from within KDE:

~]$ xrandr -q
Screen 0: minimum 320 x 200, current 3520 x 1080, maximum 8192 x 8192
LVDS1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
   1600x900       60.0*+   50.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected primary 1920x1080+1600+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      59.9*+
   1680x1050      59.9  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     66.7     60.0  
   720x400        70.1  
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
Comment 3 Martin Bříza 2013-10-21 07:38:52 EDT
Thanks Jeff,
I can reproduce this with two different-sized screens. Seems more like theme issue, will fix ASAP.
Comment 4 Martin Bříza 2013-11-19 09:18:46 EST
*** Bug 1030065 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2013-11-25 12:40:16 EST
sddm-0.2.0-0.21.20131125git7a008602.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.21.20131125git7a008602.fc20
Comment 6 Jeff Bastian 2013-11-25 16:15:43 EST
sddm-0.2.0-0.22.20131125git7a008602.fc20.x86_64 uses both of my monitors correctly.  Thanks!
Comment 7 Fedora Update System 2013-11-26 12:59:51 EST
Package sddm-0.2.0-0.22.20131125git7a008602.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-0.2.0-0.22.20131125git7a008602.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22158/sddm-0.2.0-0.22.20131125git7a008602.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-06-25 07:09:30 EDT
sddm-0.2.0-0.29.20140623gitdb1d7381.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.29.20140623gitdb1d7381.fc20
Comment 9 Fedora Update System 2014-06-25 07:13:40 EDT
sddm-0.2.0-0.29.20140623gitdb1d7381.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.29.20140623gitdb1d7381.fc19
Comment 10 Fedora Update System 2014-06-30 06:30:52 EDT
sddm-0.2.0-0.31.20140627gitf49c2c79.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2014-10-07 05:29:05 EDT
sddm-0.9.0-1.20141007git6a28c29b.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.9.0-1.20141007git6a28c29b.fc19

Note You need to log in before you can comment on or make changes to this bug.