Bug 1020966 - Mappings defaults to TCP when to Protocols specified in manifest.yml
Mappings defaults to TCP when to Protocols specified in manifest.yml
Status: CLOSED DUPLICATE of bug 1020791
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-18 11:37 EDT by Michal Fojtik
Modified: 2015-05-14 19:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 14:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Fojtik 2013-10-18 11:37:30 EDT
Description of problem:

This issue came from the Zend cartridge, where they are using this Endpoint:

  - Private-IP-Name:   IP
    Private-Port-Name: CONSOLE_PORT
    Private-Port:      16081
    Public-Port-Name:  PROXY_CONSOLE_PORT
    Mappings:
      - Frontend:      "/ZendServer"
        Backend:       "/ZendServer"

Having this in manifest.yml and deployed on the latest devenv, will cause that the endpoint is not properly created, due to the missing 'Protocols: [http]' property.

Without this property, OpenShift will default to TCP protocol, which is not what is expected I think...

I think we should default to '[http,ws]'.

Steps to Reproduce:
1. Create app with mappings set to something like in Description
2. The '/ZendServer' URl will not be routed to IP:CONSOLE_PORT/ZendServer

Expected results:

The routing should work as before, without breaking compatibility.

Additional info:

I would also suggest to update Documentation and explain the Protocol directive to cartridge authors.
Comment 1 Mrunal Patel 2013-10-18 12:49:50 EDT
If this is not the first endpoint in the manifest, then the behavior is expected.
You should add ['http','ws'] as its protocol. Keeping this bug open to update the documentation.
Comment 2 Rob Millner 2013-10-18 14:42:26 EDT
The pre-protocols behaviour was to assume http if a mapping was specified.

Stage:
https://github.com/openshift/origin-server/pull/3929

Master:
https://github.com/openshift/origin-server/pull/3930

Release ticket updated.
Comment 3 Dan McPherson 2013-10-18 14:59:08 EDT

*** This bug has been marked as a duplicate of bug 1020791 ***
Comment 4 openshift-github-bot 2013-10-18 17:34:37 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/531f9f3a0596c05c17c1c0ed3039036ceefb974c
Bug 1020966 - the pre protocols behaviour was to assume http if there was a mapping defined.  Do that by default.

Note You need to log in before you can comment on or make changes to this bug.