Bug 1021147 - vdsm from 3.3.1 beta missing dependency selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
vdsm from 3.3.1 beta missing dependency selinux-policy-targeted-3.7.19-195.el...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity unspecified
: ---
: 3.3.2
Assigned To: Eduardo Warszawski
Haim
infra
:
Depends On: 1015068
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 16:58 EDT by Jason Brooks
Modified: 2013-12-20 05:41 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 05:41:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20313 None None None Never

  None (edit)
Description Jason Brooks 2013-10-19 16:58:15 EDT
Description of problem:

When installing vdsm (standalone host or AIO), install failed on missing selinux-policy-targeted >= 3.7.19-213.

Error: Package: vdsm-4.13.0-2.gitbae164c.el6.x86_64 (ovirt-beta)
           Requires: selinux-policy-targeted >= 3.7.19-213
           Installed: selinux-policy-targeted-3.7.19-195.el6_4.12.noarch
(@updates)

Don't know if this is more appropriately a CentOS bug, but it's a problem for oVirt.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Dan Kenigsberg 2013-10-20 01:02:49 EDT
Unfortunately, ovirt-3.3's vdsm requires an selinux package that has not yet been released.

A manual tweak to the policy is required, beyond ignoring the missing dependency

 sudo semanage fcontext -a -s system_u -t virt_var_run_t -r s0 '/var/run/vdsm(/.*)
Comment 2 Itamar Heim 2013-12-19 21:08:10 EST
dan - has this been fixed in 3.3.2 and can be closed as such?
Comment 3 Dan Kenigsberg 2013-12-20 05:41:57 EST
Yes, http://gerrit.ovirt.org/20760 adds the

 selinux-policy-targeted >= 3.7.19-195.el6_4.13

dependency.

Note You need to log in before you can comment on or make changes to this bug.