Bug 1021152 - 3.3.1 beta, add vdsm host fails with error: Unexpected connection termination
3.3.1 beta, add vdsm host fails with error: Unexpected connection termination
Status: CLOSED DUPLICATE of bug 986882
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Bar-Lev
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-19 17:12 EDT by Jason Brooks
Modified: 2013-10-20 17:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-20 08:52:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
portion of engine.log from centos 6.4 / ovirt 3.3.1 beta engine (32.21 KB, text/x-log)
2013-10-19 17:12 EDT, Jason Brooks
no flags Details
engine log excerpt from attempt to add f19 host (with tar installed) to f19 engine (4.18 KB, text/x-log)
2013-10-20 15:43 EDT, Jason Brooks
no flags Details
log from f19 engine (485.62 KB, text/x-log)
2013-10-20 15:53 EDT, Jason Brooks
no flags Details

  None (edit)
Description Jason Brooks 2013-10-19 17:12:03 EDT
Created attachment 814092 [details]
portion of engine.log from centos 6.4 / ovirt 3.3.1 beta engine

Description of problem:

Tested with F19 engine and with CentOS 6.4 engine, running 3.3.1 beta packages. On adding a new host, add operation fails due to "java.io.IOException: Unexpected connection termination." Fuller log passage attached.

I confirmed that both machines have resolvable DNS names, both machines can see each other, ssh to each other, selinux permissive, tried both w/ firewalls running & not running.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Alon Bar-Lev 2013-10-20 08:52:58 EDT
stderr: bash: tar: command not found

*** This bug has been marked as a duplicate of bug 986882 ***
Comment 2 Jason Brooks 2013-10-20 15:43:48 EDT
Created attachment 814309 [details]
engine log excerpt from attempt to add f19 host (with tar installed) to f19 engine
Comment 3 Alon Bar-Lev 2013-10-20 15:45:53 EDT
(In reply to Jason Brooks from comment #2)
> Created attachment 814309 [details]
> engine log excerpt from attempt to add f19 host (with tar installed) to f19
> engine

Please attach full log.

Have you installed tar on host or on engine?
Comment 4 Jason Brooks 2013-10-20 15:53:19 EDT
Created attachment 814310 [details]
log from f19 engine

tar is installed on the host and on the engine -- I installed ovirt-release-fedora on both machines, and tar is a dep of that pkg
Comment 5 Alon Bar-Lev 2013-10-20 16:14:51 EDT
(In reply to Jason Brooks from comment #4)
> Created attachment 814310 [details]
> log from f19 engine
> 
> tar is installed on the host and on the engine -- I installed
> ovirt-release-fedora on both machines, and tar is a dep of that pkg

This is different issue.

Please file separate bug, or better discuss first at user mailing list...

What do you have at /var/log/messages at host side?

Do you have valid tar at /var/cache/ovirt-engine/ovirt-host-deploy.tar, should be non empty with lots of files.

What do you get while executing the following command at engine:

( cat /var/cache/ovirt-engine/ovirt-host-deploy.tar && cat ) | ssh root@10.10.171.201 'umask 0077; MYTMP="$(mktemp -t ovirt-XXXXXXXXXX)"; trap "chmod -R u+rwX \"${MYTMP}\" > /dev/null 2>&1; rm -fr \"${MYTMP}\" > /dev/null 2>&1" 0; rm -fr "${MYTMP}" && mkdir "${MYTMP}" && tar --warning=no-timestamp -C "${MYTMP}" -x &&  "${MYTMP}"/setup DIALOG/dialect=str:machine DIALOG/customization=bool:True'
Comment 6 Jason Brooks 2013-10-20 17:04:34 EDT
All right, this report wasn't really about tar -- after having this problem on F19, I tried on CentOS, and forgot to install the ovirt-release pkg. That pkg pulls in tar, so that's not really a problem.

Host side, /var/log/messages has NetworkManager activity -- NetworkManager appears to request a new dhcp address when the add host operation begins. I thought maybe could have been disrupting the communications, so I stopped the NetworkManager service, tried add again, no more NetworkManager activity, but the same error occurred engine-side, and on the host side, in /var/log/messages:

Oct 20 16:27:22 dhcp-10-171-201 systemd-logind[450]: New session 55 of user root.
Oct 20 16:27:23 dhcp-10-171-201 systemd-logind[450]: Removed session 55.
Oct 20 16:27:23 dhcp-10-171-201 systemd-logind[450]: New session 56 of user root.
Oct 20 16:27:23 dhcp-10-171-201 systemd-logind[450]: Removed session 56.

Engine side, ovirt-host-deploy.tar is full of files.

Running that command on the engine prompts me for the root pw of the host, then asks me to answer yes/no, and then fails with "ERROR Failed to execute stage 'Initializing': need more than 1 value to unpack"
Comment 7 Alon Bar-Lev 2013-10-20 17:16:54 EDT
please move discussion to users@ovirt.org, bugzilla is not the place for that, especially this bug which is duplicate per your original report.

please also be consistent in the environment you are using, from this thread I do not understand what OS you are using for engine and what OS you are using for host.

Note You need to log in before you can comment on or make changes to this bug.