Bug 986882 - tar which is used by host-deploy is missing from fedora minimal installation
tar which is used by host-deploy is missing from fedora minimal installation
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alon Bar-Lev
bugs@ovirt.org
infra
: FutureFeature
: 1021152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 06:21 EDT by Ohad Basan
Modified: 2014-07-15 07:42 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-15 07:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17295 master ABANDONED host-deploy: use pyar instead of tar 2016-03-09 02:44 EST
oVirt gerrit 17396 None None None Never

  None (edit)
Description Ohad Basan 2013-07-22 06:21:44 EDT
Description of problem:

1.Install a fedora19
2. reprovision host (reformat + install fedora 19)
3. from the engine's admin, chose reinstall host
4. installation immediatly fails. looking at the engine log it says :
stderr: bash: tar: command not found
workaround : install tar manually on the host and re run host deploy
Comment 2 Alon Bar-Lev 2013-07-22 07:03:21 EDT
right.

please install tar on host.
Comment 3 Alon Bar-Lev 2013-07-22 07:07:12 EDT
Solutions:

1. require to install tar at host before deploy.

2. use python to untar, already attempted and reverted as python tar has a bug with last block if zero.

3. use shar instead of tar, this requires engine to create shar or pyar instead of tar, to allow self extracting at target host.

I do not think (3) worth the extra effort, as (2) failed we go with (1).
Comment 4 Itamar Heim 2013-07-23 01:51:03 EDT
do you mean as a manual guideline? this means everyone will fail on this and we will need to add a special check with a nice alert, which sounds easier to just try to 'yum install -y tar' instead?
Comment 5 Alon Bar-Lev 2013-07-23 02:27:14 EDT
(In reply to Itamar Heim from comment #4)
> do you mean as a manual guideline? this means everyone will fail on this and
> we will need to add a special check with a nice alert, which sounds easier

I got only one(!) user report, this is something to do with our PXE image.

> to just try to 'yum install -y tar' instead?

you mean to hardcode 'yum install' at engine side? we really try to avoid using distribution specific commands, as we do indent to port this project to other distributions, right?

if we are serious in supporting porting, and for some reason fedora decided that tar is an optional component of the unix utilities (when installing a certain way), and as I wrote above, there is a bug in the python tar module, the only possibility left is to use shar like archive (self extracting shell / python script).

If you like I can do this, but I really think that pushing fedora to include tar is more productive.
Comment 6 Yedidyah Bar David 2013-07-24 05:42:28 EDT
For the record: I now installed a machine from Fedora-19-x86_64-netinst.iso, chose minimal installation, got no tar.
This is not something new, btw -
http://www.ovirt.org/Quick_Start_Guide#Install_Fedora_Host
Comment 7 Alon Bar-Lev 2013-07-24 05:51:12 EDT
(In reply to Yedidyah Bar David from comment #6)
> For the record: I now installed a machine from Fedora-19-x86_64-netinst.iso,
> chose minimal installation, got no tar.
> This is not something new, btw -
> http://www.ovirt.org/Quick_Start_Guide#Install_Fedora_Host

Relatively new for iso distribution.
So I will add self extracting python and drop tar.
Comment 8 Alon Bar-Lev 2013-07-25 08:21:37 EDT
host-deploy: use pyar instead of tar


pyar = python archive, self extracting python script.

for some reason fedora-18/19 got tar out of base system, so we are
forced to find some solution, although manual configuration is required
anyway (repository, networking etc...).

there was attempt to use python tar module, however this module has a
bug when last block is empty, so it is not suitable for usage.

Bug-Url: https://bugzilla.redhat.com/show_bug.cgi?id=986882
Change-Id: I1e5ddab9ae87979da7d7296c4f3c7ef08e21e903
Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>
Comment 9 Alon Bar-Lev 2013-07-25 08:21:53 EDT
Just for the record.

I do not think this should be applied, I prefer to depend on standard tar archive, even if in fedora it should be installed manually like any other manual configuration required.

Nevertheless it is working.
Comment 10 Yedidyah Bar David 2013-07-25 08:28:35 EDT
(In reply to Alon Bar-Lev from comment #9)
> Just for the record.
> 
> I do not think this should be applied, I prefer to depend on standard tar
> archive, even if in fedora it should be installed manually like any other
> manual configuration required.
> 
> Nevertheless it is working.

I personally have no problem closing this as NOTABUG and documenting the need to install tar (already mentioned on the wiki).
Comment 11 Alon Bar-Lev 2013-07-28 14:10:18 EDT
host-deploy: use cpio instead of tar for bundle transfer


for some reason fedora-18/19 got tar out of base system, so we are
forced to find some solution, although manual configuration is required
anyway (repository, networking etc...).

there was attempt to use python tar module, however this module has a
bug when last block is empty, so it is not suitable for usage.

cpio is alternative for fedora, however it is rightfully missing from
other distributions as it is much less used. as we do not support hosts
using different distributions, we are ok now.

in future, we can use python self extract script, work already performed
at: I1e5ddab9ae87979da7d7296c4f3c7ef08e21e903 at the price of
complexity.

Change-Id: I1386e7d688a9ec7e28519fb407478fd17cbab4ca
Signed-off-by: Alon Bar-Lev <alonbl@redhat.com>
Comment 12 Alon Bar-Lev 2013-10-20 08:52:58 EDT
*** Bug 1021152 has been marked as a duplicate of this bug. ***
Comment 13 Alon Bar-Lev 2014-07-15 07:42:37 EDT
tar is popular utility that is sane to have as basic requirement. not many issues around this since a year. closing.

Note You need to log in before you can comment on or make changes to this bug.