Bug 1021227 - Neutron server failed to start due to missing hard dependency
Neutron server failed to start due to missing hard dependency
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Linux
high Severity high
: rc
: 4.0
Assigned To: Terry Wilson
Roey Dekel
network
: EasyFix
: 1024093 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 10:32 EDT by Nir Magnezi
Modified: 2016-04-26 18:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-neutron-2013.2-5.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, the openstack-neutron package did not depend on the python-keystoneclient package. However, the OpenStack Networking service (provided by openstack-neutron) required modules provided by python-keystoneclient. As a result, users could unknowingly deploy a Neutron server that could not start. This fix adds the required dependency, ensuring that users install all the modules required by the OpenStack Networking service.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:30:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
neutron server log (9.57 KB, text/plain)
2013-10-20 10:33 EDT, Nir Magnezi
no flags Details
Verified server.log (27.86 KB, text/plain)
2013-11-14 03:18 EST, Roey Dekel
no flags Details

  None (edit)
Description Nir Magnezi 2013-10-20 10:32:44 EDT
Description of problem:
=======================
I installed neutron as a standalone node (Via packstack).
It fails to start with a missing import:

TRACE neutron.common.config ImportError: No module named keystoneclient.middleware.auth_token

Version-Release number of selected component (if applicable):
=============================================================
puddle: 2013-10-15.1

python-neutron-2013.2-0.12.rc1.el6ost.noarch
python-neutronclient-2.2.6-1.el6ost.noarch
openstack-neutron-2013.2-0.12.rc1.el6ost.noarch

How reproducible:
=================
Always

Steps to Reproduce:
===================
1. Install OpenStack via packstack, Make sure that the node you configure to run Neutron Server is only used with CONFIG_NEUTRON_SERVER_HOST.

2. Via CLI, check Neutron server status:
   # service neutron-server status

3. Check neutron-server log

Actual results:
===============
neutron-server status:
neutron dead but pid file exists

nova-cert log:

TRACE neutron.common.config ImportError: No module named keystoneclient.middleware.auth_token

Expected results:
=================
neutron-server should be up and running post installation.

Additional Info:
================
To work around the issue:
1. install python-cinderclient
   # yum install python-keystoneclient

2. and restarted the neutron-server service.
   # service neutron-server restart
Comment 1 Nir Magnezi 2013-10-20 10:33:22 EDT
Created attachment 814222 [details]
neutron server log
Comment 3 Lon Hohberger 2013-10-29 13:31:23 EDT
*** Bug 1024093 has been marked as a duplicate of this bug. ***
Comment 5 Roey Dekel 2013-11-14 03:18:20 EST
Created attachment 823811 [details]
Verified server.log
Comment 6 Roey Dekel 2013-11-14 03:23:59 EST
Verified on Havana

Version-Release number of selected component (if applicable):
=============================================================
puddle 2013-11-08.1
python-neutronclient-2.3.1-2.el6ost.noarch
python-neutron-2013.2-5.el6ost.noarch
openstack-neutron-2013.2-5.el6ost.noarch

Results:
========
neutron (pid  1718) is running...

Attachements:
=============
verified server.log

Comments:
=========
Can be seen a know bug in the log, which is specified here:
https://bugs.launchpad.net/neutron/+bug/1210121
Comment 8 errata-xmlrpc 2013-12-19 19:30:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.