Bug 1024093 - openstack-neutron should require python-keystoneclient
openstack-neutron should require python-keystoneclient
Status: CLOSED DUPLICATE of bug 1021227
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Terry Wilson
Ofer Blaut
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-28 15:34 EDT by Lars Kellogg-Stedman
Modified: 2016-04-26 16:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-29 13:31:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-10-28 15:34:07 EDT
Description of problem:

Installing (using packstack) neutron on a dedicated network controller will result in the following error in /var/log/neutron/server.log:

2013-10-28 15:22:15.694 10479 TRACE neutron.common.config ImportError: No module named keystoneclient.middleware.auth_token

Version-Release number of selected component (if applicable):

openstack-neutron-2013.2-3.el6ost.noarch

Installing python-keystoneclient resolves this problem.
Comment 2 Lon Hohberger 2013-10-29 13:31:23 EDT

*** This bug has been marked as a duplicate of bug 1021227 ***

Note You need to log in before you can comment on or make changes to this bug.