Bug 1021228 - after fedup f19->f20: Failed to load SELinux policy. Freezing.
after fedup f19->f20: Failed to load SELinux policy. Freezing.
Status: CLOSED DUPLICATE of bug 1044484
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 10:39 EDT by Christian Stadelmann
Modified: 2014-04-25 15:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 15:36:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedup log file – Note that I had to run fedup multiple times for cleaning, … before. (1.70 MB, text/plain)
2013-10-20 10:39 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2013-10-20 10:39:09 EDT
Created attachment 814223 [details]
Fedup log file – Note that I had to run fedup multiple times for cleaning, … before.

Description of problem:
I upgraded F19 to F20 (alpha). After rebooting and mounting the root fs Fedora freezes with message "Failed to load SELinux policy. Freezing."

Version-Release number of selected component (if applicable):
see log file attached

How reproducible:
not sure, will try again on another F19 machine

Steps to Reproduce:
1. run fedup
# fedup --network 20
2. reboot, let fedup install all new packages
3. reboot another time, this should be the fully updated F20

Actual results:
Does not boot. Output after successfully mounting my encrypted root fs:
~~~~~
[OK] Reached target Encrypted Volumes.
[OK] Reached target System Initialization.
[OK] Reached target Basic system.
[OK] Started dracut initqueue hook.
[OK] Mounting /sysroot
[15.762153] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: (null)
[OK] Mounted /sysroot.
[OK] Reached target Initrd Root File System.
Starting Reload Configuration from the Real Root
[OK] Started Reload Configuration from the Real Root.
[OK] Reached target Initrd Default Target.
[15.839135] systemd-journald[98]: Recieved SIGTERM
[15.900868] type=1404 audit(1382266813.891:2): enforcing=1 oldenforcing=0 auid=4294967295 ses=4294967295
[15.919226] systemd[1]: Failed to load SELinux policy. Freezing.
~~~~~
And it does what it says: freeze. Even Ctrl+Alt+Del does not work to reboot.

Expected results:
SELinux should be up and running on updated Fedora installations

Additional info:
This bug may or may not be related to https://bugzilla.redhat.com/show_bug.cgi?id=987106 (FedUp does not cache packages from repositories considered local (NFS etc.)) – I had the _local repository from yum-plugin-local activated on update

Temporary (bad) workaround:
add enforcing=0 to kernel cmdline
Comment 1 Christian Stadelmann 2013-10-22 15:36:36 EDT
Somehow selinux-policy-targeted got lost, don't know why. Since I don't have any logs from fedup to proove it wrong I'll close this bug.
Comment 2 Will Woods 2014-04-25 15:20:30 EDT

*** This bug has been marked as a duplicate of bug 1044484 ***

Note You need to log in before you can comment on or make changes to this bug.