Bug 987106 - FedUp does not cache packages from repositories considered local (NFS etc.)
FedUp does not cache packages from repositories considered local (NFS etc.)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 981754 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-22 13:57 EDT by Richard Shaw
Modified: 2014-12-22 20:11 EST (History)
4 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:21:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Shaw 2013-07-22 13:57:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Richard Shaw 2013-07-22 14:05:44 EDT
Sorry, stupid similar bug search wouldn't go away and apparently TAB can submit a BUG?!?!

Description of problem:
fedup does not copy packages it considers "local" into /var/lib/fedora-upgrade.

I keep both a (local-install) repository (dump of packages from install DVD) and a personal repository (local) for experimental or proposed updates shared on my home network via NFS. My assumption is that because the files are available locally (/net via autofs) that fedup believes they will be available for the upgrade process.


Version-Release number of selected component (if applicable):
fedup-0.7.3-4.fc18.noarch


How reproducible:
Every time.

Steps to Reproduce:
1. Start update (fedup -v --network 19)
2. Reboot
3. BUNCH of packages missing, but upgrade is attempted anyway.

Actual results:
System is unbootable, this time I got this upon reboot:
systemd[1]: Failed to load SELinux policy. Freezing.


Expected results:
Upgraded system.


Additional info:
IMHO, ALL packages should be copied into /var/lib/fedora-upgrade. I'm not sure why they are not currently, perhaps theres a good reason, but not one I can think of.

If there is a good reason, then definitely any repo location prefixed with "/net" should not be considered local or generally available.

The failure was with a laptop I don't depend on and I was eventually able to get it back up by updating enough packages from a F19 DVD rescue using RPM to get yum working in the chroot.

I have not attempted the upgrade on my desktop yet but I did notice that when I ran fedup and disabled my local repos that 1310 additional packages were added to /var/lib/fedora-upgrade.
Comment 2 Will Woods 2013-10-09 15:50:14 EDT
*** Bug 981754 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-12-11 17:11:30 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 4 Fedora Update System 2013-12-11 17:19:51 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 5 Fedora Update System 2013-12-11 17:21:42 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 6 Fedora Update System 2013-12-13 00:08:48 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-12-19 02:21:01 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-12-19 20:43:50 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-22 00:33:56 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 J. Randall Owens 2014-12-22 20:06:28 EST
As far as I can tell, this is still a problem in fedup-0.9.1-1.fc20. I'm doing an upgrade right now, with an NFS mirror of the repos, but the only files in the local-release-everything & local-updates directories in /var/cache/system-upgrade are the metadata. I'm reluctant to test it by actually letting the upgrade proceed, so I'm just disabling those local repos and downloading everything all over again, but it doesn't look promising.
Comment 11 J. Randall Owens 2014-12-22 20:11:09 EST
Oops, I guess I spoke too soon. I see now that they went into /var/lib/system-upgrade, instead. A bit confusing, but should certainly work, I suppose. Never mind me, then.

Note You need to log in before you can comment on or make changes to this bug.