This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1021258 - requires user manually create biosboot when using guided partitioning
requires user manually create biosboot when using guided partitioning
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker 1022643
  Show dependency treegraph
 
Reported: 2013-10-20 14:53 EDT by Chris Murphy
Modified: 2013-11-06 13:09 EST (History)
16 users (show)

See Also:
Fixed In Version: anaconda-20.25.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1022643 (view as bug list)
Environment:
Last Closed: 2013-11-06 13:09:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (7.74 KB, text/plain)
2013-10-20 14:56 EDT, Chris Murphy
no flags Details
program.log (33.37 KB, text/plain)
2013-10-20 14:56 EDT, Chris Murphy
no flags Details
storage.log (176.87 KB, text/plain)
2013-10-20 14:56 EDT, Chris Murphy
no flags Details
c4 storage.log (161.06 KB, text/plain)
2013-10-20 15:12 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-20 14:53:53 EDT
Description of problem: When installing using Guided partitioning path to a GPT disk containing 2 or more partitions, and at least one of them will be preserved, the installer refuses to proceed telling the user a biosboot partition is required.


Version-Release number of selected component (if applicable):
F20 beta TC5
anaconda-20.25.1-1
python-blivet-0.23.1-1

How reproducible:
Always

Steps to Reproduce:
1. Existing GPT disk with 2+ partitions that are not a BIOS boot partition.
2. Guided partitioning, Installation Options: "I want more space"; continue
3. In Reclaim Disk Space, delete one or more partitions, preserving at least one; click Reclaim Space button.

Actual results:
Error, requires user to use Manual Partitioning to create a biosboot partition.

Expected results:
To create the required partition for me.

Additional info:
Comment 1 Chris Murphy 2013-10-20 14:56:16 EDT
Created attachment 814305 [details]
anaconda.log
Comment 2 Chris Murphy 2013-10-20 14:56:40 EDT
Created attachment 814306 [details]
program.log
Comment 3 Chris Murphy 2013-10-20 14:56:51 EDT
Created attachment 814307 [details]
storage.log
Comment 4 Chris Murphy 2013-10-20 15:06:41 EDT
Regression: Easier way to reproduce is with a GPT disk with 1 partition, and enough free space for Fedora, and using the default "Automatically configure" option, then clicking continue.

Proposing as a beta blocker: "When using the guided partitioning flow, the installer must be able to cleanly install to a disk with a valid ms-dos or gpt disk label and partition table which contains existing data and sufficient unpartitioned space for a Fedora installation."

Work around requires that I use manual partitioning.
Comment 5 Chris Murphy 2013-10-20 15:12:11 EDT
Created attachment 814308 [details]
c4 storage.log

storage.log with simpler reproduce steps.

Why does blivet initially think it's unneeded? Seems similar to bug 1010495.

15:04:26,094 INFO blivet: skipping unneeded stage1 biosboot request
Comment 6 Chris Murphy 2013-10-21 12:42:21 EDT
This is reproducible in qemu/kvm using SeaBIOS.
Comment 7 Mike Ruckman 2013-10-21 12:47:30 EDT
Discussed this in 2013-10-21 Blocker Review Meeting [1]. Accepted as a blocker per Beta criterion "When using the guided partitioning flow, the installer must be able to cleanly install to a disk with a valid ms-dos or gpt disk label and partition table which contains existing data and sufficient unpartitioned space for a Fedora installation." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-21/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Guided_partitioning
Comment 8 David Lehman 2013-10-21 13:15:23 EDT
This is caused by anaconda commit 1bcfb368b75f2d. The bootloader stage1 disk must be set before doAutoPartition is called.
Comment 9 Brian Lane 2013-10-22 20:25:54 EDT
Could you give this a try (against TC5)?

http://bcl.fedorapeople.org/updates/1021258.img

It moves the bootloader execute back the way it was.

It also fixes reusing an existing /boot/efi in autopart.
Comment 10 Chris Murphy 2013-10-22 22:21:34 EDT
(In reply to Brian C. Lane from comment #9)
> Could you give this a try (against TC5)?
> http://bcl.fedorapeople.org/updates/1021258.img

Fixes this bug.
Comment 11 Fedora Update System 2013-10-25 21:10:58 EDT
anaconda-20.25.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.25.4-1.fc20
Comment 12 Chris Murphy 2013-10-27 21:45:32 EDT
Bug no longer occurs with Fedora-20-Beta-TC6-x86_64-DVD.iso
Comment 13 Adam Williamson 2013-11-06 13:09:57 EST
20.25.4-1 went stable as part of FEDORA-2013-20033, and the fix was verified, so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.