Bug 1022643 - requires user manually create biosboot when using guided partitioning
requires user manually create biosboot when using guided partitioning
Status: CLOSED DUPLICATE of bug 1022418
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On: 1021258
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-10-23 13:11 EDT by Brian Lane
Modified: 2013-10-23 19:00 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1021258
Environment:
Last Closed: 2013-10-23 19:00:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2013-10-23 13:11:27 EDT
+++ This bug was initially created as a clone of Bug #1021258 +++

Description of problem: When installing using Guided partitioning path to a GPT disk containing 2 or more partitions, and at least one of them will be preserved, the installer refuses to proceed telling the user a biosboot partition is required.


Version-Release number of selected component (if applicable):
F20 beta TC5
anaconda-20.25.1-1
python-blivet-0.23.1-1

How reproducible:
Always

Steps to Reproduce:
1. Existing GPT disk with 2+ partitions that are not a BIOS boot partition.
2. Guided partitioning, Installation Options: "I want more space"; continue
3. In Reclaim Disk Space, delete one or more partitions, preserving at least one; click Reclaim Space button.

Actual results:
Error, requires user to use Manual Partitioning to create a biosboot partition.

Expected results:
To create the required partition for me.

Additional info:

--- Additional comment from Brian C. Lane on 2013-10-22 20:25:54 EDT ---

Could you give this a try (against TC5)?

http://bcl.fedorapeople.org/updates/1021258.img

It moves the bootloader execute back the way it was.

It also fixes reusing an existing /boot/efi in autopart.

--- Additional comment from Chris Murphy on 2013-10-22 22:21:34 EDT ---

(In reply to Brian C. Lane from comment #9)
> Could you give this a try (against TC5)?
> http://bcl.fedorapeople.org/updates/1021258.img

Fixes this bug.
Comment 2 Brian Lane 2013-10-23 19:00:52 EDT
This is actually fixed by the patch for bug 1022418

*** This bug has been marked as a duplicate of bug 1022418 ***

Note You need to log in before you can comment on or make changes to this bug.