Bug 1021269 - SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /home/Lisouille/.local/share/icc/edid-808a880f7b831df429df261b11a9c269.icc.
SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /h...
Status: CLOSED DUPLICATE of bug 1021268
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b482096a377e9a80ac779028bcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 17:13 EDT by franck.bailliet
Modified: 2013-10-21 05:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 05:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-10-20 17:13:28 EDT
Description of problem:
SELinux is preventing /usr/libexec/colord from 'read' accesses on the file /home/Lisouille/.local/share/icc/edid-808a880f7b831df429df261b11a9c269.icc.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If vous souhaitez corriger l'étiquette. 
L'étiquette par défaut de /home/Lisouille/.local/share/icc/edid-808a880f7b831df429df261b11a9c269.icc devrait être icc_data_home_t.
Then vous pouvez exécuter restorecon.
Do
# /sbin/restorecon -v /home/Lisouille/.local/share/icc/edid-808a880f7b831df429df261b11a9c269.icc

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If vous pensez que colord devrait être autorisé à accéder read sur edid-808a880f7b831df429df261b11a9c269.icc file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep gdbus /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                unconfined_u:object_r:samba_share_t:s0
Target Objects                /home/Lisouille/.local/share/icc/edid-
                              808a880f7b831df429df261b11a9c269.icc [ file ]
Source                        gdbus
Source Path                   /usr/libexec/colord
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           colord-1.0.3-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.8.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.1-200.fc19.x86_64 #1 SMP Sat
                              Sep 14 15:04:51 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-10-04 09:12:52 CEST
Last Seen                     2013-10-04 09:12:52 CEST
Local ID                      baafdecf-921f-44db-85b7-8457abcfd94a

Raw Audit Messages
type=AVC msg=audit(1380870772.859:1311): avc:  denied  { read } for  pid=1273 comm="gdbus" path="/home/Lisouille/.local/share/icc/edid-808a880f7b831df429df261b11a9c269.icc" dev="sda5" ino=7340327 scontext=system_u:system_r:colord_t:s0 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1380870772.859:1311): arch=x86_64 syscall=recvmsg success=yes exit=EBUSY a0=9 a1=7f0bf3ffebb0 a2=40000000 a3=0 items=0 ppid=1 pid=1273 auid=4294967295 uid=998 gid=997 euid=998 suid=998 fsuid=998 egid=997 sgid=997 fsgid=997 ses=4294967295 tty=(none) comm=gdbus exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)

Hash: gdbus,colord_t,samba_share_t,file,read

Additional info:
reporter:       libreport-2.1.8
hashmarkername: setroubleshoot
kernel:         3.11.4-201.fc19.x86_64
type:           libreport

Potential duplicate: bug 868006
Comment 1 Lukas Vrabec 2013-10-21 05:21:42 EDT
Use: "# /sbin/restorecon -R -v /home/Lisouille/.local/" to fix it.
Comment 2 Miroslav Grepl 2013-10-21 05:54:26 EDT

*** This bug has been marked as a duplicate of bug 1021268 ***

Note You need to log in before you can comment on or make changes to this bug.