Bug 1021268 - SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' accesses on the file /home/Frankyboy/.gtkrc-2.0-kde4.
SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' ac...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:5a6e0a40b2f9d8c9c7bd17466f9...
:
: 1021269 1021271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 17:12 EDT by franck.bailliet
Modified: 2013-10-21 05:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 05:17:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-10-20 17:12:42 EDT
Description of problem:
SELinux is preventing /usr/lib64/xulrunner/plugin-container from 'getattr' accesses on the file /home/Frankyboy/.gtkrc-2.0-kde4.

*****  Plugin restorecon (57.3 confidence) suggests  *************************

If vous souhaitez corriger l'étiquette. 
L'étiquette par défaut de /home/Frankyboy/.gtkrc-2.0-kde4 devrait être user_home_t.
Then vous pouvez exécuter restorecon.
Do
# /sbin/restorecon -v /home/Frankyboy/.gtkrc-2.0-kde4

*****  Plugin mozplugger (43.1 confidence) suggests  *************************

If vous voulez utiliser le paquet plugin
Then vous devez désactiver les contrôles SELinux sur les extensions Firefox.
Do
# setsebool -P unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.06 confidence) suggests  ***************************

If vous pensez que plugin-container devrait être autorisé à accéder getattr sur .gtkrc-2.0-kde4 file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                system_u:object_r:samba_share_t:s0
Target Objects                /home/Frankyboy/.gtkrc-2.0-kde4 [ file ]
Source                        plugin-containe
Source Path                   /usr/lib64/xulrunner/plugin-container
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           xulrunner-24.0-2.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.8.fc19.noarch selinux-
                              policy-3.12.1-74.9.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.2-201.fc19.x86_64 #1 SMP Fri
                              Sep 27 19:20:55 UTC 2013 x86_64 x86_64
Alert Count                   48
First Seen                    2013-08-27 19:20:51 CEST
Last Seen                     2013-10-14 20:33:01 CEST
Local ID                      5bdfa0c4-3d5f-4577-be44-d7987675bd39

Raw Audit Messages
type=AVC msg=audit(1381775581.826:954): avc:  denied  { getattr } for  pid=5400 comm="plugin-containe" path="/home/Frankyboy/.gtkrc-2.0-kde4" dev="sda5" ino=8388647 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1381775581.826:954): arch=x86_64 syscall=lstat success=no exit=EACCES a0=7ff008115260 a1=7ffff358f850 a2=7ffff358f850 a3=7ff0155a8040 items=0 ppid=27118 pid=5400 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=plugin-containe exe=/usr/lib64/xulrunner/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,samba_share_t,file,getattr

Additional info:
reporter:       libreport-2.1.8
hashmarkername: setroubleshoot
kernel:         3.11.4-201.fc19.x86_64
type:           libreport

Potential duplicate: bug 845486
Comment 1 Lukas Vrabec 2013-10-21 05:17:29 EDT
use "# /sbin/restorecon -R -v /home/Frankyboy/" to fix it.
Comment 2 Miroslav Grepl 2013-10-21 05:54:07 EDT
*** Bug 1021271 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-10-21 05:54:26 EDT
*** Bug 1021269 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-10-21 05:59:11 EDT
Are you trying to share your homedir? 

It looks so and if yes, you can fix labeling how Lukas wrote and use

samba_enable_home_dirs

boolean to allow samba to share users home directories.

Note You need to log in before you can comment on or make changes to this bug.