This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021271 - SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the file /home/Frankyboy/libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the...
Status: CLOSED DUPLICATE of bug 1021268
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c71d3c1738a18dbaf1687c5c7df...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-20 17:16 EDT by franck.bailliet
Modified: 2013-10-21 05:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 05:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description franck.bailliet 2013-10-20 17:16:54 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the file /home/Frankyboy/libpeerconnection.log.

*****  Plugin restorecon (66.7 confidence) suggests  *************************

If vous souhaitez corriger l'étiquette. 
L'étiquette par défaut de /home/Frankyboy/libpeerconnection.log devrait être user_home_t.
Then vous pouvez exécuter restorecon.
Do
# /sbin/restorecon -v /home/Frankyboy/libpeerconnection.log

*****  Plugin chrome (33.6 confidence) suggests  *****************************

If vous voulez utiliser le paquet plugin
Then vous devrez désactiver les contrôles SELinux sur les greffons Chrome.
Do
# setsebool -P unconfined_chrome_sandbox_transition 0

*****  Plugin catchall (1.16 confidence) suggests  ***************************

If vous pensez que chrome devrait être autorisé à accéder append sur libpeerconnection.log file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:samba_share_t:s0
Target Objects                /home/Frankyboy/libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.95-213514.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.6-200.fc19.x86_64 #1 SMP Mon
                              Aug 12 14:49:42 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-19 22:41:16 CEST
Last Seen                     2013-08-19 22:41:16 CEST
Local ID                      7f6c02c4-a71f-4203-a721-9888980c0e74

Raw Audit Messages
type=AVC msg=audit(1376944876.420:531): avc:  denied  { append } for  pid=26531 comm="chrome" name="libpeerconnection.log" dev="sda5" ino=8389171 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:samba_share_t:s0 tclass=file


type=SYSCALL msg=audit(1376944876.420:531): arch=x86_64 syscall=open success=no exit=EACCES a0=7ff33229f198 a1=441 a2=1b6 a3=0 items=0 ppid=0 pid=26531 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,samba_share_t,file,append

Additional info:
reporter:       libreport-2.1.8
hashmarkername: setroubleshoot
kernel:         3.11.4-201.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-10-21 05:53:49 EDT
If vous souhaitez corriger l'étiquette. 
L'étiquette par défaut de /home/Frankyboy/libpeerconnection.log devrait être user_home_t.
Then vous pouvez exécuter restorecon.
Do

# /sbin/restorecon -v /home/Frankyboy/libpeerconnection.log
Comment 2 Miroslav Grepl 2013-10-21 05:54:07 EDT

*** This bug has been marked as a duplicate of bug 1021268 ***

Note You need to log in before you can comment on or make changes to this bug.