Bug 1021368 - account displayname should be unique
account displayname should be unique
Status: CLOSED DUPLICATE of bug 967392
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 03:43 EDT by wangjing
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 03:47:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot for comment0 (64.35 KB, image/png)
2013-10-21 03:43 EDT, wangjing
no flags Details

  None (edit)
Description wangjing 2013-10-21 03:43:13 EDT
Created attachment 814453 [details]
screenshot for comment0

Description of problem:
account displayname should be unique because displayname was used to display on the other places on web, if they are not same, then it's confused.

Version-Release number of selected component (if applicable):
beaker-devel Version 0.15.0

How reproducible:
always

Steps to Reproduce:
1. add two account1, account2 and set the same displayname to them.
2. add both of them to one account's submission delegates table.
3. check the account name on web.

Actual results:
after step1, both of them are prompted "*displayname* saved".
after step3, there are two same accounts in the submission delegates table on the web.

Expected results:
hope the displayname to be unique.

Additional info:
except the example in step1-3, there are also other places used displayname, so it's an issue.
Comment 1 Nick Coghlan 2013-10-21 03:47:41 EDT
Duping this onto 967392, since always displaying the username (which is already guaranteed to be unique) with the display name shown in a tooltip is our preferred approach to resolving this.

*** This bug has been marked as a duplicate of bug 967392 ***

Note You need to log in before you can comment on or make changes to this bug.