This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1021375 - When analyst navigates from business central to Business dashboards he is logged out
When analyst navigates from business central to Business dashboards he is log...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 04:01 EDT by Jan Hrcek
Modified: 2014-08-06 16:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When a user with the role of analyst navigates from the Business Central to the Business Dashboard, the system invalidates the users access and logs him out of the entire system. The user needs to logout and login again to get access to the dashboard. Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Steps to reproduce - video (5.26 MB, video/webm)
2013-10-21 04:01 EDT, Jan Hrcek
no flags Details
Permissions - default configuration (59.39 KB, image/png)
2013-10-21 10:10 EDT, Pedro Zapata
no flags Details
Permissions - required configuration (56.63 KB, image/png)
2013-10-21 10:10 EDT, Pedro Zapata
no flags Details

  None (edit)
Description Jan Hrcek 2013-10-21 04:01:22 EDT
Created attachment 814457 [details]
Steps to reproduce - video

Description of problem:
When you login to business central with user who has just role 'analyst' (no 'admin') and you navigate to Dashboards > Business dashboards, the user is logged out from dashbuilder. When he gets back to business central, he is logged out in the jbpm dashboard and it is impossible to login again. The only way to fix this is to logout from business central and login again.

See video for steps to reproduce.

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER4

How reproducible:
always

Steps to Reproduce:
1. Login to business-central with user who only has role analyst
2. open Dashboards > Process & Task Dashboard (should open built-in jbpm dashboard)
3. open Dashboards > Business dashboards
4. back in business central repeat step 2

Actual results:
New tab/windowis opened with dashbuilder login screen.

When back in business central, user is logged out from dashbuilder and dashbuilder login screen appears in iframe for jbpm dashboard.

Expected results:
Not sure what exactly is expected, but user should not be logged out from business central's jbpm dashboard. Either analyst role should be configured to have access to Showcase workspace too (so that he is not logged out when navigating to business dashboards) or he should be taken to the workspace that he has access to (jbpm-dashboard in this case).

Additional info:
I think the problem is, that Dashboards > Business dashboards takes user to Showcase workspace which, by default, is not accessible to user with role analyst. See also https://bugzilla.redhat.com/show_bug.cgi?id=1007725
Comment 1 Pedro Zapata 2013-10-21 10:10:25 EDT
Created attachment 814620 [details]
Permissions - default configuration
Comment 2 Pedro Zapata 2013-10-21 10:10:54 EDT
Created attachment 814621 [details]
Permissions - required configuration
Comment 3 Pedro Zapata 2013-10-21 10:12:50 EDT
The issue is caused because the default workspace configuration does NOT allow analyst role to log into the generic workspace (see screenshot 1).

That can be workarounded easily by adding this permission to the role 'analyst', as shown in screenshot 2. From then, it will work fine.
Comment 4 Pedro Zapata 2013-10-21 10:14:22 EDT
That was already fixed in community in https://bugzilla.redhat.com/show_bug.cgi?id=1018289 but I don't see any commit in the branding branch, so it must be verified in the branding branch to be sure this fix is also there.
Comment 5 David Gutierrez 2013-10-22 05:27:14 EDT
Indeed (as Pedro pointed out) this issue is already fixed in the community. From now on, 5 roles: admin, analyst, manager, developer & manager have access granted to the Showcase workspace. Those new roles has been requested by PM as you can see here: https://bugzilla.redhat.com/show_bug.cgi?id=1005981.
Comment 6 Jan Hrcek 2013-12-02 01:59:41 EST
Ok, the issue has been fixed in BPMS 6.0.0 ER5

Note You need to log in before you can comment on or make changes to this bug.