Bug 1021413 - Lock screen hangs, input ignored or lockscreen unresponsive
Lock screen hangs, input ignored or lockscreen unresponsive
Status: CLOSED DUPLICATE of bug 1019405
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
19
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-21 05:20 EDT by Sam Tuke
Modified: 2013-10-24 04:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 04:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Tuke 2013-10-21 05:20:48 EDT
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Build Identifier: 

When the screen is automatically locked, either after 5 minutes or when the laptop suspends due to lid close or timeout, the gnome lockscreen typically cannot be unlocked. Either the lockscreen with blue background and large clock hangs and is unresponsive, or keyboard input is not registered when I attempt to enter a password.
Ctrl+Alt+Backspace does initiate a response, but after a few minutes waiting for the login screen to reappear it only partially loads and also unresponsive. Using Ctrl+Alt+F2/3/4/5... typically doesn't work - the terminals are not usable - just a flashing underscore appears.

Reproducible: Sometimes

Steps to Reproduce:
1. Lock the screen (unsure if manual and automatic locking has the same effect)
2. Try to unlock it by pressing 'enter' to trigger password input field
3. Observe it's impossible to unlock the screen without a system reboot
Actual Results:  
Screen cannot be unlocked

Expected Results:  
Screen is unlocked and session is returned
Comment 1 Jeff Bastian 2013-10-22 08:27:13 EDT
Do you have cinnamon-screensaver installed?  There was a known bug with Cinnamon screensaver running in Gnome, see bug 1019405
Comment 2 Sam Tuke 2013-10-24 04:22:52 EDT
Yes it looks like the same bug. I wrote a blog how to about it here http://blogs.fsfe.org/samtuke/?p=644

*** This bug has been marked as a duplicate of bug 1019405 ***

Note You need to log in before you can comment on or make changes to this bug.