Bug 1019405 - cinnamon-screensaver causes unwanted screen locking when running GNOME
cinnamon-screensaver causes unwanted screen locking when running GNOME
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cinnamon-screensaver (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
RejectedBlocker
: Reopened
: 1020006 1021413 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 12:09 EDT by Andre Robatino
Modified: 2013-11-10 02:49 EST (History)
11 users (show)

See Also:
Fixed In Version: cinnamon-control-center-2.0.3-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 08:34:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-10-15 12:09:54 EDT
Description of problem:
If both the GNOME and Cinnamon desktops are installed, then while running GNOME, cinnamon-screensaver is running, and causes screen locking, even if it is turned off in GNOME. Sometimes it's impossible to get focus in the Password window, and one can only bypass the lock by going to a VT and running "killall cinnamon-screensaver". See https://lists.fedoraproject.org/pipermail/users/2013-October/441728.html , and specifically https://lists.fedoraproject.org/pipermail/users/2013-October/441746.html . This problem started roughly a day ago, which is when I updated to the cinnamon 2.0 packages.

Version-Release number of selected component (if applicable):
cinnamon-screensaver-2.0.0-1.fc19.x86_64
Comment 1 leigh scott 2013-10-15 13:47:32 EDT
Get the gnome devs to blacklist it.
Comment 2 leigh scott 2013-10-15 13:51:01 EDT
Cinnamon blacklists to stop stray gnome apps

https://github.com/linuxmint/cinnamon-session/commit/95808f7047a031c734052d689f2a39f39c914b61
Comment 3 Olav Vitters 2013-10-15 14:49:08 EDT
(In reply to leigh scott from comment #1)
> Get the gnome devs to blacklist it.

No, Cinnamon is specifying that their stuff should be started under GNOME. All their desktop files specify things like:
OnlyShowIn=GNOME;Unity;

GNOME is responding to this.

What Cinnamon should do is change:
  OnlyShowIn=GNOME;Unity;
to
  OnlyShowIn=Cinnamon;


The bug is in Cinnamon. "Blacklisting"?!? We're not going to work around Cinnamon bugs!
Comment 4 Wolfgang Ulbrich 2013-10-15 15:00:40 EDT
@ Andre Robatino
Why not removing gnome?
Nobody needs it.
Comment 5 leigh scott 2013-10-15 15:38:17 EDT
(In reply to Olav Vitters from comment #3)
> (In reply to leigh scott from comment #1)
> > Get the gnome devs to blacklist it.
> 
> No, Cinnamon is specifying that their stuff should be started under GNOME.
> All their desktop files specify things like:
> OnlyShowIn=GNOME;Unity;
> 
> GNOME is responding to this.
> 
> What Cinnamon should do is change:
>   OnlyShowIn=GNOME;Unity;
> to
>   OnlyShowIn=Cinnamon;
> 

Nice idea but it won't work as Clem won't register cinnamon at freedesktop.org

> 
> The bug is in Cinnamon. "Blacklisting"?!? We're not going to work around
> Cinnamon bugs!

Well that's fine with me but I see no way for me to fix it.
Comment 6 Matthias Clasen 2013-10-15 15:43:54 EDT
You'd rather have us add a Conflicts: cinnamon-screensaver to gnome-shell ?
Comment 7 Matthias Clasen 2013-10-15 15:45:53 EDT
Please remove GNOME from OnlyShowIn. Cinnamon can't identify itself as GNOME - it is not, and has not been for a long time, a variant of GNOME.
Comment 8 Fedora Blocker Bugs Application 2013-10-15 16:10:39 EDT
Proposed as a Blocker for 20-final by Fedora user mclasen using the blocker tracking app because:

 cinnamon-screensaver injects itself into the gnome-session by installing an autostart file that has OnlyShowIn=GNOME in it, and breaks screen locking functionality in GNOME.
Comment 9 leigh scott 2013-10-15 17:11:06 EDT
(In reply to Fedora Blocker Bugs Application from comment #8)
> Proposed as a Blocker for 20-final by Fedora user mclasen using the blocker
> tracking app because:
> 
>  cinnamon-screensaver injects itself into the gnome-session by installing an
> autostart file that has OnlyShowIn=GNOME in it, and breaks screen locking
> functionality in GNOME.

How the hell can this be a blocker for F20 as none of the media installs gnome and cinnamon together?

-1 as a blocker.
Comment 10 leigh scott 2013-10-15 17:20:21 EDT
(In reply to Matthias Clasen from comment #6)
> You'd rather have us add a Conflicts: cinnamon-screensaver to gnome-shell ?

No I would rather that you patched gnome-session to exclude it but judging by the tone here I doubt that will happen.
Comment 11 Wolfgang Ulbrich 2013-10-15 17:32:08 EDT
(In reply to Fedora Blocker Bugs Application from comment #8)
> Proposed as a Blocker for 20-final by Fedora user mclasen using the blocker
> tracking app because:
> 
>  cinnamon-screensaver injects itself into the gnome-session by installing an
> autostart file that has OnlyShowIn=GNOME in it, and breaks screen locking
> functionality in GNOME.

Why should this be a blocker?
Gnome default installation doesn't install cinnamon-screensaver in result this doesn't break a gnome installation.
The question is, why is there a need for users to install cinnamon if they can use gnome ;)

-1 as a blocker
Comment 12 Olav Vitters 2013-10-15 17:57:33 EDT
(In reply to leigh scott from comment #10)
> No I would rather that you patched gnome-session to exclude it but judging
> by the tone here I doubt that will happen.

That would be unreliable. The OnlyShowIn=GNOME; is for GNOME, not Cinnamon. This bug doesn't only affect cinnamon-screensaver, but other packages as well. I noticed things from cinnamon-settings-daemon as well as cinnamon-control-center.

The "GNOME" is there to avoid things like this. No need for patching, just use the infrastructure as it was designed.
Comment 13 Wolfgang Ulbrich 2013-10-15 18:08:48 EDT
(In reply to Olav Vitters from comment #12)
> (In reply to leigh scott from comment #10)
> > No I would rather that you patched gnome-session to exclude it but judging
> > by the tone here I doubt that will happen.
> 
> That would be unreliable. The OnlyShowIn=GNOME; is for GNOME, not Cinnamon.
> This bug doesn't only affect cinnamon-screensaver, but other packages as
> well. I noticed things from cinnamon-settings-daemon as well as
> cinnamon-control-center.
> 
> The "GNOME" is there to avoid things like this. No need for patching, just
> use the infrastructure as it was designed.

Do you really think removing cinnamon from fedora will bring you users back, they will simple switch to another distro.
Comment 14 Olav Vitters 2013-10-15 18:20:10 EDT
(In reply to Wolfgang Ulbrich from comment #13)
> Do you really think removing cinnamon from fedora will bring you users back,
> they will simple switch to another distro.

It seems you think this is Phoronix.com?

Anyway, some facts:
- I'd like this bug to be fixed properly
- I don't like hacks
- I don't like people who just add noise
- I don't like people who assume the worst
- I am totally happy with forks

Where did I ask for Cinnamon to be removed? Nowhere! I do want Cinnamon not to cause bugs in GNOME. Anyway, please take this offline, because at the moment you're doing nothing to get this bug fixed.
Comment 15 Wolfgang Ulbrich 2013-10-15 18:50:55 EDT
(In reply to Olav Vitters from comment #14)
> (In reply to Wolfgang Ulbrich from comment #13)
> > Do you really think removing cinnamon from fedora will bring you users back,
> > they will simple switch to another distro.
> 
> It seems you think this is Phoronix.com?
It seems that you're are the one who add noise.
> 
> Anyway, some facts:
> - I'd like this bug to be fixed properly
> - I don't like hacks
> - I don't like people who just add noise
> - I don't like people who assume the worst
> - I am totally happy with forks
Why you're getting personal and rude, this doesn't help?
> 
> Where did I ask for Cinnamon to be removed? Nowhere! I do want Cinnamon not
> to cause bugs in GNOME. Anyway, please take this offline, because at the
> moment you're doing nothing to get this bug fixed.
Anyway, some facts too.
- Gnome devs do nothing to simple fix this issue with blacklisting cinnamon-screensaver, like any other DE would do that.
- cinnamon-screensaver doesn't break any default gnome instalation.
Comment 16 Colin Guthrie 2013-10-15 19:44:17 EDT
(In reply to Wolfgang Ulbrich from comment #15)
> - Gnome devs do nothing to simple fix this issue with blacklisting
> cinnamon-screensaver, like any other DE would do that.

No other DE would have to do that because other DEs use the session name infrastructure to do things properly. Blacklists are fundamentally the wrong approach here. Many DEs whitelist the autostart applciations which they determine to be a private part of their infrastrucutre. As the DE evolves, the whitelist will change. The only way to manage this properly is upstream in the project which orchestates and glues together those private components.

A blacklist is a horrible hack. It papers over the bad design. The technically correct solution here is for Cinnamon to identify itself as itself and not pretend to be a different DE as the latter specifically breaks the whitelisting system that all DEs aggree on, collaborate on and have used successfully for years.

To make a claim that by not implementing a hack in GNOME makes this a GNOME development problem is laughable and I seriously hope you're just not understanding the proposed solution (i.e. using the existing infrastructure that all DEs have aggred on and used for years). Any developer worth their salt should reject such a hack on pure technical ground. If they didn't reject it, I would consider them a very poor engineer.
Comment 17 Olav Vitters 2013-10-16 03:59:21 EDT
(In reply to Wolfgang Ulbrich from comment #15)
> Why you're getting personal and rude, this doesn't help?

Please take this off Bugzilla as requested before.
Comment 18 Piruthiviraj Natarajan 2013-10-16 14:30:09 EDT
How is this bug a blocker? 
I don't see this bug if I don't install Cinnamon.

-1 as blocker.
Comment 19 Fedora Update System 2013-10-17 09:10:10 EDT
cinnamon-screensaver-2.0.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/cinnamon-screensaver-2.0.0-2.fc19
Comment 20 Fedora Update System 2013-10-17 09:10:59 EDT
cinnamon-screensaver-2.0.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cinnamon-screensaver-2.0.0-2.fc20
Comment 21 Colin Guthrie 2013-10-17 09:25:29 EDT
"Stop starting in gnome-shell as it pissed off the gnome devs"

Really? Is this the level of professional courtesy that goes on here?

I hope the similar hacks are applied to all other cinnamon components that also abuse the OnlyShowIn=GNOME .desktop directive?
Comment 22 Olav Vitters 2013-10-17 09:29:09 EDT
> Stop starting in gnome-shell as it pissed off the gnome devs

I'm not a GNOME developer, I am a GNOME release team member. Matthias is a release team member as well as a GNOME release team member.

Nobody at GNOME is pissed off in the slightest. This is a bug and this bug was IMO preventable. The bug should be fixed properly. There is a lot of noise in this bugreport where people are not talking about how to fix this properly and/or discussing how to fix it. That's unfortunate, but let's focus on fixing bugs and fixing bugs properly.

Now aside from cinnamon-screensaver, the same issue also occurs in other cinnamon packages. They should be modified as well. I think I'll just contact Cinnamon developers myself. Let's focus on solving things and working together.
Comment 23 Olav Vitters 2013-10-17 09:30:06 EDT
ehh.. Matthias is a developer.
Comment 24 Matthias Clasen 2013-10-17 10:06:32 EDT
To move this in a more constructive direction:

This bug illustrates that the autostart mechanism is not a good fit for desktop components. For that reason, GNOME has moved most of the 'session construction' into the RequiredComponents field in /usr/share/gnome-session/sessions/gnome.session. 

In the future, systemd user sessions should provide this functionality without the downsides.
Comment 25 Michael Webster 2013-10-17 13:38:39 EDT
As of a little while ago, all Cinnamon required components have been changed to utilize RequiredComponents in the session file.  Hopefully this action solves the current problem.

Thanks
Comment 26 D. Hugh Redelmeier 2013-10-17 14:42:29 EDT
I'm just an F19 user.  I use Gnome desktop and not Cinnamon.  At some point (probably installation time) I must have asked for Cinnamon to be installed.

My system started misbehaving this week.  I presume due to Cinnamon updates.  It was hard for me to associate the new problems with my action of months ago.  That's not good system behaviour and it should be fixed somehow.

One symptom hasn't been mentioned.

Sometimes a warning box would pop up near the bottom of my screen, and then go away.  I think it popped up when a screen-save was about to fire, so I didn't see it very often.  It said:
        Unable to Lock: lock was blocked by an application

Stupidly, the message doesn't say what program is generating this.  Grrr.

I guess it is one of the two competing screen locking facilities (ordinary Gnome and Cinnamon).  If anyone can tell me which one, I'll file a bug report against it, asking that the message be more forthcoming.
Comment 27 Fedora Update System 2013-10-17 16:20:23 EDT
Package cinnamon-screensaver-2.0.0-2.fc20, cinnamon-settings-daemon-2.0.1-2.fc20, cinnamon-2.0.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cinnamon-screensaver-2.0.0-2.fc20 cinnamon-settings-daemon-2.0.1-2.fc20 cinnamon-2.0.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19128/cinnamon-2.0.2-2.fc20,cinnamon-settings-daemon-2.0.1-2.fc20,cinnamon-screensaver-2.0.0-2.fc20
then log in and leave karma (feedback).
Comment 28 Jonathan 2013-10-18 05:30:43 EDT
Humble question from an F19 user, this bug cripples my system as well.
As I see an update submitted for F20, can I expect this to trickle down to F19 as well eventually or is the workaround here just to weed out cinnamon as that is the one I use less and they don't play nice together?
Comment 29 leigh scott 2013-10-18 05:41:21 EDT
(In reply to Jonathan from comment #28)
> Humble question from an F19 user, this bug cripples my system as well.

A temporary fix

su
rm  /etc/xdg/autostart/cinnamon-screensaver.desktop


> As I see an update submitted for F20, can I expect this to trickle down to
> F19 as well eventually 

Yes.

https://admin.fedoraproject.org/updates/cinnamon-2.0.2-3.fc19,cinnamon-settings-daemon-2.0.1-2.fc19,cinnamon-screensaver-2.0.0-2.fc19
Comment 30 Andre Robatino 2013-10-18 08:57:51 EDT
I just preemptively run "kill cinnamon-screensaver" immediately after logging into GNOME (so I never have to go to a VT), and the process doesn't respawn.

The link leigh gave appears to be broken, the correct link is https://admin.fedoraproject.org/updates/cinnamon-control-center-2.0.3-1.fc19,cinnamon-2.0.2-3.fc19,cinnamon-settings-daemon-2.0.1-2.fc19,cinnamon-screensaver-2.0.0-2.fc19 .
Comment 31 Andre Robatino 2013-10-18 08:58:40 EDT
Sorry, that should have been "killall cinnamon-screensaver".
Comment 32 Adam Williamson 2013-10-18 11:49:06 EDT
FWIW I'm -1 blocker on this (for Final) as we don't make it easy to do multi-desktop installs, but it sure is an annoying bug and should be fixed soon. Cinnamon guys, you're just shooting yourselves in the foot by being bolshie about this: I started hitting this kind of problem back in the F19 cycle and 'solved' it by removing Cinnamon, so by including this kind of bugginess in your desktop you're only causing people not to use your desktop. There seem to be enough -1 votes in-bug to mark this as rejectedblocker.
Comment 33 Michael Webster 2013-10-18 12:00:25 EDT
As I said in #25, this was addressed yesterday and should no longer be an issue.  Whether it has trickled down to the Fedora package base yet I cannot say though.
Comment 34 Andre Robatino 2013-10-18 23:46:16 EDT
(In reply to leigh scott from comment #2)
> Cinnamon blacklists to stop stray gnome apps
> 
> https://github.com/linuxmint/cinnamon-session/commit/
> 95808f7047a031c734052d689f2a39f39c914b61

Are the GNOME apps in that blacklist currently misbehaving? If so, have bugs been filed against them?

P.S. The reason the F19 cinnamon URL was broken was that it's been edited several times, the current one is

https://admin.fedoraproject.org/updates/cinnamon-2.0.3-1.fc19,cinnamon-screensaver-2.0.1-1.fc19,nemo-2.0.1-1.fc19,muffin-2.0.2-1.fc19,cinnamon-control-center-2.0.3-1.fc19,cinnamon-settings-daemon-2.0.3-1.fc19

One can always find the current one by going to https://bodhi.fedoraproject.org and searching for "cinnamon".
Comment 35 Colin Guthrie 2013-10-19 06:30:11 EDT
(In reply to Andre Robatino from comment #34)
> (In reply to leigh scott from comment #2)
> > Cinnamon blacklists to stop stray gnome apps
> > 
> > https://github.com/linuxmint/cinnamon-session/commit/
> > 95808f7047a031c734052d689f2a39f39c914b61
> 
> Are the GNOME apps in that blacklist currently misbehaving? If so, have bugs
> been filed against them?

FYI, they are not "misbehaving", but operating as designed. They are blacklisted in cinnamon because cinnamon will start anything with an XDG autostart .desktop file with a OnlyShowIn=GNOME directive (assuming nothing else overrides this).

This is only a problem under cinnnamon because it still advertises itself as GNOME. The code is a hack and would not be needed if cinnamon identified itself properly.
Comment 36 Michael Webster 2013-10-19 15:51:43 EDT
Are you guys so small that you won't let this go, days after it's been fixed/addressed upstream?  Yes Cinnamon still advertises itself as GNOME - we have reasons for doing so which we feel are currently valid, whether you agree with them or not.  Let's move on.
Comment 37 Andre Robatino 2013-10-19 16:22:04 EDT
(In reply to Michael Webster from comment #36)
> Are you guys so small that you won't let this go, days after it's been
> fixed/addressed upstream?  Yes Cinnamon still advertises itself as GNOME -
> we have reasons for doing so which we feel are currently valid, whether you
> agree with them or not.  Let's move on.

The reason I asked the question is that Leigh in comment #2 was implying by using the phrase "stray gnome apps" that those apps were buggy, and that GNOME devs were unresponsive to bug reports, and that as a result Cinnamon was forced to use a blacklist, and therefore it was justifiable to expect GNOME to do the same. I suspected that that was not the case, but wanted to be sure, since I'm an equal-opportunity bug filer, and the GNOME devs certainly aren't perfect.

BTW, the above F19 cinnamon update has now gone to updates-testing, though no bodhi message has appeared in this bug yet.
Comment 38 Matthias Clasen 2013-10-21 08:29:43 EDT
(In reply to Michael Webster from comment #36)
> Are you guys so small that you won't let this go, days after it's been
> fixed/addressed upstream?  Yes Cinnamon still advertises itself as GNOME -
> we have reasons for doing so which we feel are currently valid, whether you
> agree with them or not.  Let's move on.

If that is not changed (Cinnamon advertising itself as GNOME), we will have to consider adding conflicts
Comment 39 leigh scott 2013-10-21 08:34:05 EDT
(In reply to Matthias Clasen from comment #38)
> (In reply to Michael Webster from comment #36)
> > Are you guys so small that you won't let this go, days after it's been
> > fixed/addressed upstream?  Yes Cinnamon still advertises itself as GNOME -
> > we have reasons for doing so which we feel are currently valid, whether you
> > agree with them or not.  Let's move on.
> 
> If that is not changed (Cinnamon advertising itself as GNOME), we will have
> to consider adding conflicts

What is your problem?, cinnamon apps no longer start is gnome.

Bug closed as the original issue is fixed.
Comment 40 Matthias Clasen 2013-10-21 08:47:53 EDT
It is just wrong for cinnamon to claim it is gnome and then blacklist gnome apps. The autostart spec is not great to begin with, but this is just subverting the autostart spec for no good reason at all.

Since you (or Clement, or whoever made this decision) are not willing to fix cinnamon, the simplest solution is to prevent two desktop environments that both claim to be gnome to be installed at the same time.
Comment 41 Colin Guthrie 2013-10-21 08:53:59 EDT
Matthias, while I agree with you in principle, if the problem is only related to OnlyShowIn=GNOME marked .desktops in combination with autostart, then the workaround added in cinnamon-screensaver could be used in other cinnamon pkgs with the same problem.

The remaining problem would be non-autostart OnlyShowIn= .desktops.... this will cause cosmetic issues in menus and UIs and conflicts seems like a reasonable solution for this in the short term.
Comment 42 leigh scott 2013-10-21 09:22:05 EDT
(In reply to Matthias Clasen from comment #40)
> It is just wrong for cinnamon to claim it is gnome and then blacklist gnome
> apps. The autostart spec is not great to begin with, but this is just
> subverting the autostart spec for no good reason at all.
> 
Cinnamon no longer uses the autostart spec and has moved the files to apps instead.

https://github.com/linuxmint/Cinnamon/commit/8e593bfd78c424b126c156eb1e16e9dbd99e3a48


> Since you (or Clement, or whoever made this decision) are not willing to fix
> cinnamon, the simplest solution is to prevent two desktop environments that
> both claim to be gnome to be installed at the same time.


So now the autostart issue is fixed are you still suggesting adding conflicts? as it seems overkill in my opinion just to fix some duplicated menu items which have no affect on gnome itself (just cosmetic).
Comment 43 Matthias Clasen 2013-10-21 09:47:14 EDT
(In reply to leigh scott from comment #42)

> 
> So now the autostart issue is fixed are you still suggesting adding
> conflicts? as it seems overkill in my opinion just to fix some duplicated
> menu items which have no affect on gnome itself (just cosmetic).

Using RequiredComponents for session components is a good step in the right direction, and I appreciate it.

But cinnamons fork of gnome-session still supports the autostart spec and still claims to be GNOME. That still needs to be corrected. I'll talk to clem about it.
Comment 44 Adam Williamson 2013-10-21 10:21:33 EDT
can you guys please take the cinnamon vs. gnome willy-waving to a more appropriate forum? this is a bug report, not a phoronix forum thread.
Comment 46 Marius Adamut 2013-10-22 09:13:20 EDT
*** Bug 1020006 has been marked as a duplicate of this bug. ***
Comment 47 Fedora Update System 2013-10-22 23:31:50 EDT
cinnamon-control-center-2.0.3-1.fc19, muffin-2.0.2-1.fc19, nemo-2.0.1-1.fc19, cinnamon-2.0.3-1.fc19, cinnamon-screensaver-2.0.1-1.fc19, cinnamon-settings-daemon-2.0.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 48 Sam Tuke 2013-10-24 04:22:52 EDT
*** Bug 1021413 has been marked as a duplicate of this bug. ***
Comment 49 Fedora Update System 2013-11-10 02:49:55 EST
cinnamon-control-center-2.0.3-1.fc20, muffin-2.0.2-1.fc20, nemo-2.0.1-1.fc20, cinnamon-2.0.3-1.fc20, cinnamon-screensaver-2.0.1-1.fc20, cinnamon-settings-daemon-2.0.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.