This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1021605 - No Default Syslog
No Default Syslog
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Fedora Docs QA
: Tracking
Depends On: 967521 998573
Blocks: 1001355 1001356
  Show dependency treegraph
 
Reported: 2013-10-21 11:41 EDT by Petr Bokoc
Modified: 2014-01-07 09:04 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 998573
Environment:
Last Closed: 2014-01-07 09:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Bokoc 2013-10-21 11:41:30 EDT
+++ This bug was initially created as a clone of Bug #998573 +++

This is a tracking bug for Change: No Default Syslog
For more details, see: http://fedoraproject.org//wiki/Changes/NoDefaultSyslog

No longer install a traditional syslog service by default. (Specifically, remove rsyslog from the @core or @standard groups in comps.)

--- Additional comment from Zbigniew Jędrzejewski-Szmek on 2013-10-08 15:22:54 EDT ---

http://cgit.freedesktop.org/systemd/systemd/commit/?id=2b8f6883a17b

--- Additional comment from Jaroslav Reznik on 2013-10-11 04:44:57 EDT ---

This message is a reminder that Fedora 20 Accepted Changes 100%
Completed Deadline is on 2013-10-15 [1].

All Accepted Changes has to be code complete and ready to be
validated in the Beta release (optionally by Fedora QA). Required
bug state at this point is ON_QA.

As for several System Wide Changes, Beta Change Deadline is a
point of contingency plan, all incomplete Changes will be 
reported to FESCo for 2013-10-16 meeting. In case of any
questions, don't hesitate to ask Wrangler (jreznik).

[1] https://fedoraproject.org/wiki/Releases/20/Schedule

--- Additional comment from Matthew Miller on 2013-10-15 14:38:53 EDT ---

The basic change to implement this went in, although quite a few packages still bring in rsyslogd as a dependency. I think this feature is fine as it is, and we'll detangle that as part of making separate, targeted Fedora products.

--- Additional comment from Jaroslav Reznik on 2013-10-16 06:56:42 EDT ---

Ok, thanks, moving to ON_QA.

--- Additional comment from Karel Volný on 2013-10-21 08:27:14 EDT ---

just FTR, journal brings bug #967521 - how could we switch to this nonsense if that one is still unresolved?

well, in fact, how could we even have this activated by default, maybe I'm just out of luck googling, but I see no approval for journal to be used?

--- Additional comment from Jóhann B. Guðmundsson on 2013-10-21 08:59:21 EDT ---

Just an FYI This feature is not as simple as no default syslog. We need to fix the entire syslog ( journal/rsyslog/syslog-ng ) implementation in the distribution, come up with virtual provide ( to sub package or not to sub package rsyslog/syslog-ng ) as well as fix roughly 600 packages. Now the proposal on how to do so has been stuck with FPC for 2 years now and until that has been done and fixed this feature can never be considered 100% complete...

--- Additional comment from Matthew Miller on 2013-10-21 09:10:10 EDT ---

(In reply to Jóhann B. Guðmundsson from comment #6)
> Just an FYI This feature is not as simple as no default syslog. We need to
> fix the entire syslog ( journal/rsyslog/syslog-ng ) implementation in the
> distribution, come up with virtual provide ( to sub package or not to sub
> package rsyslog/syslog-ng ) as well as fix roughly 600 packages. Now the
> proposal on how to do so has been stuck with FPC for 2 years now and until
> that has been done and fixed this feature can never be considered 100%
> complete...

I agree that that's the target, and also that it will continue to be slow-moving. This feature was intentionally meant to slice off and accomplish a small portion of that.

--- Additional comment from Brent R Brian on 2013-10-21 09:42:27 EDT ---

My comments are not intended to be a remedy, fix, enoursement of a fix/remedy or anything other than a "data point".

If you guys need a "lab rat", let me know.

B

--- Additional comment from Jóhann B. Guðmundsson on 2013-10-21 11:10:22 EDT ---

(In reply to Matthew Miller from comment #7)
> (In reply to Jóhann B. Guðmundsson from comment #6)
> > Just an FYI This feature is not as simple as no default syslog. We need to
> > fix the entire syslog ( journal/rsyslog/syslog-ng ) implementation in the
> > distribution, come up with virtual provide ( to sub package or not to sub
> > package rsyslog/syslog-ng ) as well as fix roughly 600 packages. Now the
> > proposal on how to do so has been stuck with FPC for 2 years now and until
> > that has been done and fixed this feature can never be considered 100%
> > complete...
> 
> I agree that that's the target, and also that it will continue to be
> slow-moving. This feature was intentionally meant to slice off and
> accomplish a small portion of that.

That is one of the core problem people really as in that feature and related work are just implemented up to the point it serves the feature requester need ( and is labelled as 100% feature completed ) as opposed to the actual work required to implement properly into the distribution.

What we need to do is to keep distribute wide changes as these in a separated branch and switch all the components at the same time when the feature actually is 100% feature complete
Comment 1 Petr Bokoc 2014-01-07 09:04:54 EST
This doesn't really have much impact on the Installation Guide, since we weren't talking about rsyslog a whole lot in the first place. The only mentions can be found in the Logging the Installation appendix and then can stay there.

Note You need to log in before you can comment on or make changes to this bug.