Bug 1021610 - Packstack will not run the openstack::provision unless neutron is available.
Packstack will not run the openstack::provision unless neutron is available.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 4.0
Assigned To: Maru Newby
Nir Magnezi
:
Depends On:
Blocks: 1022661
  Show dependency treegraph
 
Reported: 2013-10-21 11:47 EDT by Lars Kellogg-Stedman
Modified: 2013-12-19 19:30 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.8.dev835.el6ost
Doc Type: Bug Fix
Doc Text:
PackStack generated Tempest configuration can now be used by setting parameter CONFIG_PROVISION_TEMPEST=y to validate an OpenStack install even if you choose to set CONFIG_NEUTRON_INSTALL=n and not setup OpenStack Networking.
Story Points: ---
Clone Of:
: 1022661 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:30:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1242668 None None None Never
OpenStack gerrit 52944 None None None Never

  None (edit)
Description Lars Kellogg-Stedman 2013-10-21 11:47:48 EDT
We would like to use a packstack-generated Tempest configuration to validate a RHOS install both prior to and after an upgrade.  Unfortunately, the current version of packstack will only generate a tempest configuration if (a) it is performing an allinone install and (b) neutron networking is enabled.

We would like to at least fix (b) so that we get an appropriate tempest configuration when nova networking is in use.

marun has proposed the necessary changes upstream:

  https://bugs.launchpad.net/puppet-openstack/+bug/1242668

This requires a related change to the puppet-openstack modules.
Comment 5 Nir Magnezi 2013-11-26 08:52:42 EST
Verified NVR: openstack-packstack-2013.2.1-0.11.dev847.el6ost.noarch

Used packstack to install openstack all in one
Answer file relevant entries:
CONFIG_NEUTRON_INSTALL=n
CONFIG_PROVISION_TEMPEST=y



Result:
tempest configuration file was created at: /var/lib/tempest/etc/tempest.conf
Neutron is not used for networking: 

# grep neutron /var/lib/tempest/etc/tempest.conf | grep -v "#"
neutron=False
Comment 8 errata-xmlrpc 2013-12-19 19:30:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.