Bug 1022661 - Packstack will not run the openstack::provision unless neutron is available.
Packstack will not run the openstack::provision unless neutron is available.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: z3
: 3.0
Assigned To: Maru Newby
Nir Magnezi
: ZStream
Depends On: 1021610
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-23 14:09 EDT by Scott Lewis
Modified: 2016-04-26 21:34 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.34.dev696.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, demo provisioning and tempest configuration were only possible when OpenStack Networking was enabled, and not possible when Nova Network was enabled. This has been fixed by updating demo provisioning and tempest configuration to support Nova Network. Now, demo provisioning and tempest configuration are supported when either OpenStack Networking or Nova Network is enabled.
Story Points: ---
Clone Of: 1021610
Environment:
Last Closed: 2013-11-18 10:19:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nmagnezi: needinfo-


Attachments (Terms of Use)
tempest.conf (9.28 KB, text/plain)
2013-11-11 03:15 EST, Nir Magnezi
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1242668 None None None Never
OpenStack gerrit 52944 None None None Never

  None (edit)
Comment 1 Ami Jeain 2013-10-30 07:32:24 EDT
Maru,

can you tell me plz what are the steps to verify this bug?
Comment 2 Maru Newby 2013-10-31 02:37:29 EDT
To reproduce, invoke packstack to configure tempest for nova network:

packstack --allinone --os-quantum-install=n --provision-tempest=y
Comment 6 Nir Magnezi 2013-11-10 10:30:08 EST
(In reply to Maru Newby from comment #2)
> To reproduce, invoke packstack to configure tempest for nova network:
> 
> packstack --allinone --os-quantum-install=n --provision-tempest=y

Maru,

I followed your instructions, but packstack did not create any configuration file for tempest.
attaching both answer file and packstack log (DEBUG Mode).

let me know if I should re-open the bug.
Comment 9 Maru Newby 2013-11-11 00:36:10 EST
(In reply to Nir Magnezi from comment #6)
> (In reply to Maru Newby from comment #2)
> > To reproduce, invoke packstack to configure tempest for nova network:
> > 
> > packstack --allinone --os-quantum-install=n --provision-tempest=y
> 
> Maru,
> 
> I followed your instructions, but packstack did not create any configuration
> file for tempest.
> attaching both answer file and packstack log (DEBUG Mode).
> 
> let me know if I should re-open the bug.

I'm afraid it's not clear to me from the logs whether there was an error in provisioning or not.  Can you please report as to the status of the following provisioning artifacts?

 - 'demo' tenant and user created (keystone tenant-list, keystone user-list)
 - cirros image created (nova image-list)
 - https://github.com/openstack/tempest.git checked out to /var/lib/tempest
 - /var/lib/tempest/etc/tempest.conf created
Comment 10 Nir Magnezi 2013-11-11 03:13:29 EST
(In reply to Maru Newby from comment #9)
> (In reply to Nir Magnezi from comment #6)
> > (In reply to Maru Newby from comment #2)
> > > To reproduce, invoke packstack to configure tempest for nova network:
> > > 

<snipped

> 
> I'm afraid it's not clear to me from the logs whether there was an error in
> provisioning or not.  Can you please report as to the status of the
> following provisioning artifacts?
> 
>  - 'demo' tenant and user created (keystone tenant-list, keystone user-list)

# keystone tenant-list 
+----------------------------------+----------+---------+
|                id                |   name   | enabled |
+----------------------------------+----------+---------+
| d205b06e489846059a4c11b81a0b8b67 |  admin   |   True  |
| 653b7abb26f64db68c57a1df227c7f3a | alt_demo |   True  |
| 6da35081857443129a96e3fadfc0ebce |   demo   |   True  |
| 98f19eee2ac24ceb85b71d990112604a | services |   True  |
+----------------------------------+----------+---------+

# keystone user-list 
+----------------------------------+----------+---------+------------------+
|                id                |   name   | enabled |      email       |
+----------------------------------+----------+---------+------------------+
| d3a1ea88fe9d49ada5917c9438c7462a |  admin   |   True  |  test@test.com   |
| 29762689be4b468588ca0d1047a9b950 | alt_demo |   True  |                  |
| 1657dd53b9914ede853edf3f14385393 |  cinder  |   True  | cinder@localhost |
| 2d194f1f09904602b82e40155c5d41a7 |   demo   |   True  |                  |
| 2863456717354552a980a4a672bc88ba |  glance  |   True  | glance@localhost |
| 436d244dad4b46f6919f0df46b18fbf0 |   nova   |   True  |  nova@localhost  |
| 307c679296904f18819193ef33aff649 |  swift   |   True  | swift@localhost  |
+----------------------------------+----------+---------+------------------+

>  - cirros image created (nova image-list)

# nova image-list
+--------------------------------------+--------+--------+--------+
| ID                                   | Name   | Status | Server |
+--------------------------------------+--------+--------+--------+
| 42048247-5628-4941-a204-fe6c88842ba2 | cirros | ACTIVE |        |
+--------------------------------------+--------+--------+--------+

>  - https://github.com/openstack/tempest.git checked out to /var/lib/tempest
>  - /var/lib/tempest/etc/tempest.conf created

I stand corrected, just found It.
I was not aware of it's location, sorry about that.

Will attach it in my next comment, please review and let me know if it looks as expected.
Comment 11 Nir Magnezi 2013-11-11 03:15:11 EST
Created attachment 822317 [details]
tempest.conf
Comment 12 Nir Magnezi 2013-11-11 03:18:27 EST
it might be an issue for a different bug (if any), but: why does it uses localhost rather than real IP Addresses?

# grep localhost /var/lib/tempest/etc/tempest.conf
db_uri = mysql://nova:secret@localhost/nova
ec2_url = http://localhost:8773/services/Cloud
s3_url = http://localhost:3333
Comment 14 Lon Hohberger 2013-11-11 12:44:47 EST
I think the issue was whether or not tempest.conf was getting created -- it is, but there may be certain configurations where the URLs for the APIs as noted above are incorrect - that should be the focus of a different bugzilla, in my opinion.
Comment 15 Nir Magnezi 2013-11-11 15:04:45 EST
(In reply to Lon Hohberger from comment #14)
> I think the issue was whether or not tempest.conf was getting created -- it
> is, but there may be certain configurations where the URLs for the APIs as
> noted above are incorrect - that should be the focus of a different
> bugzilla, in my opinion.

Agreed.

Following to Comment #10, Verified NVR: openstack-packstack-2013.1.1-0.35.dev696.el6ost.noarch
Comment 16 Maru Newby 2013-11-12 03:31:42 EST
(In reply to Nir Magnezi from comment #12)
> it might be an issue for a different bug (if any), but: why does it uses
> localhost rather than real IP Addresses?
> 
> # grep localhost /var/lib/tempest/etc/tempest.conf
> db_uri = mysql://nova:secret@localhost/nova
> ec2_url = http://localhost:8773/services/Cloud
> s3_url = http://localhost:3333

The values in question are not set by the puppet-tempest module and are likely not relevant in a default provisioning scenario.
Comment 17 errata-xmlrpc 2013-11-18 10:19:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1510.html

Note You need to log in before you can comment on or make changes to this bug.