Bug 1021627 - cinder-backup service installation
cinder-backup service installation
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Francesco Vollero
Martin Magr
: OtherQA, Triaged
: 1018548 (view as bug list)
Depends On: 884748
Blocks: 1018548
  Show dependency treegraph
 
Reported: 2013-10-21 12:31 EDT by Eric Harney
Modified: 2016-01-06 05:02 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:30:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 59992 None None None Never

  None (edit)
Description Eric Harney 2013-10-21 12:31:25 EDT
Description of problem:
Packstack does not appear to enable the cinder-backup service.  This should be done with an allinone install, defaulting to using Swift as a backup target if Swift is installed.

Version-Release number of selected component (if applicable):
2013.2.1 dev763

Additional info:
# chkconfig --list openstack-cinder-backup
openstack-cinder-backup	0:off	1:off	2:off	3:off	4:off	5:off	6:off

cinder.conf settings:
#backup_driver=cinder.backup.drivers.swift
backup_swift_user=admin
backup_swift_password=asdfasdf
backup_swift_url=http://192.168.122.xxx:8080/v1/AUTH_
Comment 1 Francesco Vollero 2013-11-27 10:39:04 EST
There is a change in puppet-cinder that will enable the installation of cinder-backup service, waiting upstream to be properly fixed and arranged, once this is done, we could support it in packstack.

https://review.openstack.org/#/c/58792/
Comment 3 Alvaro Lopez Ortega 2013-12-05 09:51:53 EST
Merged
Comment 6 Ivan Chavero 2013-12-11 13:35:19 EST
*** Bug 1018548 has been marked as a duplicate of this bug. ***
Comment 7 Martin Magr 2013-12-12 08:52:25 EST
[root@virtual-rhel ~]# cat /etc/cinder/cinder.conf  | grep backup | grep -v "^#"
backup_swift_url=http://192.168.122.15:8080/v1/AUTH_
backup_swift_container=volumes_backup
backup_swift_object_size=52428800
backup_swift_retry_attempts=3
backup_swift_retry_backoff=2
backup_driver=cinder.backup.drivers.swift
backup_topic=cinder-backup
backup_manager=cinder.backup.manager.BackupManager
backup_api_class=cinder.backup.api.API
backup_name_template=backup-%s

[root@virtual-rhel ~]# cat /etc/cinder/cinder.conf  | grep backup_swift
#backup_swift_url=http://localhost:8080/v1/AUTH_
backup_swift_url=http://192.168.122.15:8080/v1/AUTH_
#backup_swift_auth=per_user
#backup_swift_user=<None>
#backup_swift_key=<None>
#backup_swift_container=volumebackups
backup_swift_container=volumes_backup
#backup_swift_object_size=52428800
backup_swift_object_size=52428800
#backup_swift_retry_attempts=3
backup_swift_retry_attempts=3
#backup_swift_retry_backoff=2
backup_swift_retry_backoff=2

swift_user and swift_password are missing. Is this a big deal Eric?
Comment 8 Eric Harney 2013-12-17 14:13:32 EST
(In reply to Martin Magr from comment #7)
> swift_user and swift_password are missing. Is this a big deal Eric?

Well, my opinion is that since Packstack is setting up Swift, there should be as few steps as possible to make a volume backup work after an allinone install.  Setting these vars is required for that, and seems like a reasonable thing for Packstack to do.

This bug covered the initial basics as far as the service itself but I think we need to get things further along in 5.0.

Could Packstack create the volume_backups Swift container as well?
Comment 10 errata-xmlrpc 2013-12-19 19:30:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.