Bug 102171 - User accounts from central server (NIS,LDAP)
User accounts from central server (NIS,LDAP)
Status: CLOSED DUPLICATE of bug 65331
Product: Red Hat Raw Hide
Classification: Retired
Component: authconfig (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-08-12 01:24 EDT by Gavin Graham
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-13 13:46:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gavin Graham 2003-08-12 01:24:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If you do a first time login to a PC where user account information is not
local, you will not have a home dir to log in to.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Create a Central User Database (NIS,LDAP)
2.Set up workstation to query user databse
3.try to log in on workstation

Actual Results:  You will log in with / as your home and no basic settings.

Expected Results:  To have an account the same a local login account.

Additional info:

This can be easily fixed by having the following line by default in

the following line:
session    optional     pam_mkhomedir.so skel=/etc/skel umask=022
Comment 1 Gavin Graham 2003-08-12 18:50:27 EDT
Correction to comments.

To correct this behaviour, the following line needs to be added to
/etc/pam.d/system-auth and NOT /etc/pam.d/serviceconf:

session     optional      /lib/security/$ISA/pam_mkhomedir.so skel=/etc/skel

This needs to be added by the authentication configuration program upon service
Comment 2 Jindrich Novy 2004-09-21 10:56:40 EDT
I'll reassign this to authconfig as an RFE.
Comment 3 Tomas Mraz 2004-12-13 13:43:55 EST

*** This bug has been marked as a duplicate of 65331 ***

Note You need to log in before you can comment on or make changes to this bug.