Bug 65331 - RFE (+patch): support for configuring pam_mkhomedir through authconfig
RFE (+patch): support for configuring pam_mkhomedir through authconfig
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: authconfig (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
: FutureFeature
: 102171 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 05:07 EDT by Panu Matilainen
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 09:42:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2002-05-22 05:07:01 EDT
First of all: I know this might be a fairly uncommon requirement...
I did a patch that adds support for configuring PAM to use pam_mkhomedir with
authconfig, it's useful at least in here so that you can install a basically
standalone workstation, plug it into company network, login and it "just works"
since it creates a local homedir for the user automatically.

The question is
a) are you interested at all in such functionality?
b) if yes would you want to have it only as command line option or have the
option in TUI+GUI also? (so far the patch only supports cli + tui and I guess
the option is obscure enough it might not make sense to add it to the tui/gui
tools at all)

P.S. Didn't include the patch here yet as it needs cleaning up and I'd like to
know whether to include the tui/gui part at all first.
Comment 1 Tomas Mraz 2004-12-13 13:44:03 EST
*** Bug 102171 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Mraz 2005-09-08 09:42:40 EDT
This is too specialized functionality which would complicate the authconfig UI
unnecessarily. Authconfig should however try to preserve parts of the
system-auth config if possible.
Comment 3 Gavin Graham 2005-09-08 17:52:33 EDT
There have been quite a few occasions where it would have been usefull to have
this so it make me question how specialised it is.
Maybe if it was there, more people would have a use for it.

Note You need to log in before you can comment on or make changes to this bug.