Bug 1021776 - quota: deprecate or warn with for "volume set quota on" cmd
quota: deprecate or warn with for "volume set quota on" cmd
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Anuradha
Saurabh
: ZStream
Depends On:
Blocks: 1024626
  Show dependency treegraph
 
Reported: 2013-10-22 01:27 EDT by Saurabh
Modified: 2016-09-19 22:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.52rhs-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Previously, you could enable or disable quota with the 'gluster volume set <VOLNAME> quota on/off' command. As a result, the 'volume set' command displayed 'success' message incorrectly to the user on enabling and disabling quota. With this fix, this option is deprecated and the user is warned about the issue and an appropriate message is displayed.
Story Points: ---
Clone Of:
: 1024626 (view as bug list)
Environment:
Last Closed: 2014-02-25 02:42:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-10-22 01:27:30 EDT
Description of problem:

Presently we have an issue about enabling quota with volume set command.

This actually as per developers itself is not a correct way of enabling quota translator.

As we already have gluster volume quota $volname enable command, hence request  you to deprecate or warn people about the problem that they may face with enabling quota along with "volume set" command.

Earlier also to avoid confusion we had filed a BZ 1001573
which was closed as NOTABUG
Comment 2 Anuradha 2013-11-07 07:59:44 EST
Patch posted for review on branch rhs-2.1 :
https://code.engineering.redhat.com/gerrit/#/c/14827/

Patch posted for review on branch rhs-2.1-u1 :
 https://code.engineering.redhat.com/gerrit/#/c/14835/
Comment 4 Anuradha 2013-12-19 10:40:06 EST
Patch for rhs-2.1 posted on:
https://code.engineering.redhat.com/gerrit/#/c/17725/

Upstream patch url:
http://review.gluster.org/#/c/6512/
Comment 5 Saurabh 2013-12-24 03:13:01 EST
verified on  glusterfs-3.4.0.52rhs-1.el6rhs


[root@quota5 ~]# gluster volume set dist-rep quota enable
volume set: failed:  'gluster volume set <VOLNAME> quota enable' is deprecated. Use 'gluster volume quota <VOLNAME> enable' instead.
[root@quota5 ~]# gluster volume info dist-rep
 
Volume Name: dist-rep
Type: Distributed-Replicate
Volume ID: 4ee792db-48f0-463e-8ad1-d1507d161227
Status: Started
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: 10.70.35.219:/rhs/brick1/d1r1
Brick2: 10.70.35.108:/rhs/brick1/d1r2
Brick3: 10.70.35.191:/rhs/brick1/d2r1
Brick4: 10.70.35.144:/rhs/brick1/d2r2
Brick5: 10.70.35.219:/rhs/brick1/d3r1
Brick6: 10.70.35.108:/rhs/brick1/d3r2
Brick7: 10.70.35.191:/rhs/brick1/d4r1
Brick8: 10.70.35.144:/rhs/brick1/d4r2
Brick9: 10.70.35.219:/rhs/brick1/d5r1
Brick10: 10.70.35.108:/rhs/brick1/d5r2
Brick11: 10.70.35.191:/rhs/brick1/d6r1
Brick12: 10.70.35.144:/rhs/brick1/d6r2
Comment 6 Pavithra 2014-01-03 04:20:53 EST
Can you please verify if the doc text is technically correct?
Comment 7 Anuradha 2014-01-03 06:09:09 EST
Doc text is correct.
Comment 9 errata-xmlrpc 2014-02-25 02:42:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.