This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1024626 - quota: deprecate or warn with for "volume set quota on" cmd
quota: deprecate or warn with for "volume set quota on" cmd
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
pre-release
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anuradha
:
Depends On: 1021776
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-30 02:23 EDT by Anuradha
Modified: 2016-09-19 22:00 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1021776
Environment:
Last Closed: 2014-11-11 03:24:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-30 02:26:21 EDT
REVIEW: http://review.gluster.org/6192 (cli : enabling quota using volume set cmd deprecated) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 2 Anand Avati 2013-10-30 02:30:30 EDT
REVIEW: http://review.gluster.org/6192 (cli : enabling quota using volume set cmd deprecated) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 3 Anand Avati 2013-10-30 05:53:48 EDT
REVIEW: http://review.gluster.org/6192 (cli : enabling/disabling quota using volume set cmd deprecated) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 4 Anand Avati 2013-11-12 06:52:40 EST
REVIEW: http://review.gluster.org/6192 (cli : enabling/disabling quota using volume set cmd deprecated) posted (#4) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 5 Anand Avati 2013-12-11 06:46:33 EST
COMMIT: http://review.gluster.org/6192 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 4bbbda2017be3cfae57c122d70d11c9470364f63
Author: Anuradha <atalur@redhat.com>
Date:   Wed Oct 30 11:57:38 2013 +0530

    cli : enabling/disabling quota using volume set cmd deprecated
    
    Using the command 'gluster volume set <volname> quota {on|off}'
    doesn't really enable/disable quota. So, a message to the user is
    provided. Message asks the user to use 'gluster volume
    quota <volname> {enable|disable}' instead.
    
    Change-Id: Ic4e12d5f8298ca9233639b4f6f8601ed6937fecb
    BUG: 1024626
    Signed-off-by: Anuradha <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6192
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Anand Avati 2013-12-16 03:30:40 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#1) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 7 Anand Avati 2013-12-17 08:25:44 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#2) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 8 Anand Avati 2013-12-17 08:43:00 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#3) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 9 Anand Avati 2013-12-17 08:52:10 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#4) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 10 Anand Avati 2013-12-19 07:32:03 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#5) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 11 Anand Avati 2013-12-19 07:50:18 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated) posted (#6) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 12 Anand Avati 2013-12-19 08:38:16 EST
REVIEW: http://review.gluster.org/6512 (glusterd : enable/disable quota using volume set cmd deprecated.) posted (#7) for review on master by Anuradha Talur (atalur@redhat.com)
Comment 13 Anand Avati 2013-12-19 11:09:01 EST
COMMIT: http://review.gluster.org/6512 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 7b392ad395ae7597a3ed3a1aa7fe61faefd96368
Author: Anuradha Talur <atalur@redhat.com>
Date:   Sun Dec 15 13:26:15 2013 +0000

    glusterd : enable/disable quota using volume set cmd deprecated.
    
    Using the command 'gluster volume set <volname> quota {on|off}'
    doesn't really enable/disable quota. So, a message to the user is
    provided. Message asks the user to use 'gluster volume
    quota <volname> {enable|disable}' instead.
    
    Improvement of the previous method to solve the issue.
    
    Change-Id: Ibeda35bb49ec7b541d53e592b48fd132380fce76
    BUG: 1024626
    Signed-off-by: Anuradha Talur <atalur@redhat.com>
    Reviewed-on: http://review.gluster.org/6512
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 14 Niels de Vos 2014-09-22 08:32:28 EDT
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/
Comment 15 Niels de Vos 2014-11-11 03:24:20 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users

Note You need to log in before you can comment on or make changes to this bug.