Bug 1021785 - the error message "scsi generic interface too old" is wrong more often than not
the error message "scsi generic interface too old" is wrong more often than not
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
:
Depends On:
Blocks: 1021788
  Show dependency treegraph
 
Reported: 2013-10-22 02:10 EDT by Sibiao Luo
Modified: 2015-07-22 02:04 EDT (History)
10 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.449.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1021788 (view as bug list)
Environment:
Last Closed: 2015-07-22 02:04:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-10-22 02:10:37 EDT
Description of problem:
boot guest specified passthough iSCSI LUN with '-snapshot/snapshot=on', but QEMU will quit with prompt message "scsi-block: scsi generic interface too old", this prompt message is misleading for users who thought its command line wrong.
Add '-snapshot/snapshot=on' means that write to temporary files instead of disk image files, QEMU should give a correctly or friendly prompt message if QEMU not support or make it works well.

Version-Release number of selected component (if applicable):
host info:
2.6.32-424.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.414.el6.x86_64
seabios-0.6.1.2-28.el6.x86_64
guest info:
2.6.32-424.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.prepare a iSCSI LUN.
# ls -lh /dev/disk/by-path/ip-10.66.90.100\:3260-iscsi-iqn.2001-05.com.equallogic\:0-8a0906-0971f7d03-1dff49b26885073d-s2-sluo-172259-lun-0
lrwxrwxrwx. 1 root root 9 Oct 22 01:45 /dev/disk/by-path/ip-10.66.90.100:3260-iscsi-iqn.2001-05.com.equallogic:0-8a0906-0971f7d03-1dff49b26885073d-s2-sluo-172259-lun-0 -> ../../sdb
2.boot guest specified passthough iSCSI LUN with '-snapshot/snapshot=on'.
e.g1:...-drive file=/dev/disk/by-path/ip-10.66.90.100\:3260-iscsi-iqn.2001-05.com.equallogic\:0-8a0906-0971f7d03-1dff49b26885073d-s2-sluo-172259-lun-0,if=none,id=drive-data-disk,format=raw,aio=native -device virtio-scsi-pci,bus=pci.0,addr=0x7,id=scsi0 -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0 *-snapshot*
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0: scsi-block: scsi generic interface too old
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0: Device 'scsi-block' could not be initialized
/etc/qemu-ifdown: could not launch network script
e.g2:...-drive file=/dev/disk/by-path/ip-10.66.90.100\:3260-iscsi-iqn.2001-05.com.equallogic\:0-8a0906-0971f7d03-1dff49b26885073d-s2-sluo-172259-lun-0,if=none,id=drive-data-disk,format=raw,aio=native,*snapshot=on* -device virtio-scsi-pci,bus=pci.0,addr=0x7,id=scsi0 -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0: scsi-block: scsi generic interface too old
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi0.0: Device 'scsi-block' could not be initialized
/etc/qemu-ifdown: could not launch network script
3.

Actual results:
QEMU will quit with prompt message "scsi-block: scsi generic interface too old", this prompt message is misleading for users who thought its command line wrong.

Expected results:
QEMU should give a more correctly or friendly prompt message if QEMU not support it or make it works well.

Additional info:
Comment 1 Sibiao Luo 2013-10-22 02:14:11 EDT
BTW, also tried that it can make live snapshot from a passthrough iSCSI LUN to anther iSCSI LUN successfully.
Comment 2 Paolo Bonzini 2013-10-24 19:17:12 EDT
The command line is incorrect, so I am changing the subject.
Comment 3 Fam Zheng 2014-04-16 01:59:12 EDT
Posted a patch to upstream:

http://lists.nongnu.org/archive/html/qemu-devel/2014-04/msg02404.html
Comment 5 Jeff Nelson 2014-12-19 13:50:23 EST
Fix included in qemu-kvm-0.12.1.2-2.449.el6
Comment 7 Sibiao Luo 2015-02-26 22:34:56 EST
Verify this issue on qemu-kvm-0.12.1.2-2.454.el6.x86_64 with the same steps.

host info:
qemu-kvm-0.12.1.2-2.454.el6.x86_64

e.g:...-drive file=/dev/disk/by-path/ip-127.0.0.1:3260-iscsi-iqn.2014-06.com.example:server.target2-lun-1,if=none,id=drive-data-disk,format=raw,aio=native -device virtio-scsi-pci,bus=pci.0,addr=0x7,id=scsi1 -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi1.0 -snapshot
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi1.0: cannot get SG_IO version number: Operation not supported.  Is this a SCSI device?
qemu-kvm: -device scsi-block,drive=drive-data-disk,id=data-disk,bus=scsi1.0: Device 'scsi-block' could not be initialized
/etc/qemu-ifdown: could not launch network script

Base on above, this issue has been fixed correctly, move to VERIFIED status, please correct me if any mistake, thanks.

Best Regards,
sluo
Comment 10 errata-xmlrpc 2015-07-22 02:04:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1275.html

Note You need to log in before you can comment on or make changes to this bug.