Bug 1021816 - [RHSC] - Rebalance status dialog gives "No Rebalance ever happened on Volume"
[RHSC] - Rebalance status dialog gives "No Rebalance ever happened on Volume"
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
RamaKasturi
: ZStream
Depends On: 1020331
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 03:21 EDT by RamaKasturi
Modified: 2015-05-13 12:26 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:42:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rebalance status dialog (183.33 KB, image/png)
2013-10-22 03:21 EDT, RamaKasturi
no flags Details

  None (edit)
Description RamaKasturi 2013-10-22 03:21:16 EDT
Created attachment 814868 [details]
Rebalance status dialog

Description of problem:
 Rebalance status dialog gives "No Rebalance ever happened on Volume"

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.0.scratch.beta1.el6_4.noarch

How reproducible:
Intermittently

Steps to Reproduce:
1. create two volumes distribute and distribute replicate.
2. Now start rebalance on distribute replicate volume.
3. Once rebalance is started click on the status button.


Actual results:
Rebalance status dialog says "No rebalance has ever run on this volume: <volName>". 

volName dispalyed in the above output is of the another volume and not of the same on which rebalance status is being queried.(attaching screen shot for the same)

Expected results:
Rebalance status should give the output same as that of CLI.

Additional info:
Comment 2 RamaKasturi 2013-10-22 03:40:05 EDT
Link for the sos reports 

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1021816/
Comment 3 Dusmant 2013-10-24 02:22:40 EDT
*** Bug 1021497 has been marked as a duplicate of this bug. ***
Comment 4 RamaKasturi 2013-11-12 02:36:35 EST
Shubendu, could you please tell me what was causing the issue and what is the fix ?
Comment 5 Shubhendu Tripathi 2013-11-12 22:25:02 EST
This was happening because gluster was returning status as UNKNOWN from the hosts that were not participating in the volume. The same is fixed as part of gluster bug 1027094 and it should be working fine.
Comment 6 Shubhendu Tripathi 2013-11-14 06:34:44 EST
The bugs BZ#1020331 BZ#1027094 are duplicate/

This was happening because gluster was returning status as "Not Started" from the hosts that were not participating in the volume. The same is fixed as part of gluster bug 1020331 and it should be working fine.
Comment 7 RamaKasturi 2013-11-14 08:44:42 EST
verified in CB7 (rhsc-2.1.2-0.23.master.el6_5.noarch) and works fine.
Comment 9 errata-xmlrpc 2014-02-25 02:42:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.