Bug 1021874 - Asset repository table doesn't refresh its content after I delete a kjar
Asset repository table doesn't refresh its content after I delete a kjar
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER5
: 6.0.0
Assigned To: manstis
Ivo Bek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 04:59 EDT by Ivo Bek
Modified: 2013-12-05 08:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 08:22:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Bek 2013-10-22 04:59:32 EDT
Description of problem:

When I delete a kjar in Guvnor M2 Repository view, the table, containing all the assets, won't refresh. I think it's caused by checking the checkbox to not see any more popups.

How reproducible:


Steps to Reproduce:
1. Deploy a kjar
2. Delete the kjar in Asset repository
3. Check that you don't want to see popups any more. This time the table should be refreshed.
4. Deploy a kjar again
5. Delete the kjar
6. See that the asset is still in the table. After the manual refresh the asset will disappear.
Comment 1 manstis 2013-10-24 11:15:13 EDT
I could replicate this issue with FireFox (12.0) and tracked it down to a bug reported against Mozilla: https://bugzilla.mozilla.org/show_bug.cgi?id=633154. The error in the Mozilla BZ is observed in the log (or at least it is shown at runtime within the IDE). Since this appears to be a browser issue, and there is a work-around I propose this BZ is closed. WDYT?
Comment 2 Ivo Bek 2013-10-25 07:38:07 EDT
Isn't there any other option how to avoid the issue? For example to asynchronously refresh the table after the delete operation. An another solution could be to catch the NS_ERROR_NOT_AVAILABLE in java or embed javascript when you show the dialog. Do you believe it's possible?
Comment 3 Ivo Bek 2013-12-05 08:22:05 EST
This bug is no more relevant. The "remove" button has been removed, see BZ 1038164. So I change the status to not a bug, since it's not possible to get to the state of this issue any more.

Note You need to log in before you can comment on or make changes to this bug.