Bug 1021881 - [abrt] dnf-0.4.5-1.fc20: commands.py:1474:doCommand:AttributeError: 'Repo' object has no attribute 'metalink_data'
[abrt] dnf-0.4.5-1.fc20: commands.py:1474:doCommand:AttributeError: 'Repo' ob...
Status: CLOSED DUPLICATE of bug 1020934
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e19b0ce51b90f6132753ee7d1ec...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-22 05:12 EDT by Philipp Dreimann
Modified: 2013-10-22 05:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 05:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.84 KB, text/plain)
2013-10-22 05:13 EDT, Philipp Dreimann
no flags Details
File: environ (2.12 KB, text/plain)
2013-10-22 05:13 EDT, Philipp Dreimann
no flags Details

  None (edit)
Description Philipp Dreimann 2013-10-22 05:12:57 EDT
Description of problem:
by executing "dnf repolist"

Version-Release number of selected component:
dnf-0.4.5-1.fc20

Additional info:
reporter:       libreport-2.1.8
cmdline:        /usr/bin/python /usr/bin/dnf repolist
executable:     /usr/bin/dnf
kernel:         3.11.5-302.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
commands.py:1474:doCommand:AttributeError: 'Repo' object has no attribute 'metalink_data'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1305, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 1474, in doCommand
    mdts = repo.metalink_data.repomd.timestamp
AttributeError: 'Repo' object has no attribute 'metalink_data'

Local variables in innermost frame:
verbose: False
on_ehibeg: '\x1b[32m\x1b[1m'
repos: [<Repo fedora>, <Repo fedora-debuginfo>, <Repo fedora-source>, <Repo google-chrome>, <Repo google-talkplugin>, <Repo owncloud>, <Repo rpmfusion-free>, <Repo rpmfusion-free-debuginfo>, <Repo rpmfusion-free-rawhide>, <Repo rpmfusion-free-rawhide-debuginfo>, <Repo rpmfusion-free-rawhide-source>, <Repo rpmfusion-free-source>, <Repo rpmfusion-free-updates>, <Repo rpmfusion-free-updates-debuginfo>, <Repo rpmfusion-free-updates-source>, <Repo rpmfusion-free-updates-testing>, <Repo rpmfusion-free-updates-testing-debuginfo>, <Repo rpmfusion-free-updates-testing-source>, <Repo rpmfusion-nonfree>, <Repo rpmfusion-nonfree-debuginfo>, <Repo rpmfusion-nonfree-rawhide>, <Repo rpmfusion-nonfree-rawhide-debuginfo>, <Repo rpmfusion-nonfree-rawhide-source>, <Repo rpmfusion-nonfree-source>, <Repo rpmfusion-nonfree-updates>, <Repo rpmfusion-nonfree-updates-debuginfo>, <Repo rpmfusion-nonfree-updates-source>, <Repo rpmfusion-nonfree-updates-testing>, <Repo rpmfusion-nonfree-updates-testing-debuginfo>, <Repo rpmfusion-nonfree-updates-testing-source>, <Repo steam>, <Repo updates>, <Repo updates-debuginfo>, <Repo updates-source>, <Repo updates-testing>, <Repo updates-testing-debuginfo>, <Repo updates-testing-source>]
cols: []
ui_endis_wid: 0
num: 37941
ehibeg: ''
arg: 'enabled'
rid: 'fedora'
hiend: ''
on_hiend: '\x1b(B\x1b[m'
dhibeg: ''
self: <dnf.cli.commands.RepoListCommand object at 0x2765450>
on_dhibeg: '\x1b[31m'
ui_excludes_num: ''
tot_num: 37941
extcmds: []
repo: <Repo fedora>
_num2ui_num: <function _num2ui_num at 0x28df8c0>
ui_enabled: ''
ui_num: u'37.941'
enabled: True
_repo_size: <function _repo_size at 0x28df7d0>
enabled_repos: [<Repo updates-testing>, <Repo owncloud>, <Repo google-talkplugin>, <Repo fedora>, <Repo rpmfusion-free-rawhide>, <Repo rpmfusion-nonfree-rawhide>, <Repo updates>, <Repo google-chrome>, <Repo steam>]
_repo_match: <function _repo_match at 0x28df848>
basecmd: 'repolist'
force_show: False
Comment 1 Philipp Dreimann 2013-10-22 05:13:03 EDT
Created attachment 814908 [details]
File: backtrace
Comment 2 Philipp Dreimann 2013-10-22 05:13:07 EDT
Created attachment 814909 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-10-22 05:38:30 EDT

*** This bug has been marked as a duplicate of bug 1020934 ***

Note You need to log in before you can comment on or make changes to this bug.