Bug 1020934 - traceback in "dnf repolist"
Summary: traceback in "dnf repolist"
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdeněk Pavlas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1021881 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-18 14:30 UTC by Michal Schmidt
Modified: 2014-02-02 22:29 UTC (History)
9 users (show)

Fixed In Version: hawkey-0.4.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 00:39:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Schmidt 2013-10-18 14:30:56 UTC
Description of problem:
I am seeing python tracebacks with "dnf repolist" and "dnf repolist -v".

Version-Release number of selected component (if applicable):
dnf-0.4.4-1.fc20.noarch
hawkey-0.4.2-1.git4c51f65.fc20.x86_64
librepo-1.2.1-3.bc2c8a5.fc20.x86_64
rpm-4.11.1-7.fc20.x86_64

How reproducible:
always

Steps to Reproduce:

$ sudo dnf repolist
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1305, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 1474, in doCommand
    mdts = repo.metalink_data.repomd.timestamp
AttributeError: 'Repo' object has no attribute 'metalink_data'

$ sudo dnf repolist -v
Config time: 0.007
dnf version: 0.4.4
repo: using cache for: updates-testing
repo: using cache for: fedora
repo: using cache for: rpmfusion-free-rawhide
not found deltainfo for: RPM Fusion for Fedora Rawhide - Free
repo: using cache for: rhpkg
not found deltainfo for: rhpkg for Fedora 20
repo: using cache for: rpmfusion-nonfree-rawhide
not found deltainfo for: RPM Fusion for Fedora Rawhide - Nonfree
repo: using cache for: updates
hawkey sack setup time: 0.193
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 272, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 133, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1305, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 1514, in doCommand
    ts = repo.metalink_data.repomd.timestamp
AttributeError: 'Repo' object has no attribute 'metalink_data'

Comment 1 Zdeněk Pavlas 2013-10-18 15:12:24 UTC
Fixed in https://github.com/zde/dnf/

Comment 2 Zdeněk Pavlas 2013-10-22 09:38:30 UTC
*** Bug 1021881 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2013-10-30 10:09:11 UTC
dnf-0.4.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.6-1.fc20

Comment 4 Fedora Update System 2013-10-30 17:14:29 UTC
Package dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, hawkey-0.4.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.6-1.fc20 libsolv-0.4.0-1.gitd49d319.fc20 hawkey-0.4.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20333/libsolv-0.4.0-1.gitd49d319.fc20,hawkey-0.4.4-1.fc20,dnf-0.4.6-1.fc20
then log in and leave karma (feedback).

Comment 5 lnie 2013-10-31 02:55:44 UTC
when run "dnf repolist","dnf repolist -v"with the updates above see bug 1025098

Comment 6 Fedora Update System 2013-10-31 14:22:50 UTC
hawkey-0.4.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hawkey-0.4.4-1.fc20

Comment 7 Fedora Update System 2013-10-31 17:42:37 UTC
Package hawkey-0.4.4-1.fc20, dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, librepo-1.3.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.4.4-1.fc20 dnf-0.4.6-1.fc20 libsolv-0.4.0-1.gitd49d319.fc20 librepo-1.3.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20406/dnf-0.4.6-1.fc20,libsolv-0.4.0-1.gitd49d319.fc20,librepo-1.3.0-1.fc20,hawkey-0.4.4-1.fc20
then log in and leave karma (feedback).

Comment 8 lnie 2013-11-01 04:14:53 UTC
fixed with the updates above

Comment 9 Fedora Update System 2013-11-12 00:39:44 UTC
hawkey-0.4.4-1.fc20, dnf-0.4.6-1.fc20, libsolv-0.4.0-1.gitd49d319.fc20, librepo-1.3.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.