Bug 1021890 - Removing thin LV results in exception
Removing thin LV results in exception
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 1022366 (view as bug list)
Depends On:
Blocks: F20BetaBlocker 1023186
  Show dependency treegraph
 
Reported: 2013-10-22 05:33 EDT by Marian Csontos
Modified: 2014-03-12 09:04 EDT (History)
13 users (show)

See Also:
Fixed In Version: python-blivet-0.23.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1023186 (view as bug list)
Environment:
Last Closed: 2013-11-06 13:27:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda crash report (221.91 KB, application/x-gzip)
2013-10-22 05:33 EDT, Marian Csontos
no flags Details

  None (edit)
Description Marian Csontos 2013-10-22 05:33:03 EDT
Created attachment 814919 [details]
anaconda crash report

Description of problem:
Attempt to remove LV to be created, results in crash

Version-Release number of selected component (if applicable):
anaconda-20.25-1

How reproducible:
I have seen this second time.

Steps to Reproduce:
1. select "LVM thin" profile
2. click link to create default layout on free disks
3. try to remove fedora-root thin LV

Actual results:
Crash in anaconda

Expected results:
LV should be removed

Additional info:
Proposing as Beta Blocker as not meeting following Custom Partitioning requirement:

When using the custom partitioning flow, the installer must be able to:
- Remove a planned storage volume from the planned layout
Comment 1 Marian Csontos 2013-10-22 05:48:46 EDT
Update:
Reproducible: 4/4

More accurate steps:
1. Select "I want to review/modify my disk..."\
2. Change Partition scheme to "LVM Thin Provisioning"
3. Continue
4. In "New Fedora 20 Installation" click "Click here to create them automatically"
5. Select / (fedora-root) and "-" to remove

Works fine for /boot (partition) and swap (which is plain (linear) LV)
Comment 2 David Lehman 2013-10-22 11:47:52 EDT
I am using TC5 (anaconda-20.25.1-1) and have been unable to reproduce the reported failure. Please try with TC5 and see if the problem persists.
Comment 3 Marian Csontos 2013-10-23 03:29:04 EDT
Still the same I think - opened BZ 1022366 so abrt catches duplicates.
Comment 4 Marian Csontos 2013-10-23 03:29:32 EDT
*** Bug 1022366 has been marked as a duplicate of this bug. ***
Comment 5 Marian Csontos 2013-10-23 07:51:53 EDT
When I created other mountpoints (thin LV) those could be removed.
I removed swap on the VG and then removed root LV just fine.

I created LV /home and thin-LV /, attempt to remove / resulted in crash.

Seems that happens only when there are other non-thin LVs.
Comment 6 David Lehman 2013-10-23 12:09:45 EDT
I was able to reproduce it. It happens when you remove the last thin lv from a new/non-existent pool. I'm testing a patch.
Comment 7 David Lehman 2013-10-23 12:12:13 EDT
My test of the patch was successful. Please try it for yourself to verify:

  http://dlehman.fedorapeople.org/updates/updates-1021890.0.img

Thanks.
Comment 8 Adam Williamson 2013-10-23 12:26:48 EDT
Discussed at 2013-10-23 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-23/f20-blocker-review.2013-10-23-16.00.log.txt . Accepted as a blocker per Beta criterion "When using the custom partitioning flow, the installer must be able to: ... Remove a planned storage volume from the planned layout" - https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Custom_partitioning .
Comment 9 Marian Csontos 2013-10-25 05:33:43 EDT
The update works for me. Thanks!
Comment 10 Chris Murphy 2013-10-27 22:58:12 EDT
Not reproducible with Fedora-Live-Desktop-x86_64-20-Beta-TC6.iso.
Comment 11 David Lehman 2013-10-29 12:26:01 EDT
I put the wrong bug in the commit message for this one. It should be fixed in python-blivet-0.23.2-1.
Comment 12 Chris Murphy 2013-10-29 19:54:38 EDT
Confirming squashed status, does not occur with beta TC6: python-blivet-0.23.2-1, anaconda-20.25.4-1.
Comment 13 Adam Williamson 2013-11-06 13:27:25 EST
python-blivet-0.23.2-1.fc20 went stable as part of FEDORA-2013-20033 and the fix was verified, so this can be closed.

Note You need to log in before you can comment on or make changes to this bug.