Bug 1023186 - Removing last thin LV results in exception
Removing last thin LV results in exception
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On: 1021890
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-24 16:16 EDT by David Lehman
Modified: 2014-06-18 00:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: python-blivet-0.18.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1021890
Environment:
Last Closed: 2014-06-13 07:41:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lehman 2013-10-24 16:16:03 EDT
+++ This bug was initially created as a clone of Bug #1021890 +++

Description of problem:
Attempt to remove LV to be created, results in crash

Version-Release number of selected component (if applicable):
python-blivet-0.18.7-1

How reproducible:
I have seen this second time.

Steps to Reproduce:
1. select "LVM thin" profile
2. click link to create default layout on free disks
3. try to remove fedora-root thin LV

Actual results:
Crash in anaconda

Expected results:
LV should be removed

Additional info:
Proposing as Beta Blocker as not meeting following Custom Partitioning requirement:

When using the custom partitioning flow, the installer must be able to:
- Remove a planned storage volume from the planned layout

--- Additional comment from Marian Csontos on 2013-10-22 05:48:46 EDT ---

Update:
Reproducible: 4/4

More accurate steps:
1. Select "I want to review/modify my disk..."\
2. Change Partition scheme to "LVM Thin Provisioning"
3. Continue
4. In "New Fedora 20 Installation" click "Click here to create them automatically"
5. Select / (fedora-root) and "-" to remove

Works fine for /boot (partition) and swap (which is plain (linear) LV)

--- Additional comment from David Lehman on 2013-10-22 11:47:52 EDT ---

I am using TC5 (anaconda-20.25.1-1) and have been unable to reproduce the reported failure. Please try with TC5 and see if the problem persists.

--- Additional comment from Marian Csontos on 2013-10-23 03:29:04 EDT ---

Still the same I think - opened BZ 1022366 so abrt catches duplicates.

--- Additional comment from Marian Csontos on 2013-10-23 03:29:32 EDT ---



--- Additional comment from Marian Csontos on 2013-10-23 07:51:53 EDT ---

When I created other mountpoints (thin LV) those could be removed.
I removed swap on the VG and then removed root LV just fine.

I created LV /home and thin-LV /, attempt to remove / resulted in crash.

Seems that happens only when there are other non-thin LVs.

--- Additional comment from David Lehman on 2013-10-23 12:09:45 EDT ---

I was able to reproduce it. It happens when you remove the last thin lv from a new/non-existent pool. I'm testing a patch.

--- Additional comment from David Lehman on 2013-10-23 12:12:13 EDT ---

My test of the patch was successful. Please try it for yourself to verify:

  http://dlehman.fedorapeople.org/updates/updates-1021890.0.img

Thanks.
Comment 2 Ľuboš Kardoš 2014-03-12 09:12:34 EDT
Verified on python-blivet-0.18.31-1 (RHEL-7.0-20140305.0).
Comment 3 Ludek Smid 2014-06-13 07:41:33 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.