Bug 1021957 - Anaconda does not start when thin volumes already exist on disk
Anaconda does not start when thin volumes already exist on disk
Status: CLOSED DUPLICATE of bug 1013800
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-10-22 08:06 EDT by Marian Csontos
Modified: 2013-10-22 11:04 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-22 11:04:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda logs (37.46 KB, application/octet-stream)
2013-10-22 10:49 EDT, Marian Csontos
no flags Details

  None (edit)
Description Marian Csontos 2013-10-22 08:06:44 EDT
Description of problem:
I have thin pool with thin volumes (existing linux installation)

Version-Release number of selected component (if applicable):
20.25-1

How reproducible:
100%

Steps to Reproduce:
1. start anaconda on disk which already contains thin-pool with thin volumes

Actual results:
Anaconda does not start.
Nothing logged on console.

Proposing as beta blocker though I am not sure which requirement is the best match, I guess following alpha may apply:

> Installer must run
> 
> - The installer must run when launched normally from the release-blocking images.


Expected results:
Anaconda should start (and report issues, if there are any.)
If there is any unhandled expection in anaconda, it should be reported on text console.

Additional info:
Starting anaconda in text mode raises TypeError: __init__() got an unexpected keyword argument 'segType' exception:

===============================================================================
An unknown error has occurred
===============================================================================
anaconda 20.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1304, in handleVgLvs
    exists=True)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1404, in handleUdevLVMPVFormat
    self.handleVgLvs(vg_device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1691, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1075, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1916, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 1860, in populate
    self._populate()
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 417, in reset
    self.devicetree.populate(cleanupOnly=cleanupOnly)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 144, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
TypeError: __init__() got an unexpected keyword argument 'segType'
Comment 1 David Lehman 2013-10-22 10:38:51 EDT
Please -- always -- attach the /tmp/anaconda-tb-* file when reporting an anaconda crash. Thanks.
Comment 2 Marian Csontos 2013-10-22 10:49:02 EDT
Created attachment 815026 [details]
anaconda logs
Comment 3 Marian Csontos 2013-10-22 10:50:45 EDT
BTW, it does display "Report bug" dialog for a while, but X get's SIGCHLD soon after that.
Comment 4 David Lehman 2013-10-22 11:04:44 EDT
This was fixed along with bug 1013800.

*** This bug has been marked as a duplicate of bug 1013800 ***

Note You need to log in before you can comment on or make changes to this bug.