Bug 1013800 - devicetree.py:1293:handleVgLvs:DeviceTreeError: failed to look up thin pool
devicetree.py:1293:handleVgLvs:DeviceTreeError: failed to look up thin pool
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:17cb21e07b94340e1b641ff2e20...
:
: 1021957 (view as bug list)
Depends On: 1020111
Blocks: F20BetaBlocker 1016842
  Show dependency treegraph
 
Reported: 2013-09-30 15:42 EDT by Chris Murphy
Modified: 2013-10-27 03:48 EDT (History)
16 users (show)

See Also:
Fixed In Version: anaconda-20.25.1-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1016842 (view as bug list)
Environment:
Last Closed: 2013-10-22 01:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (376 bytes, text/plain)
2013-09-30 15:42 EDT, Chris Murphy
no flags Details
File: os_info (291 bytes, text/plain)
2013-09-30 15:42 EDT, Chris Murphy
no flags Details
anaconda-tb (336.31 KB, text/plain)
2013-09-30 15:49 EDT, Chris Murphy
no flags Details
journalctl -b (406.68 KB, text/plain)
2013-09-30 15:49 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-09-30 15:42:21 EDT
Description of problem:
Crash on launch. Existing system is F20alpha with LVM Thin Provisioning set as the partitioning scheme.

Version-Release number of selected component:
anaconda-20.20-1.fc20

Additional info:
cmdline:        /usr/bin/python /usr/bin/anaconda-cleanup anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
dso_list:       python-blivet-0.22-1.fc20.noarch
executable:     /usr/bin/anaconda-cleanup
kernel:         3.11.0-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0
Comment 1 Chris Murphy 2013-09-30 15:42:25 EDT
Created attachment 805498 [details]
File: environ
Comment 2 Chris Murphy 2013-09-30 15:42:29 EDT
Created attachment 805499 [details]
File: os_info
Comment 3 Chris Murphy 2013-09-30 15:49:14 EDT
Created attachment 805500 [details]
anaconda-tb
Comment 4 Chris Murphy 2013-09-30 15:49:24 EDT
Created attachment 805501 [details]
journalctl -b
Comment 5 Chris Murphy 2013-09-30 15:55:19 EDT
Is reproducible. Could be related to bug 1013767 "rootfs on thinp not found, startup failure" in which a successful installation using LVM Thin Provisioning fails to boot.

Proposing as beta blocker: When using the guided partitioning flow, the installer must be able to reject or disallow invalid disk and volume configurations without crashing.
Comment 6 Mike Ruckman 2013-10-02 15:52:07 EDT
Discussed this in the 2013-10-02 Blocker Review Meeting [1]. This has been voted an AcceptedBlocker. This violates the following F20 beta release criterion for LVM thinp: "When using the guided partitioning flow, the installer must be able to ... Complete an installation using any combination of disk configuration options it allows the user to select" [2].


[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-02/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Guided_partitioning
Comment 7 David Lehman 2013-10-04 19:00:55 EDT
I have a fix for this bug, but in working on this I found a change in the way lvm lays things out for thinp setups. I'm not going to post the patch until it includes handling for the lvm change as well, which will have to wait until I can speak with the lvm team on Monday.
Comment 8 Tim Flink 2013-10-09 14:50:09 EDT
This shouldn't be blocking F20 beta, removing depends on and AcceptedBlocker
Comment 9 Tim Flink 2013-10-09 14:51:50 EDT
This shouldn't be blocking F20 beta, removing depends on and AcceptedBlocker(In reply to Tim Flink from comment #8)
> This shouldn't be blocking F20 beta, removing depends on and AcceptedBlocker

And I just modified the wrong bug. Replacing AcceptedBlocker and blocks. Sorry for the noise
Comment 10 Adam Williamson 2013-10-11 05:40:09 EDT
dlehman: any news on this one? Did you get in touch with LVM team?
Comment 11 Adam Williamson 2013-10-16 14:45:40 EDT
Discussed at 2013-10-16 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-16/f20beta-blocker-review-4.2013-10-16-16.02.log.txt .

<dlehman> adamw: I have a patch for it. it's been reviewed and all.
Comment 12 Fedora Update System 2013-10-16 20:29:27 EDT
anaconda-20.25.1-1.fc20, python-blivet-0.23.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-blivet-0.23.1-1.fc20,anaconda-20.25.1-1.fc20
Comment 13 Chris Murphy 2013-10-16 23:45:47 EDT
Applied those updates. Crash. Bug 1020111.
Comment 14 Fedora Update System 2013-10-17 16:31:03 EDT
Package anaconda-20.25.1-1.fc20, python-blivet-0.23.1-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-20.25.1-1.fc20 python-blivet-0.23.1-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19194/python-blivet-0.23.1-1.fc20,anaconda-20.25.1-1.fc20
then log in and leave karma (feedback).
Comment 15 Kamil Páral 2013-10-21 02:43:23 EDT
Fixing status per comment 13.
Comment 16 Fedora Update System 2013-10-22 01:38:06 EDT
anaconda-20.25.1-1.fc20, python-blivet-0.23.1-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 David Lehman 2013-10-22 11:04:44 EDT
*** Bug 1021957 has been marked as a duplicate of this bug. ***
Comment 18 Chris Murphy 2013-10-27 03:48:07 EDT
Working with Fedora-20-Beta-TC6-x86_64-DVD.iso (install and reboot to the installer, no crash).

Note You need to log in before you can comment on or make changes to this bug.